Download it now!
Bug 57930 - Intermittant freeze in splash screen when starting with a file to open
Summary: Intermittant freeze in splash screen when starting with a file to open
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-06 00:22 UTC by jwoithe
Modified: 2013-10-28 01:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
gdb thread info for the oosplash process during the freeze (2.00 KB, text/plain)
2012-12-06 00:23 UTC, jwoithe
Details
gdb thread info for the soffice.bin process during the freeze (9.88 KB, text/plain)
2012-12-06 00:24 UTC, jwoithe
Details
strace output during a run which ended with the freeze (1.07 MB, text/plain)
2012-12-06 00:25 UTC, jwoithe
Details
For comparison, strace output when libreoffice runs and is exitted normally (2.51 MB, text/plain)
2012-12-06 00:26 UTC, jwoithe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jwoithe 2012-12-06 00:22:10 UTC
A number of my Linux users are having Libreoffice freeze during the splash screen on an intermittant basis (that is, the splash screen freezes up before the progress bar has completed its move to the right, and no other Libreoffice windows appear).  It has been determined that this only happens if they are starting Libreoffice with a file to open (eg: from the command line with "swriter foobar.odt" or double-clicking on an ODT file in a file manager environment).  However, the fault does not occur every time this is done.  It's hard to estimate the frequency, but my first order guess would be perhaps one in every 20 starts.  If Libreoffice is started without a file to open (eg: from the command line with "swriter" or via a desktop icon) the fault does not seem to be triggered.  Similarly, opening a file when any component of Libreoffice is already running successfully also does not trigger the bug in our experience.

Attempting to open other documents with Libreoffice when the fault condition is present is unsuccessful; unsurprisingly they appear to be blocking until the first instance has started correctly.

This problem has most recently been observed in the Libreoffice 3.6.2 release.  We have been observing it at least since 3.5.0.

The bug appears to be far easier to trigger if the file being opened resides on an NFS volume.

Libreoffice quickstart is not running on the affected system.

I have tried various hacks to work around this but they all fail to prevent the intermittant freeze.  Firstly, in the soffice script SAL_ENABLE_FILE_LOCKING was set to 0.  We then tried with it undefined.  The SAL_NO_XINITTHREADS line in the soffice script was commented out but again the fault recurred.  Finally, oosplash was made into a symlink to soffice.bin.  Curiously the splash screen was still shown, and disappointingly the intermittant fault sill occured when this was in place.

The system on which this fault has been observed the most is a stock 32-bit Slackware 13.1 Linux distribution (2 GB RAM, Pentium D (dual core) at 3.4 GHz, Intel 82945G/GZ integrated graphics, intel Xorg driver, 2.6.33.4 kernel, xfce4 desktop).  However, it has also been seen on a PC running 32-bit Slackware 13.37 (1 GB RAM, Athlon XP CPU at 2 GB, Nvidia GeForce2 MX graphics, Nouveau Xorg drivers, 3.6.3 kernel, fvwm2 window manager, libreoffice started only from command line).

At the time of the freeze there are two processes running: oosplash and soffice.bin.  The attachments gdb_info-oosplash and gdb_info-soffice provide thread information about both these processes as recorded during a freeze.  I have tested through strace, and will attach an trace from a working (strace-ok.log) and frozen (strace-freeze.log) invocation so long as I don't run into size limitations.  All these attachments were recorded while using Libreoffice 3.5.5.

Finally, this may or may not be related to bug 50686.  The description offered in that bug suggests that the problem in bug 50686 is a freeze or immediate quit, with no "normal" behaviour being observed.  We are not seeing any spontaneous application exits and the issue we're seeing is intermittant, so I expect 50686 is a different issue.
Comment 1 jwoithe 2012-12-06 00:23:34 UTC
Created attachment 71063 [details]
gdb thread info for the oosplash process during the freeze
Comment 2 jwoithe 2012-12-06 00:24:23 UTC
Created attachment 71064 [details]
gdb thread info for the soffice.bin process during the freeze
Comment 3 jwoithe 2012-12-06 00:25:23 UTC
Created attachment 71065 [details]
strace output during a run which ended with the freeze
Comment 4 jwoithe 2012-12-06 00:26:36 UTC
Created attachment 71066 [details]
For comparison, strace output when libreoffice runs and is exitted normally
Comment 5 Joel Madero 2013-07-02 05:40:20 UTC
Thanks for all the useful info - is this still an issue with version 4? If so I'll seek additional input from some experienced developers to see what we can do about it.

Marking as NEEDINFO - just confirm that it still is an issue in version 4, mark as UNCONFIRMED and I will get the appropriate people involved.


Thanks!
Comment 6 jwoithe 2013-07-03 01:45:07 UTC
About 2 months ago I upgraded most of the affected users to 4.0.2 (the 4.0.x version current at the time), mostly as part of an ongoing attempt to address the freezing splash screen problem.  Prompted by comment 5 I have attempted to contact the users to ask whether they have observed the splash screen freeze since the upgrade.  I am still waiting to hear back from some, but those who have replied (including one heavy user) do not think the problem has occurred with 4.0.2.  I personally have not experienced it with 4.0.x (but I don't use it that much so this observation in isolation doesn't say much).

I will continue to collect feedback over the next week and post a final reply once it's all in.  Based on the evidence I have so far it appears that maybe 4.0.x is clear of the problem (or that other changes have just made it much less likely to occur).  However, I would like to get feedback from all my users first before calling this.
Comment 7 jwoithe 2013-10-28 00:19:08 UTC
Thanks for the patience while I have been checking this issue out over the last few months.  I have now had a vast majority of the affected users running some variation of Libreoffice 4.x for at least 4 months (some longer).  In this time I have not had a report of the frozen splash screen, and in speaking to the users I am being told that they have not seen it since their system was updated.  In addition, I also have not seen the problem occur since I moved to 4.x.

Based on these observations I conclude that the problem does not exist in Libreoffice 4.x.  It definitely existed in 3.5.x and 3.6.x, so either the bug was addressed during the leadup to 4.0 or it was inadvertently fixed during other work.  I suspect the latter.

From my point of view this bug can be closed as "Resolved" - upgrading to Libreoffice 4.0 or later fixes the problem.
Comment 8 Joel Madero 2013-10-28 01:06:26 UTC
Thanks for the update - putting it in appropriate status (WFM) as we don't know what patch fixed it. Thanks again!