Bug 58019 - UI: Options dialog in translations with many wrong strings because of missing string for Personalization
Summary: UI: Options dialog in translations with many wrong strings because of missing...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
: 58153 (view as bug list)
Depends on:
Blocks: 58025
  Show dependency treegraph
 
Reported: 2012-12-08 15:26 UTC by Rainer Bielefeld Retired
Modified: 2012-12-16 21:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Compare English and German UI (168.07 KB, image/png)
2012-12-08 15:26 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-08 15:26:33 UTC
Created attachment 71202 [details]
Compare English and German UI

Steps how to reproduce [Reproducible] with parallel installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID:d6579884752c298a18b7cdfcc7d1614b55c9c7c)]"  {tinderbox: Win-x86@6, pull time 2012-12-06 02:46:58} on German WIN7 Home Premium (64bit) with own separate User Profile:

1. Launch LibO wiht German UI from LibO Start Center Menu 'Tools -> Options -> 
   LibO-Dev'
2. For Comparion, Launch LibO server installation of same version with english UI 
3. Compare

You will that the menu structure is identical until 'Security'. Behind that you will find 5 Items in the English UI, but only 4 ones in the German UI. There is no Item for "Personalization. So from now on in German UI the Menu item strings do not match with the function:

Darstellung (=Appearance) leads to 'Personllization'
Zugänglichkeit (=Accessibility) leads to 'Appearance'
Erweitert (=Acvanced) leads to 'Accessibility'
Online Update leads to 'Acvanced'

Function 'Online Update' can not be reached
Comment 1 Rainer Bielefeld Retired 2012-12-08 15:29:08 UTC
I see the same in Spanish UI, I think all translated UI are affected.
Comment 2 Andras Timar 2012-12-08 19:13:38 UTC
@Rainer, this is a temporary problem, translations are out of sync. We had this problem in earlier versions (in 3.3 for sure), later I prevented it by filling language sdf files with en-US strings, when a translation was missing. Now sdf files are no more, so we need a real fix in l10ntools.

@Tamas, this is what we were talking about today, missing list item translations lead to visible UI errors.
Comment 3 Andras Timar 2012-12-11 17:48:41 UTC
*** Bug 58153 has been marked as a duplicate of this bug. ***
Comment 4 Roman Eisele 2012-12-15 11:06:23 UTC
Definitely a cross-platform issue -- also reproducible with 4.0.0.0beta1 on Mac OS X (10.6.8, Intel), with German langpack installed.