Bug 58027 - EDITING increases height of integrated Text box with rounded corners and gradient color fill
Summary: EDITING increases height of integrated Text box with rounded corners and grad...
Status: RESOLVED DUPLICATE of bug 83159
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-08 18:03 UTC by Rainer Bielefeld Retired
Modified: 2015-06-25 01:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (15.79 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2012-12-08 18:12 UTC, Rainer Bielefeld Retired
Details
how it looks in master and how it looks after moving the chart (112.80 KB, image/png)
2015-04-13 22:51 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-08 18:03:18 UTC
Francisco found this bug in "Bug 39052 - FORMATTING single characters in titles, axis titles and other labels is not possible"

Steps  how to reproduce with "LibreOffice 3.6.4.3" German UI/ German Locale [Build-ID: 2ef5aff] {pull date 2012-11-28} on German WIN7 Home Premium (64bit):

1. Open attached Sample document from LibO Start center
2. Double Click Chart to get Chart edit mode, observe green 
   "This is the Text Box Title" with gradient
   Bug: Box height increases to 3 times height after double click
        The modification is enduring after edit mode has been lost

New for LibO 3.6 due to  Attachment 71210 [details] Details for Bug 39052
Comment 1 Rainer Bielefeld Retired 2012-12-08 18:12:19 UTC
Created attachment 71214 [details]
Sample document
Comment 2 Francisco 2014-05-18 15:10:36 UTC
@Joren

I have been able to reproduce this bug without any formatting in the textbox. I mean, it is _not_ necessary to add a gradient nor round corners to the textbox to see the bug.
Comment 3 Yousuf Philips (jay) (retired) 2015-04-13 22:51:06 UTC
Created attachment 114770 [details]
how it looks in master and how it looks after moving the chart

So i tested it in master and the shows up with large letters when opened and after being in edit mode and moving the chart, the letters change size. Seems like some thing fishy is being set in the fonts of the textbox which is effecting the size of the textbox.

Version: 4.5.0.0.alpha0+
Build ID: b024e36ddb3b53163d7a01f6f7b5aadb7a858cd9
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-31_08:18:46
Comment 4 Francisco 2015-06-25 01:48:40 UTC

*** This bug has been marked as a duplicate of bug 83159 ***