Bug Hunting Session
Bug 58068 - Localization broken in master
Summary: Localization broken in master
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
: 58120 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-10 05:41 UTC by Jean-Baptiste Faure
Modified: 2012-12-17 17:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2012-12-10 05:41:21 UTC
Hi,

The localization seems to be broken in the master and LO 4.0 beta1+
Symptom: in French UI the main menu and its submenus are still in English. Others dialogs are in French, for example Options, character or paragraph formatting, etc.

No such problem on beta1.

Test done on my own build of the master (Build ID: 782c243045a1c7ee95b2d7ea6bca64812a9049e) and before on LO 4.0.0.0beta1+ (last commit: http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-0&id=9fc3adb2f0163bc9f00e764792049fd6df049255)
OS: Ubuntu 12.04 x86_64 with gnome-shell

My autogen.lastrun:
--without-junit
--enable-ext-presenter-minimizer
--with-lang=en-US fr
--enable-graphite
--with-system-cairo
--without-doxygen
--enable-ext-nlpsolver
--with-system-openssl
--disable-neon
--with-system-openldap
--with-parallelism=2
--enable-python=internal

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2012-12-10 05:43:44 UTC
Hi Andras

Do you confirm and have an idea of what went wrong?

Best regards. JBF
Comment 2 Andras Timar 2012-12-10 16:19:03 UTC
Somehow share/registry/res/registry_fr.xcd is too small, translations are missing. I need to find out, why.
Comment 3 Andras Timar 2012-12-10 16:51:53 UTC
Warning : /home/timar/libreoffice-master/translations/source/fr/officecfg/registry/data/org/openoffice/Office/UI.po has invalid header
This is the root cause of the bug. We need to make our tools more fault tolerant. Fixing the French po files is another option, but it would be better to fix the tools.
Comment 4 Andras Timar 2012-12-10 17:25:28 UTC
I fixed the invalid headers.
Comment 5 Jean-Baptiste Faure 2012-12-10 20:39:13 UTC
Works as expected in master (Build ID: c74fe188b178fab821084bb82d4574f77dc2e1c)
Thank you very much, Andras. :-)

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2012-12-11 09:40:28 UTC
*** Bug 58120 has been marked as a duplicate of this bug. ***
Comment 7 Petr Mladek 2012-12-17 17:19:39 UTC
There were more broken headers after updating strings for 4.0.0.0.beta2 release. Fixed by
http://cgit.freedesktop.org/libreoffice/translations/commit/?h=libreoffice-4-0
Comment 8 Petr Mladek 2012-12-17 17:27:20 UTC
(In reply to comment #7)
> There were more broken headers after updating strings for 4.0.0.0.beta2
> release. Fixed by
> http://cgit.freedesktop.org/libreoffice/translations/commit/?h=libreoffice-4-
> 0

Ah, this was not needed. In the meantime, it has been fixed a better way, see
https://gerrit.libreoffice.org/gitweb?p=core.git;a=commit;h=d684056f9a7e75fa73439277bdda16aec2da0e46