Download it now!
Bug 58173 - PDF import does not handle rotated text correctly
Summary: PDF import does not handle rotated text correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 64664 (view as bug list)
Depends on:
Blocks: PDF-Import-Draw
  Show dependency treegraph
 
Reported: 2012-12-12 06:51 UTC by Winfried Donkers
Modified: 2016-07-04 06:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF document which opens distorted in draw (30.03 KB, application/vnd.oasis.opendocument.graphics)
2012-12-12 06:51 UTC, Winfried Donkers
Details
another PDF document that opens with incorrect rotated text (125.04 KB, application/pdf)
2013-12-12 11:53 UTC, Winfried Donkers (retired)
Details
Screenshot with LO Draw 4.3.0 (111.71 KB, image/png)
2014-07-14 13:42 UTC, Alexandr
Details
screenshot with LO 4.4.4.3 (42.50 KB, image/gif)
2015-07-20 06:05 UTC, Winfried Donkers (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2012-12-12 06:51:17 UTC
Created attachment 71380 [details]
PDF document which opens distorted in draw

When opening a PDF-file in draw with text that is upside down (rotated 180 degrees), this text is shown with each character in place, but not rotated.
See attachment. The calendar is rotated, but does not shown correctly at all and neither does the exported PDF.
Comment 1 Winfried Donkers (retired) 2013-12-12 11:53:37 UTC
Created attachment 90660 [details]
another PDF document that opens with incorrect rotated text

Problem still there with version 4.1.3.2
Comment 2 Winfried Donkers (retired) 2013-12-12 11:56:26 UTC
4.3.0.0.alpha+ on Linux has the same problem.
Comment 3 Alexandr 2014-07-14 13:42:06 UTC
Created attachment 102772 [details]
Screenshot with LO Draw 4.3.0

> this text is shown with each character in place, but not rotated.

In LibreOffice 4.3.0.2 the text is displayed opposite way: the characters are rotated, but misplaced.
Comment 4 Winfried Donkers (retired) 2014-07-15 10:36:44 UTC
(In reply to comment #3)
> Created attachment 102772 [details]
> In LibreOffice 4.3.0.2 the text is displayed opposite way: the characters
> are rotated, but misplaced.

Same for 4.4.0.0alpha+.
At least we can say that there is some improvement since 3.6 ;-)
Comment 5 QA Administrators 2015-07-18 17:43:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 6 Winfried Donkers (retired) 2015-07-20 06:05:59 UTC
Created attachment 117334 [details]
screenshot with LO 4.4.4.3

Problem still occurring with version 4.4.4.3 (Windows 7).
Comment 7 Heiko Tietze 2016-05-09 15:15:39 UTC
Confirmed

Version: 5.2.0.0.alpha0+
Build ID: 6b232aeecc55f1715bc111e636e36a8e24827efb
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-26_07:40:04
Locale: de-DE (de_DE)
Comment 8 Heiko Tietze 2016-05-10 12:33:07 UTC
*** Bug 64664 has been marked as a duplicate of this bug. ***
Comment 9 V Stuart Foote 2016-07-03 23:17:46 UTC
This works correctly (still minor issues of character alignment within the calendar tables) but the rotated text seems to be handled as desired.

On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)
Comment 10 Heiko Tietze 2016-07-04 06:43:46 UTC
Minor issues? Check December. But you are right that a lot has been done, e.g. the January looks much better. And when I create a couple of rotated shapes, export and load from PDF the result is okay (using 5.3 from ~two weeks ago).

Version: 5.3.0.0.alpha0+ (x64)
Build ID: f536a83d51443d19dba58157cea28fb67a090e02
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-06-13_01:19:21
Locale: de-DE (de_DE)