Bug 58236 - FILEOPEN: freeze splash when i try open file located on samba share
Summary: FILEOPEN: freeze splash when i try open file located on samba share
Status: RESOLVED DUPLICATE of bug 67527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-13 09:34 UTC by Terentev Maksim
Modified: 2014-03-21 13:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
part of kern.log (3.96 KB, text/plain)
2012-12-13 09:34 UTC, Terentev Maksim
Details
slog openoffice smb problem (17.79 KB, application/gzip)
2013-01-03 18:01 UTC, Juan David Ruiz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terentev Maksim 2012-12-13 09:34:52 UTC
Created attachment 71435 [details]
part of kern.log

Problem description: 
freeze splash (soffice.bin) when i try open file located on samba share. And i can not to kill it

Steps to reproduce:
1. My Xubuntu starts. And autostart:thunderbird, psi-plus, gigolo(whith automount samba shares), remmina
2. I open gigolo window, open share, click on file (some.ods)
3. Appears libreoffice splash.. that`s all.
4. I trying kill process soffice.bin (as user & as root) but it is.

Current behavior:
Reboot computer. 
I copy file to my computer and open. All fine.
or
reboot, just open libreoffice blank. Then drag&drop file from thunar window. libre ask me password, I enter password and document opens. 
Expected behavior:
I want that file opens with double click
              
Operating System: Ubuntu
Last worked in: 3.3.4 release
Comment 1 Michael Meeks 2012-12-18 22:21:35 UTC
Unusual interaction with the Ubuntu kernel / fuse module - Bjoern - can you chase ?
Comment 2 Michael Meeks 2012-12-18 22:22:53 UTC
What precise version of Ubuntu are you using ? and could you do:

pkill -9 -f soffice.bin
strace -f -ttt -s 256 -o /tmp/slog soffice -writer

and gzip & attach the /tmp/slog as/when it has frozen for a bit ? Thanks ! :-)
Comment 3 Michael Meeks 2012-12-18 22:24:27 UTC
possibly related to bug#58320
Comment 4 Björn Michaelsen 2012-12-18 23:16:20 UTC
taking over, waiting for log ...
Comment 5 Juan David Ruiz 2013-01-03 18:01:03 UTC
Created attachment 72467 [details]
slog openoffice smb problem

Same problem, Ubuntu 12.10, libreoffice 1:3.6.2~rc2-0ubuntu4

I created this slog following instruction in comment #2

Slog from reporter at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1070963
Comment 6 Michael Stahl (CIB) 2013-02-01 13:01:05 UTC
deadlock during startup sounds like bug 33484;
can you try if it still happens in a 4.0 RC2 or later build or
a build from the 3.6 branch that is newer than 3.6.5 release?
Comment 7 Michael Meeks 2013-03-26 16:13:26 UTC
Can you test again with a LibreOffice 4.0.2 pre-release from:

http://www.libreoffice.org/download/pre-releases/

My hope is that this is another dup of bug#54275 or bug#59022 - both fixed there.

Thanks.
Comment 8 Justinas Buckus 2013-04-29 13:03:06 UTC
Hello. Im using Linux Mint 14 Mate. LibreOffice 3.6 right now, but tried with newest version 4.0 and had same problem. With some computers when i try to open any LO Calc or Writer files in samba server LibreOffice freezes during splash screen. Not everytime, sometimes i need to open that file 10 or more times until it freezes. After freeze i cannot kill soffice.bin process it becomes zombie and only reboot helps. I can still open any Calc or Writer files on my computer, but it doesnt start samba. I just noticed that, if i kill process "gvfs-fuse", the "soffice.bin" process dissapears. But after that i need to reboot pc anyway, because samba doesnt work proberly, i get another error if i try to open something.
Comment 9 Justinas Buckus 2013-04-29 13:40:42 UTC
I just managed to avoid rebooting pc. At first i killed oosplash process (libre office splash screen), then unmounted samba server volume, by rightclicking on it on desktop and pressing unmount. soffice.bin process dissapeared and now i can open that file on samba until it freezes again.
Comment 10 Michael Meeks 2013-05-07 09:55:56 UTC
3126  1357235495.356292 connect(3, {sa_family=AF_FILE, path="/tmp/OSL_PIPE_1000_SingleOfficeIPC_29564c0f238622cbf196bdbd1cd3df2"}, 110) = 0
3126  1357235495.377358 getcwd("/home/zuidj", 4096) = 12
3126  1357235495.377474 write(3, "InternalIPC::Arguments1file:///home/zuidj,-writer\0", 50) = 50
3126  1357235495.377543 read(3,  <unfinished ...>
3138  1357235505.351796 <... futex resumed> ) = -1 ETIMEDOUT (Connection timed out)
3138  1357235505.351887 gettimeofday({1357235505, 351902}, NULL) = 0

Looks like some IPC evil to the factory process - which is failing to respond.

You'd need to pkill -9 -f soffice.bin before running to get a better strace.

Thanks ! :-)
Comment 11 Björn Michaelsen 2013-09-01 15:23:16 UTC
possible another fallout from fdo bug 67527?
Comment 12 Stephan Bergmann 2013-09-02 09:21:47 UTC
(In reply to comment #11)
> possible another fallout from fdo bug 67527?

Sounds very much like <https://bugzilla.redhat.com/show_bug.cgi?id=885156> "Libreoffice locks up when opening Microsoft Office file over SMB share," where LO locks up when it is called with a /run/user/*/gvfs/smb-share:... pathname rather than an smb:... URL.
Comment 13 Björn Michaelsen 2014-03-21 13:41:49 UTC
Closing remaining issues as dupe of 67527.

*** This bug has been marked as a duplicate of bug 67527 ***