Download it now!
Bug 58320 - FILEOPEN: Open a spreadsheet (ODS) in 4.0.0.0.beta1 on SMB server fails
Summary: FILEOPEN: Open a spreadsheet (ODS) in 4.0.0.0.beta1 on SMB server fails
Status: RESOLVED DUPLICATE of bug 54275
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-15 01:53 UTC by John Ervin
Modified: 2013-03-26 16:11 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of error message (9.67 KB, image/png)
2012-12-15 01:53 UTC, John Ervin
Details
This is the file that fails with 4.0.0.beta1 but not with 3.6.4.3 (94.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-15 04:19 UTC, John Ervin
Details
Error I get when I tried to use lodev4.0 under Ubuntu 12.04 (14.33 KB, image/png)
2012-12-19 15:10 UTC, John Ervin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Ervin 2012-12-15 01:53:56 UTC
Created attachment 71531 [details]
Screenshot of error message

Problem description: 

Steps to reproduce:
1. brought up Calc v4.0.0.0.beta1
2. selected open and drilled down to my file successfully
3. clicked on open 

Current behavior:
Expected file to open into spreadsheet
Expected behavior:
Got error message General Error. General input/output error.

Ubuntu 12.10

              
Operating System: Ubuntu
Last worked in: 3.6.4.3 release
Comment 1 Urmas 2012-12-15 03:21:25 UTC
Please attach this file.
Comment 2 John Ervin 2012-12-15 04:19:53 UTC
Created attachment 71532 [details]
This is the file that fails with 4.0.0.beta1 but not with 3.6.4.3

This the file (among others) that gives me the error when I try to load it.  I have removed and re-added lo 4.0.0.beta1 and the problem persists.  I can open the file with lo 3.6.4.3 with no problems.
Comment 3 Korrawit Pruegsanusak 2012-12-16 11:15:00 UTC
NOT reproducible on Windows 7 x64. The file can open with both official 3.6.3.2 and 4.0.0.0.beta1, both opening from start center and from new blank spreadsheet.

Linux specific bug? Or any specific method of file open?

John, thanks for reporting this bug :) Could you please tell us more about how do you open this file, as much details as possible? (any clicks, any keyboard buttons, etc)

Also, where did you get 4.0.0.0.beta1? From PPA, or from LibreOffice website?
Comment 4 John Ervin 2012-12-16 13:16:13 UTC
The file fails regardless of how I try to open it.  I can go to nautilus file manager, right click on the file and select Calc 4.0, I can go to the nautilus file manager and double click on it, I can go to the Unity menu and select either Calc 4.0 or the Main page and select Calc 4.0.

I downloaded the file from the Test Marathon website.  http://www.libreoffice.org/download/pre-releases

My ubuntu is pretty up to date, at 12.10 level with all maintenance regularly installed.
Comment 5 Werner 2012-12-16 13:36:59 UTC
NOT reproducible on Ubuntu 12.10 with Version 4.0.0.0.alpha1+ (Build ID: ce90f99a2d66c2b998ad3f9f028e2ea623a757f) and Version 4.1.0.0.alpha0+ (Build ID: 8450a99c744e9005f19173e4df35d65640bcf5c).
Comment 6 Korrawit Pruegsanusak 2012-12-16 13:51:28 UTC
John, how did you install LibreOffice? May I suggest you to reset your user profile, following http://wiki.documentfoundation.org/UserProfile and try to open the file again? If resetting helps, could you please attach your old user profile here?

Anyway, I'm not sure where is the user profile for this 4.0beta1 ... If you install in parallel, look in program/bootstraprc file for UserInstallation line. But if you didn't install in parallel, maybe it's in ~/.config/lodev ... (?)
Comment 7 John Ervin 2012-12-17 02:36:35 UTC
with LOdev4 down, I renamed both my lodev and libreoffice config files.  I brought up lodev4 calc and tried to access the same file.  Same error.

Btw, the profile was in ~/.config/lodev/ or ~/.config/libreoffice
from /opt/lodev4.0/program/bootstraprc:
UserInstallation=$SYSUSERCONFIG/lodev/4
Comment 8 John Ervin 2012-12-17 02:37:47 UTC
Shall I try to uninstall and re-install it from a fresh deb file?
Comment 9 Michael Meeks 2012-12-17 22:03:23 UTC
How strange; I can't reproduce with master - loads fine (albeit very green ;-) for me; does the problem recur when you remove & re-install the .debs ? it is possible there is some un-related horrible dependency problem, can you install the gnome-vfs package (a stab in the dark).
Comment 10 John Ervin 2012-12-17 23:32:25 UTC
I removed lodev4.0 entirely.  Updated my files with libreoffice 3.6, downloaded and reinstalled lodev4.0 and attempted to access my .ods file again.  Same error.
Comment 11 Michael Meeks 2012-12-18 10:08:34 UTC
Any chance you can try with a build from:

http://dev-builds.libreoffice.org/daily/libreoffice-4-0/Linux-x86_10-Release-Configuration/current/

That should be effectively beta-2 by now; if that fails then we have a strange Debian-specific issue I think.
Comment 12 John Ervin 2012-12-18 13:43:35 UTC
Nope, didn't work.  It's odd how a xlxs file that was created a couple of weeks ago that is almost identical to the ods file will open, but the ods file get's the error.  I'm going to regress to 3.6, take that xlxs convert it back to an ods file and see if an identical ods file has the same problem still.  

Hmm, OK an odd thing happened.  I put the smoketest file on and the problem persisted.  I switched back to 3.6 (meant switched desktop environment debs) and opened the bad file and created an xlxs file from it.  I switched back to lodev4.0 (with smoketest) and opened the xlxs file (no problem) then I was able to open the bad file with lodev4.0.

So to test this, I will download the bad file that I uploaded and see if there is a problem, nope it opened the file no problem.  I think I'll remove the smoketest file and see if that breaks it. Nope.

Here's the weird thing.  I original bad file still fails, but the one I uploaded and downloaded works.  Let me just copy the file and see if the copy works. OK it failed if I just copied it into the same subdir but it worked when I copied it to another subdir.  I'm wondering if this is more of a Ubuntu problem?
Comment 13 John Ervin 2012-12-18 13:51:47 UTC
OK, it seems to be somehow subdirectory related, when I copied the file to my desktop, it worked, but when I copied the file back to my subdirectory it failed again as an ods file, but the xlxs version always worked.
Comment 14 Michael Meeks 2012-12-18 14:06:22 UTC
> OK, it seems to be somehow subdirectory related, when I copied the file
> to my desktop, it worked, but when I copied the file back to my
> subdirectory it failed again as an ods file, but the xlxs version
> always worked.

more and more interesting ;-) you're not by any chance introducing a load of meta-characters into your sub-directory name ':'s and the like ? ;-) It'd be great to know what subdirectory path - both absolute and relative from where you launch soffice ../../foo-to-path.ods is.

Glad we're getting somewhere here; thanks !
Comment 15 John Ervin 2012-12-18 19:53:12 UTC
Let's see, I think the file in questions is:

a) a mounted file system that lives on a Windows XP SP2 system
b) to access it on my Ubuntu box it's at:
   /home/jervin/mount/cft/PDACFT/Nissan.ods

I hadn't considered that it might be a samba problem.  when I moved it, it was on my desktop which is not a remote/mounted file system.
Comment 16 Markus Mohrhard 2012-12-18 20:18:40 UTC
See also Bug 58236 for another problem with samba.
Comment 17 Michael Meeks 2012-12-18 22:24:01 UTC
Any chance you can try the same build on an older Ubuntu; as Markus says it does look a little like that other bug. Can you do:

pkill -9 -f soffice.bin
strace -f -s 256 -ttt -o /tmp/slog soffice -writer

and gzip & attach /tmp/slog as/when the file open fails ? it would be nice to have some 'mount' output, and (if you're using it) details on your FUSE version / file-system setup.

Thanks ! :-)
Comment 18 John Ervin 2012-12-18 23:25:32 UTC
I hesitate to mention, but I don't seem to have the other problem from Bug 58236 but I do have an Ubuntu 12.04 system that I can use.
Comment 19 John Ervin 2012-12-18 23:30:49 UTC
I see the instructions: 
\/ \/ \/ \/ \/ \/ \/ \/ \/ \/
pkill -9 -f soffice.bin
strace -f -s 256 -ttt -o /tmp/slog soffice -writer

and gzip & attach /tmp/slog as/when the file open fails ? it would be nice to   have some 'mount' output, and (if you're using it) details on your FUSE version / file-system setup.\
/\ /\ /\ /\ /\ /\ /\ /\ /\ /\

I'll give them a shot on the new machine.  Don't actually know what FUSE is.
Comment 20 John Ervin 2012-12-19 15:10:00 UTC
Created attachment 71809 [details]
Error I get when I tried to use lodev4.0 under Ubuntu 12.04

Tried to add the lodev4.0 on Ubuntu 12.04 but got the attached error message.  Seems to balk at accessing a module called something like ucpgvfs1.uno.so
Comment 21 Michael Meeks 2012-12-19 15:31:57 UTC
Another instance of the gnome-vfs monstrosity - Fridrich, I hope you're prepped for discussing that at ESC tomorrow :-)

I'd really love to switch that for GIO in the RHEL5 build - but that will need some new / clean conditional / separation of the dbus-menu code I guess (?)
Comment 22 Björn Michaelsen 2012-12-19 17:50:11 UTC
does https://bugs.freedesktop.org/show_bug.cgi?id=58052#c13 solve this?
Comment 23 John Ervin 2012-12-19 19:00:27 UTC
12.10 Systems says that I already have libbonobo2-0 at most current level.
Comment 24 John Ervin 2012-12-19 19:05:22 UTC
on 12.04 I didn't have libbonobo2.0 installed, I installed it but it didn't resolve that 12.04 issue.
Comment 25 Björn Michaelsen 2012-12-19 19:12:29 UTC
do you get any 'not found' from "ldd /opt/lodev4.0//program/ucpgvfs1.uno.so"?
https://bugs.freedesktop.org/show_bug.cgi?id=58052#c11
Comment 26 Michael Stahl (CIB) 2013-02-01 13:04:24 UTC
this sounds like the same problem as bug 59022
Comment 27 Michael Meeks 2013-03-26 16:11:47 UTC
Quite probably a duplicate of the underlying broken-ness in the gvfs backend Stefan fixed, and/or mst's 59022.

Marking as such; please re-open if 4.0.2 doesn't solve your problem :-)

Thanks for reporting !

*** This bug has been marked as a duplicate of bug 54275 ***