Bug Hunting Session
Bug 58283 - .desktop files miss translations -> LibO descriptions untranslated in application menu
Summary: .desktop files miss translations -> LibO descriptions untranslated in applica...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta3
Hardware: All Linux (All)
: medium major
Assignee: David Tardon
URL:
Whiteboard: target:4.1.0 target:3.6.6 target:4.0.1
Keywords:
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-12-14 12:01 UTC by Mihkel Tõnnov
Modified: 2013-12-11 19:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2012-12-14 12:01:46 UTC
The .desktop files in /opt/lodev3.6/share/xdg (from package "lodev3.6" or "libreoffice3.6") only contain localisation sections for Zulu, no other translations are included for some reason.

Also, the Unity strings "New Document", "New Spreadsheet", etc. (which are included in the same files) are untranslated (or even untranslatable).

Confirmed with DEB x86 and x86-64; the Windows build seems to be unaffected. Can't test the Mac builds.

This was a regression in 3.6.0.0.beta3 (I just tested, 3.6.0.0.beta2 still seemed to have everything it should) and the problem is still present in 3.6.4.3.

(I noticed this only now because previously I had the desktop-integration from 3.5 branch installed.)
Comment 1 Mihkel Tõnnov 2013-01-13 14:36:14 UTC
Translations still missing in 4.0.
Comment 2 Mihkel Tõnnov 2013-01-13 14:36:48 UTC
I mean, 4.0.0 RC 1.
Comment 3 Michael Meeks 2013-02-14 09:14:58 UTC
Andras - any chance you can look into this one ? :-) Much as we love Zulu - it seems like an odd regression ...
Comment 4 Andras Timar 2013-02-14 15:18:12 UTC
regression from b9c376111b7ed3137d7ff72286888e7373487142 - 	rewrite a horrible perl script to saner form ;-)
Comment 5 Not Assigned 2013-02-15 06:37:13 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4a6f1853a2a15b938575406feada108443257536

fdo#58283 produce all translations for desktop files



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Meeks 2013-02-15 09:28:32 UTC
Andras - any chance of back-porting to -4-0 and -3-6 ? :-)
Comment 7 Not Assigned 2013-02-15 10:31:24 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c4d36b7d6da9f9b578d903499844930f90c8faf&h=libreoffice-3-6

fdo#58283 produce all translations for desktop files


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Not Assigned 2013-02-15 10:31:42 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4ed8987530d5b6cf79075937bfb12010f3a02a21&h=libreoffice-4-0

fdo#58283 produce all translations for desktop files


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.