Bug 58309 - Import document with lots of VML shapes crashes
Summary: Import document with lots of VML shapes crashes
Status: RESOLVED DUPLICATE of bug 58267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-14 17:48 UTC by Cor Nouws
Modified: 2012-12-15 08:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
typescript of gdb session (57.34 KB, text/plain)
2012-12-14 23:24 UTC, Terrence Enger
Details
typescript of valgrind run (13.74 KB, text/plain)
2012-12-14 23:45 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-12-14 17:48:26 UTC
Take the vml.docx from here
  http://vmiklos.hu/blog/lo-ooxml-improvements.html :

  http://people.freedesktop.org/~vmiklos/2012/docx-demo/3.6/vml.docx

Try to open in 440beta1
 > crash

(opens reasonably in 3.6.4)
Comment 1 Miklos Vajna 2012-12-14 18:02:13 UTC
Dupe of bug 58267?
Comment 2 Jorendc 2012-12-14 20:14:30 UTC
I can conform with LibreOffice Version 4.0.0.0.beta1 (Build-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37
Mac OSX 10.8.2

Set platform to All?
Comment 3 Jorendc 2012-12-14 20:33:35 UTC
reproduced with Mac OSX 10.8.2 (see comment 2) -> NEW + change platforms to 'all'
Comment 4 Terrence Enger 2012-12-14 23:24:33 UTC
Created attachment 71526 [details]
typescript of gdb session

typescript shows

    SIGSEGV
    info threads
    thread apply all backtrace
    start of backtrace full

from master commit id 7ba2c82, fetched 2012-12-11 around 13:00 UTC,
configured as

    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --without-system-postgresql
    --without-myspell-dicts
    --without-help
    --with-extra-buildid

built and running on ubuntu-natty (11.04) 32-bit

    $ uname -a
    Linux cougar-natty 2.6.38-16-generic #67-Ubuntu SMP Thu Sep 6 18:00:43 UTC 2012 i686 athlon i386 GNU/Linux

    $ gcc --version
    gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
    Copyright (C) 2010 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    $ java -version
    java version "1.6.0_24"
    OpenJDK Runtime Environment (IcedTea6 1.11.5) (6b24-1.11.5-0ubuntu1~11.04.1)
    OpenJDK Client VM (build 20.0-b12, mixed mode, sharing)


In "backtrace full" there a bunch of error messages from gdb or from a
python helper or something.  I do not know whether this is a hint at
the problem or merely a nusiance.

Later, the output looked repetitive, so I cancelled the rest of the
backtrace.
Comment 5 Julien Nabet 2012-12-14 23:42:19 UTC
Miklos: i don't know for 58267 but same stacktrace than fdo#58310
Comment 6 Terrence Enger 2012-12-14 23:45:29 UTC
Created attachment 71528 [details]
typescript of valgrind run
Comment 7 Miklos Vajna 2012-12-15 08:15:50 UTC

*** This bug has been marked as a duplicate of bug 58267 ***