Bug 58310 - FILEOPEN Crash when opening this simple docx file
Summary: FILEOPEN Crash when opening this simple docx file
Status: RESOLVED DUPLICATE of bug 58267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86 (IA32) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 58211 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-14 17:56 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2012-12-15 08:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The document causing the crash (5.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-12-14 17:56 UTC, Samuel Mehrbrodt (allotropia)
Details
GDB Trace log (22.17 KB, text/plain)
2012-12-14 17:58 UTC, Samuel Mehrbrodt (allotropia)
Details
bt on master sources (5.36 KB, text/plain)
2012-12-14 23:35 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2012-12-14 17:56:48 UTC
Created attachment 71516 [details]
The document causing the crash

This file is being opened correctly in LO 3.5.4, but crashes with current master (build from 13.12.12).

I got this file from a MS Word User, edited it with LO 3.5 to remove all private text and there is almost nothing left, so it shouldn't be too hard to find the reason why this crashes.
Comment 1 Samuel Mehrbrodt (allotropia) 2012-12-14 17:58:26 UTC
Created attachment 71517 [details]
GDB Trace log
Comment 2 VX 2012-12-14 19:18:16 UTC
I can open the attached file with LO Writter 4.0.0.0 beta 1 without a crash, but an empty page is displayed (there is no content).

MS Wrord 2007 can't open this file because it claims the file is damaged (there are smoe problems with the content). After restoring the file with MS Word 2007 I can see a green horizontal line on the top. Is this all it contains?
Comment 3 Jorendc 2012-12-14 20:30:26 UTC
Crash with both LO 3.6.4.3 (Bouw-id: 2ef5aff) and Version 4.0.0.0.beta1 (Build-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37
Comment 4 Samuel Mehrbrodt (allotropia) 2012-12-14 22:55:14 UTC
Thanks for confirming.

There is no content. It has a green Textbox and a thin line (displayed by LO 3.5.4).
Comment 5 Julien Nabet 2012-12-14 23:35:05 UTC
Created attachment 71527 [details]
bt on master sources

On pc Debian x86-64 with master sources updated today (commit edf999c3f42cc97a0340cf253a80885a24cedf24), I reproduced this too.
Comment 6 Julien Nabet 2012-12-14 23:35:31 UTC
*** Bug 58211 has been marked as a duplicate of this bug. ***
Comment 7 Julien Nabet 2012-12-14 23:38:31 UTC
Cedric,Michael: one for you? I reproduced this and fdo#58211 seems to be the same case.
Comment 8 Miklos Vajna 2012-12-15 08:14:42 UTC

*** This bug has been marked as a duplicate of bug 58267 ***