Download it now!
Bug 58371 - REPORTBUILDER: abort (unexpected exception thrown) in dbgutil builds when opening report of attachment fdo#48056
Summary: REPORTBUILDER: abort (unexpected exception thrown) in dbgutil builds when ope...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on: 61725 64150
Blocks: Database-Reports-Builder-MAB 58805 64279
  Show dependency treegraph
 
Reported: 2012-12-16 17:44 UTC by Julien Nabet
Modified: 2013-05-06 20:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bt + console logs on master (5.98 KB, text/plain)
2012-12-16 17:44 UTC, Julien Nabet
Details
bt + console logs on 3.6 (5.96 KB, text/plain)
2012-12-16 17:45 UTC, Julien Nabet
Details
Error message Ubuntu 12.10 LO 4.1 latest master (133.84 KB, image/png)
2013-01-09 19:17 UTC, Jorendc
Details
paper over the problem patch (7.27 KB, patch)
2013-04-24 17:23 UTC, Lionel Elie Mamane
Details
console + bt with symbols on master sources (17.50 KB, text/plain)
2013-05-04 06:00 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2012-12-16 17:44:08 UTC
Created attachment 71592 [details]
bt + console logs on master

Problem description: 
On pc Debian x86-64 with master sources updated today (commit 3bbe79eef841ae4a756593557641e32fa28c0184), I had a crash when trying to open the report included in file attached of fdo#48056

Steps to reproduce:
1. Open Lo Base
2. Retrieve file https://bugs.freedesktop.org/attachment.cgi?id=59233
3. Try open the report "Bericht1"

Current behavior:
Crash
Expected behavior:
No crash and open the report
              
Operating System: Debian
Comment 1 Julien Nabet 2012-12-16 17:45:18 UTC
Created attachment 71593 [details]
bt + console logs on 3.6

With 3.6 sources (commit 6e963da804ed6f222a4a6c5f373d7ea6532d75ad), I reproduced this too.
Comment 2 Julien Nabet 2012-12-16 17:47:11 UTC
With 3.5.4.2, I don't have the crash and reproduce what's described in fdo#48056
Comment 3 Jorendc 2013-01-09 19:17:04 UTC
We (Joel Madero) and I can reproduce this using the latest 4.1 version;
NO CRASH, but an error message, and we can't open the report. (see attachment)

Tested with: Ubuntu 12.10, LO build today (Version 4.1.0.0.alpha0+ (Build ID: 92afb61d8bb1b264a945371065115981ecaed0f))
(Joel Madero tested it with Bondhi).
Comment 4 Jorendc 2013-01-09 19:17:29 UTC
Created attachment 72748 [details]
Error message Ubuntu 12.10 LO 4.1 latest master
Comment 5 Robert Großkopf 2013-01-09 20:29:46 UTC
(In reply to comment #4)
> Created attachment 72748 [details]
> Error message Ubuntu 12.10 LO 4.1 latest master

When I had a look at the screenshot I have seen "Report_Diagramm.odb". Its this attachment
https://bugs.freedesktop.org/attachment.cgi?id=59233
... and the report of this attachment already says: Report with charts fails ...
see: https://bugs.freedesktop.org/show_bug.cgi?id=48056

The error-message you reported is different to the message of other versions since 3.5.0, which couldn't open such a report. But it could be the same reason, if you don't test it with a report, which doesn't contain a chart.
Comment 6 Alex Thurgood 2013-01-10 08:09:31 UTC
Yep, same here on Linux Mint 13 32 bit, with :

Version 4.1.0.0.alpha0+ (Build ID: 6880e2d31a38d5f4b44ba4f5b4a2b3e361a6631)

Alex
Comment 7 Alex Thurgood 2013-01-10 08:10:32 UTC
What I meant is that it doesn't crash, but I get the same error message as Joren.

Alex
Comment 8 Alex Thurgood 2013-01-10 08:11:52 UTC
DUP of #48056 ?
Comment 9 Lionel Elie Mamane 2013-03-03 04:59:45 UTC
(In reply to comment #8)
> DUP of #48056 ?

No, crash is most probably different problem than the "failed to parse".
Comment 10 Lionel Elie Mamane 2013-03-13 10:49:26 UTC
So, here's what is happening:

The reportdesign::OShape claims to have properties "CustomShapeEngine", "CustomShapeDesign", etc, but when one tries to get their value, the internal
m_aProps.aComponent.m_xProperty throws com::sun::star::beans::UnknownPropertyException
which is unexpected and thus aborts LibreOffice.
The internal m_aProps.aComponent.m_xProperty
seems to be completely empty (!), while the
hasPropertyByname method recognises more than
200 property names!

Possibly this is a problem of query aggregation (the "get property value" is dispatched to the wrong object), but I think this is rather that the OShape is not initialised properly.

This could after all have the same underlying reason as bug 48056.

Any further than that, I'm stumped.
Comment 11 Lionel Elie Mamane 2013-04-24 17:23:09 UTC
Created attachment 78432 [details]
paper over the problem patch

Here's a patch that papers over the abort problem, but does not solve the "real" underlying problem. Note that even with this patch, the chart does not actually work :-|
Comment 12 Julien Nabet 2013-05-01 18:22:31 UTC
Lionel: I haven't tested your workaround patch but I entirely trust you (since you're the Base expert) and suppose it works :-).
I think that at least there's no more crash with it so it could be interesting to push it on master. Obviously you can let a comment in the commit + FIXME in the code. Sometimes the mess can't be fixed in one time :-)
What do you think?
Comment 13 Lionel Elie Mamane 2013-05-03 19:34:49 UTC
So, the crash had the same origin as bug 48056 after all, but happened only in dbgutil builds, because of the extra checking contained therein (the program was aborting on an inconsistency).

Since this "crash" is non-reproducible now, I'm leaving it as a canary so that dbgutil builds "fail early fail hard" if a similar problem comes in future.
Comment 14 Julien Nabet 2013-05-04 06:00:10 UTC
Created attachment 78830 [details]
console + bt with symbols on master sources

On pc Debian x86-64 with master sources updated today, I still reproduce the problem.
The bt attached is different from others (that's why I put the other to obsolete)
Comment 15 Julien Nabet 2013-05-04 06:01:24 UTC
Lionel: canary is still dead here :-(
Here's my autogen.input:
--with-system-odbc
--enable-ext-barcode
--enable-ext-diagram
--enable-ext-google-docs
--enable-ext-hunart
--enable-ext-nlpsolver
--enable-ext-ct2n
--enable-ext-numbertext
--enable-postgresql-sdbc
--enable-ext-presenter-minimizer
--enable-ext-typo
--enable-ext-validator
--enable-ext-watch-window
--enable-ext-wiki-publisher
--enable-dbus
--enable-graphite
--enable-evolution2
--enable-werror
--enable-debug
--enable-dbgutil
--enable-crashdump
--enable-dependency-tracking
--enable-online-update
--enable-ext-mariadb-connector
--enable-extra-sample
--enable-extra-template
--enable-extra-gallery
Comment 16 Lionel Elie Mamane 2013-05-04 07:40:58 UTC
(In reply to comment #14)

> On pc Debian x86-64 with master sources updated today, I still reproduce the
> problem.

What git commit id?
Comment 17 Julien Nabet 2013-05-04 08:56:56 UTC
git log -1 gives this:
commit 630bc850f7e36f75d295fc1d4a3cc56acd6921e7
Author: Kohei Yoshida <kohei.yoshida@gmail.com>
Date:   Fri May 3 21:37:38 2013 -0400

    Additional unit test for sorting.
    
    Change-Id: Ic7834a07341cee2b2fdcff3ae0707755e5500347
Comment 18 Julien Nabet 2013-05-04 10:45:07 UTC
Just for information, I did a "make clean && make dev-install" (I haven't done it since some days). I reproduce the crash.
Comment 19 Lionel Elie Mamane 2013-05-06 14:35:54 UTC
(In reply to comment #14)

> On pc Debian x86-64 with master sources updated today, I still reproduce the
> problem.
> The bt attached is different from others (that's why I put the other to
> obsolete)

This is a completely different crash, with a different backtrace and a different reason / source. I've opened bug 64279 for it. Closing this one again.
Comment 20 Lionel Elie Mamane 2013-05-06 14:41:08 UTC
(In reply to comment #3)
> We (Joel Madero) and I can reproduce this using the latest 4.1 version;
> NO CRASH, but an error message, and we can't open the report. (see
> attachment)

This means that you have *NOT* reproduced this bug, but found *another* one (which has different cause, different dates of appearance, etc).
Comment 21 Julien Nabet 2013-05-06 20:13:28 UTC
Thank you Lionel for the explanation! I'm reading right now the bugtracker you created.