Download it now!
Bug 58805 - Report builder: Wrong date and time in report page header footer
Summary: Report builder: Wrong date and time in report page header footer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: All Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.0.2
Keywords: regression
: 61151 62894 (view as bug list)
Depends on: 58371 61725 64279
Blocks: Database-Reports-Builder-MAB
  Show dependency treegraph
 
Reported: 2012-12-27 14:01 UTC by Zoltán Reizinger
Modified: 2013-12-15 23:14 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc with report (9.20 KB, application/vnd.oasis.opendocument.database)
2013-01-10 06:43 UTC, Zoltán Reizinger
Details
report header screenshot (8.12 KB, image/png)
2013-01-10 08:46 UTC, Zoltán Reizinger
Details
report footer screenshot (5.76 KB, image/png)
2013-01-10 08:47 UTC, Zoltán Reizinger
Details
Date and time of attachment 72771 - shown on linux 32bit rpm. (21.82 KB, image/png)
2013-01-10 16:26 UTC, Robert Großkopf
Details
Screenshot Mac OSX 10.8.2 (176.32 KB, image/png)
2013-01-11 07:15 UTC, Jorendc
Details
bugdoc with report (16.22 KB, application/vnd.oasis.opendocument.database)
2013-01-13 09:57 UTC, Zoltán Reizinger
Details
First page in LibreOffice 4.0 RC1; Can't reproduce (235.02 KB, image/png)
2013-01-14 19:31 UTC, Jorendc
Details
Second page in LibreOffice 4.0 RC1; Can't reproduce (154.43 KB, image/png)
2013-01-14 19:31 UTC, Jorendc
Details
newly cretaed database in RC1 (12.38 KB, application/vnd.oasis.opendocument.database)
2013-01-14 19:55 UTC, Zoltán Reizinger
Details
windows dates and times screenshot (68.21 KB, image/jpeg)
2013-02-02 21:21 UTC, headsup
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Reizinger 2012-12-27 14:01:08 UTC
The report builder report shows wrong (1899-12-30) date instead of Today(), and time 00:00 instead of Now() current value.

See attached file, open report for edit, I put date/time into header/footer and details area, the fields in Details, shows correct date/time values.

This error is a reincarnation of some old bugs from report builder past. 

This not happens in LibO 3.6.4, regression.
Comment 1 Robert Großkopf 2012-12-29 20:21:36 UTC
I have tested with Version 4.0.0.0.beta2+, Branch:libreoffice-4-0, Time: 2012-12-28_12:46:28 and a linux-rpm-32bit-system.
I can't confirm this behavior. Have tested to insert Today() and Now() by 
Insert → Date and Time
Have done this in pageheader and -footer, reportheader and -footer and groupheader. All the same right date and right time.
Comment 2 Joel Madero 2013-01-09 19:42:22 UTC
"See attached file" - no attached file, please attach document and reopen as REOPENED :) Thanks for reporting
Comment 3 Zoltán Reizinger 2013-01-10 06:43:13 UTC
Created attachment 72771 [details]
bugdoc with report

This database created in LibO 4 beta2, see report.
Comment 4 Zoltán Reizinger 2013-01-10 06:44:05 UTC
reopen.
Comment 5 Robert Großkopf 2013-01-10 08:04:48 UTC
I opened the report with Version 4.0.0.0.beta2+ Time: 2013-01-07_14:50:57.
I could see a blue and a grey area with the actual date and time, date is formatted "10.01.13". Then I could see yellow areas with actual date and time, date formatted "2013. 1. 10."
I opened the report for editing. Seems, that all dates have been formatted as the dates in the yellow areas ("Detail"), but the formatting is ignored in the header and in the footer. I couldn't format it as "Hungarian" - its still shown as "German" because of the local settings. Could this be a part of the problem?
Comment 6 Zoltán Reizinger 2013-01-10 08:46:49 UTC
Created attachment 72773 [details]
report header screenshot
Comment 7 Zoltán Reizinger 2013-01-10 08:47:34 UTC
Created attachment 72774 [details]
report footer screenshot
Comment 8 Zoltán Reizinger 2013-01-10 08:49:36 UTC
all date formatted as YYYY". "M". "D.
The extra quotation marks in format I subitted in separate bug: 58797.
Comment 9 Robert Großkopf 2013-01-10 16:26:26 UTC
Created attachment 72789 [details]
Date and time of attachment 72771 [details] - shown on linux 32bit rpm.

I don't see any quotes in the date-format.
Which java-version do you use? I use 1.6.0_29 on linux 32bit rpm
Comment 10 Zoltán Reizinger 2013-01-10 17:44:59 UTC
Java 1.6.37, same with 1.7.10. May be it is a windows problem.

Wait until someone other can test it under windows, and with other locale than Hungarian, may be it is Hungarian only or windows only bug.  

Quotes is another bug.
Comment 11 Jorendc 2013-01-11 07:15:21 UTC
Created attachment 72838 [details]
Screenshot Mac OSX 10.8.2

Hi, can't reproduce either... See attached screenshot.

Tested with Mac OSX 10.8.2 and LibreOffice Versie 4.0.0.1 (Bouw-id: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-09_10:49:53
Comment 12 Jorendc 2013-01-11 23:54:54 UTC
Can't test this bug any longer until bug 58371 (https://bugs.freedesktop.org/show_bug.cgi?id=58371) is fixed.
Comment 13 Zoltán Reizinger 2013-01-13 09:57:47 UTC
Created attachment 72951 [details]
bugdoc with report

I created in oroginal bugdoc a new report in RC1, the page header and footer contains wrong date. The bugdoc saved with new name.
Comment 14 Jorendc 2013-01-14 19:30:49 UTC
Still can't confirm using Mac OSX 10.8.2 with LibreOffice Version 4.0.0.1 (Build id: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-09_10:49:53
Comment 15 Jorendc 2013-01-14 19:31:17 UTC
Created attachment 73019 [details]
First page in LibreOffice 4.0 RC1; Can't reproduce
Comment 16 Jorendc 2013-01-14 19:31:40 UTC
Created attachment 73020 [details]
Second page in LibreOffice 4.0 RC1; Can't reproduce
Comment 17 Zoltán Reizinger 2013-01-14 19:55:17 UTC
Created attachment 73023 [details]
newly cretaed database in RC1

I not argue that it can't be reproduced under Mac, it can be a windows platform only bug.
Comment 18 Zoltán Reizinger 2013-01-14 19:55:47 UTC
Change platform to windows.
Comment 19 headsup 2013-02-02 21:21:44 UTC
Created attachment 74105 [details]
windows dates and times screenshot

Jorendc asked me to test this as I use Windows. I tested on W8 pro 32 bit, x86. 

I opened the two reports in "72023 newly created database in RC1." The dates in the header and footer are indeed incorrect - see attached screen shot. They should be todays date. 

I tested using LO 4.0.0.3.

I am changing the status accordingly.
Comment 20 Robert Großkopf 2013-02-18 17:57:07 UTC
(In reply to comment #19)
> 
> I tested using LO 4.0.0.3.
> 
> I am changing the status accordingly.

It's also confirmed in the German OpenOffice-Forum.
You did assign yourself to this bug. As I understand this you are working to get it resolved, right?

Robert
Comment 21 Robert Großkopf 2013-02-20 19:48:10 UTC
*** Bug 61151 has been marked as a duplicate of this bug. ***
Comment 22 Rob Keeney 2013-02-27 13:59:44 UTC
I see this as well on both WinXP and Win8 using v4.0. It's definitely something new with this version as I confirmed the correct behavior using an earlier version (v3.6).
Comment 23 Joel Madero 2013-02-28 01:32:14 UTC
Lionel - believe this one is yours
Comment 24 Lionel Elie Mamane 2013-02-28 06:43:58 UTC
(In reply to comment #23)
> Lionel - believe this one is yours

Well... Windows-only bugs are not my area of speciality, and that's a big understatement. (I have no Windows build environment...) The best hope would be to find another developer that *does* have some Windows build environment and experience. I'm willing to collaborate, but cannot do this on my own.


(In reply to comment #0)
> The report builder report shows wrong (1899-12-30) date instead of Today(),
> and time 00:00 instead of Now() current value.

> This error is a reincarnation of some old bugs from report builder past.

*Maybe*, if you remember or can find out (the more exactly, the better) when (what version, what OpenOffice.org issue number, ...) had this bug and when it got fixed, I could look at the diff and get some inspiration.
Comment 27 Joel Madero 2013-03-07 14:50:57 UTC
@info@ben-wagner.de - please don't change priority without an explanation of why. This policy is in place so that users don't over estimate bugs that affect themselves and thus make our bug tracker not useful for prioritization purposes. 

Just going into the future please leave comments. thanks!
Comment 28 Robert Großkopf 2013-04-13 06:36:14 UTC
*** Bug 62894 has been marked as a duplicate of this bug. ***
Comment 29 Lionel Elie Mamane 2013-04-24 17:14:23 UTC
I changed date-related stuff in Reportbuilder recently... Try with a recent master build or LibreOffice 4.0.3.

(Sorry, but since I have no Windows machine, I cannot test myself.)
Comment 30 Andras Timar 2013-05-13 12:11:25 UTC
In fact it is fixed even in 4.0.2. 4.0.1 was the last wrong version.