Bug Hunting Session
Bug 67930 - REPORTBUILDER: when detail section upper left corner is string, all formulas in page foot/header evaluate to zero
Summary: REPORTBUILDER: when detail section upper left corner is string, all formulas ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: BSA target:4.2.0 target:4.1.2 target:...
Keywords: regression
: 67893 (view as bug list)
Depends on: 68020 68024
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 01:09 UTC by Alan McKenzie
Modified: 2016-10-05 11:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Months.odb (8.21 KB, application/vnd.sun.xml.base)
2013-08-09 23:26 UTC, Alan McKenzie
Details
Report1_x_0.00.odt (11.11 KB, application/vnd.oasis.opendocument.text)
2013-08-09 23:26 UTC, Alan McKenzie
Details
Report1_x_0.01.odt (11.23 KB, application/vnd.oasis.opendocument.text)
2013-08-09 23:26 UTC, Alan McKenzie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan McKenzie 2013-08-09 01:09:46 UTC
Problem description: 

Steps to reproduce:
1. Start building report
2. Insert a data field from the data base with x=0.00cm and y=0.00cm in the detail section
3. Insert date field today() anywhere in header or footer
4. The date will display in a report as Saturday, 30 December 1899
5. Set either x or y at 0.01cm or more
6. The date will display correctly in the report

Current behavior: Incorrect if both x and y are set at0.00cm

Expected behavior: Correct if either x or y set 0.01cm or more

This supplements previously submitted error report

              
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 Robert Großkopf 2013-08-09 13:16:26 UTC
Shure that it is the new version LO 4.1.0.4 ? I have just tested with Linux 64bit rpm - there it works right. We had some problems with date in the header and footer under Windows. See https://bugs.freedesktop.org/show_bug.cgi?id=58805 . But this bug might have been fixed. If not we have to reopen it.
Comment 2 Lionel Elie Mamane 2013-08-09 13:20:47 UTC
Please attach an example database with two reports:

1) One showing the problem. (x=y=0)
2) One showing the correct result (x or y set to 0.01cm or more)
Comment 3 Alan McKenzie 2013-08-09 23:26:23 UTC
Created attachment 83910 [details]
Months.odb

Sample database months.odb attached. This has both x and y set at 0.00 
and gives a wrong date
Report1_x_0.00.odt is the corresponding report saved as an odt file. Day 
is correct, but date month and year are all wrong at 30 December 1899.
Report1_x_0.01.odt is the report when x=0.01. date is correct

Alan McKenzie
Comment 4 Alan McKenzie 2013-08-09 23:26:23 UTC
Created attachment 83911 [details]
Report1_x_0.00.odt
Comment 5 Alan McKenzie 2013-08-09 23:26:23 UTC
Created attachment 83912 [details]
Report1_x_0.01.odt
Comment 6 Lionel Elie Mamane 2013-08-10 02:59:49 UTC
*** Bug 67893 has been marked as a duplicate of this bug. ***
Comment 7 Lionel Elie Mamane 2013-08-10 04:51:23 UTC
OK, reproduced.
Comment 8 Commit Notification 2013-08-12 16:55:31 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fc92c1abebcfe9b18649d35b76bf22e001e332da

fdo#67930 don't use variables for formattedtext in header/footer



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-08-13 07:48:44 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=76408b0f0d7e91cddb8b056069a2ee547109b156&h=libreoffice-4-1

fdo#67930 work around fdo#68024


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Alan McKenzie 2013-08-14 23:19:07 UTC
LibreOffice 4.1.2 was downloaded and run on Thursday 15 August.
All reports which had previously resulted in an incorrect date for 
date() when x=y=0 now produced the correct date in the footer.
The same reports are still incorrect when run today with LibreOffice 4.1.0.4
Thanks for a successful fix.
Alan McKenzie
Comment 11 Commit Notification 2014-12-12 17:10:58 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e10f6d229587ffc2a955c225b489645f8016e23

fdo#67930 work around fdo#68024

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-12-12 17:13:32 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c582a7b280afc96ecf897356e0885d2bcf289710&h=libreoffice-4-4

fdo#67930 work around fdo#68024

It will be available in 4.4.0.0.beta3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.