Bug 58375 - FILESAVE: Hyphenation in xls xlsx Spreadsheet will be ignored
Summary: FILESAVE: Hyphenation in xls xlsx Spreadsheet will be ignored
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: XLSX-Limitations XLS
  Show dependency treegraph
 
Reported: 2012-12-16 21:30 UTC by liblawyer
Modified: 2018-07-19 12:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Before saving the first paragraph of lorum ipsum (127.15 KB, image/png)
2012-12-17 14:01 UTC, Jorendc
Details
After saving the first paragraph of lorum ipsum (152.78 KB, image/png)
2012-12-17 14:01 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liblawyer 2012-12-16 21:30:03 UTC
Problem description: 

Hyphenation in xls-Spreadsheet will be ignored

Steps to reproduce:
1. create a new spread sheet or take an existing one
2. create some longer text entries
3. format them using Format -> Cells -> Alignment -> Properties -> check "Wrap text automatically" and check "Hyphenation active"
4, check whether text is properly hyphenated
4. save as MS Excel 97 "xls" Format (maybe other file formats affected as well)
5. close and reopen file

Current behavior:
Hyphenation does not work anymore

Expected behavior:
Hyphenation does work and is shown properly

This can be either a viewing problem or a formatting problem. I could verify this odd behaviour under Windows 7 and Mac OS X
Operating System: All
Comment 1 m.a.riosv 2012-12-16 22:23:07 UTC
Seems that the [Hyphenation active] mark is lost when reopening the file.
Comment 2 Jorendc 2012-12-17 14:00:53 UTC
I can reproduce with LibreOffice 3.6.4.3 (Build id: 2ef5aff) and LibreOffice 4.0.0.0.beta1 (Build id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37; Dutch UI.

I copied the first paragraph of 'Lorum Ipsum' in the first cell. I followed all the steps to reproduce this bug. When I reopen the document, indeed all hyphenations are 'gone', but the content is shuffled. The start of 'Lorum ipsum' is now at the 27 line of that cell. (see attachment 'before saving' and 'after saving').
Comment 3 Jorendc 2012-12-17 14:01:32 UTC
Created attachment 71652 [details]
Before saving the first paragraph of lorum ipsum
Comment 4 Jorendc 2012-12-17 14:01:57 UTC
Created attachment 71653 [details]
After saving the first paragraph of lorum ipsum
Comment 5 QA Administrators 2015-01-05 17:51:45 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-01-23 16:27:45 UTC
Still repro.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 07e84cae983c08afdba03018413a19d01abb3006
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-19_06:15:38
Comment 7 QA Administrators 2016-02-21 08:36:08 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-03-06 15:25:40 UTC Comment hidden (obsolete)
Comment 9 Timur 2018-07-19 12:42:27 UTC
LO Calc has "Hyphenation Active" with Format-Cells-Wrap and MSO Excel doesn't have that option. 
I don't see Hyphenation in "18. SpreadsheetML Reference Material" either. 
So looks like MSO and XLS and XLSX formats don't support Hyphenation. 
I'll close as NotOurBug and add to "XLSX-Limitations". If I'm wrong please explain.