Bug 58464 - segfault CRASH when FILEOPEN particular .docx
Summary: segfault CRASH when FILEOPEN particular .docx
Status: RESOLVED DUPLICATE of bug 58267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-18 14:47 UTC by Juan Matías de la Cámara Beovide
Modified: 2012-12-27 04:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Files I used to test. Test 001 just lines. Test 002 draws. (70.10 KB, application/x-gzip)
2012-12-18 14:47 UTC, Juan Matías de la Cámara Beovide
Details
typescript of gdb session with backtrace (19.03 KB, text/plain)
2012-12-18 21:56 UTC, Terrence Enger
Details
typescript of valgrind run (13.48 KB, text/plain)
2012-12-18 21:57 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Matías de la Cámara Beovide 2012-12-18 14:47:21 UTC
Created attachment 71733 [details]
Files I used to test. Test 001 just lines. Test 002 draws.

Problem description: when a file is exported to DOCX it loses certain formats. I made a file with paragraph's lines (one paragraph with upper line, one with lower line and one with all lines). Then I saved it as ODT, DOC and exported to PDF with no problem. When I export it to DOCX and then open the docx again the lines are gone. If I add some draws (a smily, a box and a dialog box) the DOCX can't be reopened.

Steps to reproduce:
1. Create a doc
2. Add lines around the paragraphs
3. Export to DOCX
4. Close LO
5. Open LO and try to open the created DOCX
6. The lines are not shown
7. Now create a doc again
8. Add some draws (a smily it's ok)
9. Export it to DOCX
10. Close LO
11. Open LO and open the created DOCX
12. LO will crash

Current behavior: In the firt case the lines are not shown. In the second LO will crash.

Expected behavior: In the first case is expected to see the lines. In the second at least see the document without crash.


Operating System: Linux (Other)
Comment 1 Terrence Enger 2012-12-18 21:53:11 UTC
Opening test_paragraphlines_002.docx from the command line, I have
reproduced the segfault in both 4.0.0.0beta1 and in master commit
72b2c82 pulled 2012-12-11, configured with
    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --without-system-postgresql
    --without-myspell-dicts
    --without-help
    --with-extra-buildid
built and executing on ubuntu-natty (11.04) 32-bit.  The attached
typescript is from master.

As I can make the segfault happen, I am rewriting the bug summary to
just the segfault and setting bug status CONFIRMED.


Juan Matías,

I am unclear in my mind about how the lost paragraph lines that you
reported here relate to fdo#58469.  If you are in fact reporting
different incorrect behaviours, feel free to open another bug report
with the problem that I am leaving out of this one.

And, by the way I am not exactly ignoring your receint contributions
to fdo#58460; just not sure that I have anything useful to write.

Terry.
Comment 2 Terrence Enger 2012-12-18 21:56:53 UTC
Created attachment 71758 [details]
typescript of gdb session with backtrace

The segfault happened at svdobj.cxx:1979 in SdrObject::GetMergedItemSet
Comment 3 Terrence Enger 2012-12-18 21:57:46 UTC
Created attachment 71759 [details]
typescript of valgrind run

The segfault happened under valgrind, too.
Comment 4 Rainer Bielefeld Retired 2012-12-20 18:20:44 UTC
Related to "Bug 58399 - CRASH when FILEOPEN particular .docx (MSO2007)"?

Can we simply say crash can be reproduced when open whatdoiknow.docx from test kit (or all steps required)? A simple proceeding would ease bibisecting.
Comment 5 Terrence Enger 2012-12-20 20:23:02 UTC
Simpler steps to reproduce just the segfault

(1) Download the first attachment to this bug
    <https://bugs.freedesktop.org/attachment.cgi?id=71733> and unpack
    it.

(2) Run soffice naming the unpacked test_paragraphlines_002.docx on
    the command line.


The segfault was not evident when I opened the file in LO 3.6.4.4, so
I am setting keyword "regression".

Terry.
Comment 6 Terrence Enger 2012-12-20 20:26:45 UTC
For the convenience of those who like who like to search this way, the segfault happend in SdrObject::GetMergedItemSet in file svx/source/svdraw/svdobj.cxx.
Comment 7 Michael Stahl (allotropia) 2012-12-20 22:01:30 UTC
this was fixed by 7fec8dfcaca4efc92516f9af51a3157f1a11ccd7
->duplicate

*** This bug has been marked as a duplicate of bug 58267 ***
Comment 8 Terrence Enger 2012-12-27 04:43:24 UTC
In both 4.0.0.0.beta2 and a recent debug build from master, the
segfault with test_paragraphlines_002.docx is gone, like fdo#58267
says.

Juan,

Please feel free to file another bug for the problem with disappearing
paragraph borders.

I notice as well that he added drawins have different different
colours when I load different files.  Is this what you intended?

Terry.