Download it now!
Bug 58484 - FILEOPEN particular LibO 3.5 .ods: all CONDITIONAL FORMATTING lost
Summary: FILEOPEN particular LibO 3.5 .ods: all CONDITIONAL FORMATTING lost
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-18 22:07 UTC by john.pratt
Modified: 2012-12-19 09:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ods file which works in 3.5 but not 4.0 beta a (23.81 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-18 22:07 UTC, john.pratt
Details
seems to work for me (102.94 KB, image/png)
2012-12-19 01:07 UTC, Marco Menardi
Details
Screenshot comparison (121.88 KB, application/pdf)
2012-12-19 05:46 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john.pratt 2012-12-18 22:07:24 UTC
Created attachment 71764 [details]
ods file which works in 3.5 but not 4.0 beta a

Problem description: when I open my .ods spreadsheet (my school mark book) in 4.0 beta 1 there is no conditional formatting, but in 3.5 there is lots of conditional formatting

Steps to reproduce:
1. open the attached file in 3.5 (everything works as expected, e.g. enter 'M' in cell CA7)
2. open the attached file in 4.0

Current behavior: no conditional formatting is working or listed under CF -> Manage

Expected behavior: conditional formatting should still be present and working

NB: I have tried creating a simple document with only one conditional format in 3.5 and then opening in 4.0 beta 1 and this worked as expected.

              
Operating System: Windows XP
Version: 4.0.0.0.beta1
Comment 1 Marco Menardi 2012-12-19 01:07:33 UTC
Created attachment 71779 [details]
seems to work for me
Comment 2 Marco Menardi 2012-12-19 01:11:10 UTC
Well, I'm not very fond with attachment in bugzilla...
My comment is that I've tried with WinXP-32 and LiBo 4.0beta1, and it works, also in CF -> manage I see all the conditional formatting as you can see in the attached screenshot (n.b. there you see the filename has "aaa_" prefix but has been renamed from file explorer, not re-saved).
Comment 3 Rainer Bielefeld Retired 2012-12-19 05:17:44 UTC
NOT reproducible with parallel installation of  "LOdev  4.0.0.0.beta1   -  GERMAN UI / German Locale  [Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)]"  {tinderbox: @6, pull time 2012-12-06} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch.

I open the document form LibO Start Center, see lots of CF in menu 'Format -> CF -> Manage', and it works fine for AA7 and T7
Comment 4 Rainer Bielefeld Retired 2012-12-19 05:46:58 UTC
Created attachment 71787 [details]
Screenshot comparison

But during my research for "Bug 58499 - FILEOPEN particular LibO 3.5 .ods: Bold formatting for several cells lost" I found CF problems:

Example: Cell AN7 (see attached screenshots)
Comment 5 john.pratt 2012-12-19 08:17:25 UTC
I agree that the conditional formatting works today!
Comment 6 Rainer Bielefeld Retired 2012-12-19 08:32:46 UTC
@john.pratt@cantab.net:
But what's with my observation in Comment 4? If you can confirm, please open a new bug with reference to this one and add me to CC!
Comment 7 john.pratt 2012-12-19 09:57:50 UTC
(In reply to comment #6)
> @john.pratt@cantab.net:
> But what's with my observation in Comment 4? If you can confirm, please open
> a new bug with reference to this one and add me to CC!

I see what you mean, but am not convinced this is a bug.  I am playing and will shortly write a new bug/feature request.  Sorry I didn't realise quite what the problem was the first time I replied.