Download it now!
Bug 58588 - Recovery of document after program crash fails if file was not saved before
Summary: Recovery of document after program crash fails if file was not saved before
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Document-Recovery
  Show dependency treegraph
 
Reported: 2012-12-20 21:19 UTC by clemty
Modified: 2017-10-07 09:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Error message: cannot open file (476.92 KB, image/png)
2012-12-20 21:19 UTC, clemty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clemty 2012-12-20 21:19:34 UTC
Created attachment 71874 [details]
Error message: cannot open file

4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Win7 x64

If I crash lodev with bug 48775 recovery fails if the file was not saved first:

"The file '$(ARG1)' is corrupt and therefore cannot be opened. LOdev can try to repair the file." - recovery subsequently fails

Recovery only fails if the file was not saved before (i.e. does not have a filename):

create new document, provoke crash: recovery fails
create new document, save, provoke crash: recovery succeeds

screenshot attached; note that the recovered file has an .odt extention but the failing document is simply called "Untitled 1"

This may also be the reason for recovery failing in bug 57142
Comment 1 clemty 2013-01-06 12:38:25 UTC
I can no longer reproduce this on 4.0.0.0.beta2

setting to WORKSFORME since I don't know if this was just me or if it was fixed in code, feel free to correct the status