Download it now!
Bug 58628 - Frame don't support Rotation
Summary: Frame don't support Rotation
Status: CLOSED DUPLICATE of bug 91530
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-21 17:26 UTC by BinLi
Modified: 2017-07-17 12:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Basic ODT example showing: text box, frame, text box in a frame. (9.34 KB, application/vnd.oasis.opendocument.text)
2013-11-15 09:33 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BinLi 2012-12-21 17:26:07 UTC
I use openSUSE 12.2, and after use 'Text' in Drawing toolbar, it don't support 'block selection', so I use the Frame to input text, after that I wanna rotate it like 'Text', but it doesn't have this option.
Comment 1 A (Andy) 2013-04-20 14:56:04 UTC
Could you pleae give more information about your bug.
For me it is possible to rotate a frame with LO 4.0.2.2 (Win7 Home, 64bit).

-> from the DRAWING toolbar select the RECTANGLE and place it inside the WRITER document.  Then select this rectangle with one left mouse click and make a right mouse click on it and go to POSITION AND SIZE and there to the tab ROTATION and now you can rotate the rectangle.

Or is there a misunderstanding from my side?
Comment 2 QA Administrators 2013-11-04 22:18:00 UTC Comment hidden (obsolete)
Comment 3 Owen Genat (retired) 2013-11-15 09:33:56 UTC
Created attachment 89255 [details]
Basic ODT example showing: text box, frame, text box in a frame.

This appears to be a shortcoming in the LO UI as the ODF specification currently supports rotation of a frame. For clarity, all text boxes (inserted by selecting T on the Drawing toolbar) are frames:

<draw:frame text:anchor-type="paragraph" draw:z-index="0" draw:style-name="gr1" svg:width="20.01mm" svg:height="20.01mm" draw:transform="rotate (-3.14159265358979) translate (20.0025mm 30.00375mm)">
   <draw:text-box>
      <text:p>Text in a text box.</text:p>
   </draw:text-box>
</draw:frame>

... and they are rotated by inclusion of the draw:transform attribute of the <draw:frame> element. A frame (Insert > Frame...) has a similar structure:

<draw:frame draw:style-name="fr1" draw:name="Frame1" text:anchor-type="paragraph" svg:y="10mm" svg:width="20mm" draw:z-index="1">
   <draw:text-box fo:min-height="20mm">
      <text:p text:style-name="P1">Text in a frame.</text:p>
   </draw:text-box>
</draw:frame>

... yet it cannot be rotated. Right-click on a text box > Position and Size... > offers a dialog with a Rotation tab. Right-click on a frame > Frame... > there are no similar options available.
Comment 4 QA Administrators 2014-06-01 21:30:08 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2014-07-08 17:17:52 UTC Comment hidden (obsolete)
Comment 6 Regina Henschel 2017-07-17 12:29:12 UTC
This is basically a valid request, but has a bad description. In the meantime there exists the better bug 91530 with the same request. So I close this one.

*** This bug has been marked as a duplicate of bug 91530 ***