Bug 91530 - FEATURE REQUEST: rotate the frame
Summary: FEATURE REQUEST: rotate the frame
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: topicUI
: 58628 (view as bug list)
Depends on:
Blocks: ODF-import
  Show dependency treegraph
 
Reported: 2015-05-23 15:19 UTC by Edmund Laugasson
Modified: 2019-01-23 19:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
example Writer document with frame and rotated text box (21.38 KB, application/vnd.oasis.opendocument.text)
2015-05-23 15:23 UTC, Edmund Laugasson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Edmund Laugasson 2015-05-23 15:19:10 UTC
Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)


Steps to reproduce
* Insert->Frame
* design the frame
* try to rotate - there is no way to do that

Expected result: like with text box there would be the rotate tool available.
Comment 1 Edmund Laugasson 2015-05-23 15:23:07 UTC
Created attachment 115899 [details]
example Writer document with frame and rotated text box

Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)
Comment 2 Jean-Baptiste Faure 2015-05-23 18:19:52 UTC
Not a bug --> enhancement
Comment 3 Edmund Laugasson 2015-05-23 20:40:21 UTC
There is even in pull-down menu the choice available:
Format->Rotate
...but is greyed out.

The proposal would be to make it work in case of selected panel. There in Format menu are only 90 degree steps and certainly there would be expected also more precise rotation - at least 1 degree step.
Comment 4 tommy27 2015-05-24 11:11:35 UTC
has OOo/LibO ever had that function? if not version should be inherited from OOo
Comment 5 Edmund Laugasson 2015-05-24 15:39:44 UTC
Do not know that but I hope the developers can check that.
Comment 6 Buovjaga 2015-06-08 10:43:19 UTC
Sounds reasonable, NEW.
Comment 7 Yousuf Philips (jay) (retired) 2016-08-09 04:43:24 UTC
As images are treated as frames in writer, enabling the 90* rotations for frames like what as done for images in bug 34423 should likely be possible. We would need a dev to evaluated what is possible.
Comment 8 Tomaz Vajngerl 2016-08-09 10:50:45 UTC
No, image 90 degree rotation creates a new image that is rotated and replaces the old image.
Comment 9 Regina Henschel 2017-07-17 12:25:34 UTC
The file format uses a <draw:frame> element for the shape, which is generated by the T symbol and for the frame, which is inserted via Insert > Frame, as well. The ODF standard allows a draw:transform attribute on a <draw:frame> element. It is a missing feature in LibreOffice, that transformations are only performed, for what LibreOffice considers to be a shape.

I think it is a hard task, to implement transformations on all kind of <draw:frame> elements. But it would be very useful to have such feature.
Comment 10 Regina Henschel 2017-07-17 12:29:12 UTC
*** Bug 58628 has been marked as a duplicate of this bug. ***
Comment 11 John Statler 2017-11-13 09:29:13 UTC Comment hidden (me-too)
Comment 12 Luke 2019-01-23 19:57:44 UTC
Miklos resolved this issue with his Text Box implementation in LO 4.4. 

Steps to reproduce
* Insert->Text Box
* Format -> Text Box -> design the Text Box like your frame
* Format -> Text Box -> Position -> Rotate the Text Box

Frames are a well defined word processing concept with an industry accepted standard. Implementing this request as is would break export to .doc and word perfect formats. Their frame objects do not support rotation. They use Text boxes for this.