Download it now!
Bug 58703 - MAILMERGE: Mail merge fail on clicking "Send documents"
Summary: MAILMERGE: Mail merge fail on clicking "Send documents"
Status: RESOLVED DUPLICATE of bug 63388
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-24 08:44 UTC by To Do
Modified: 2016-04-18 12:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description To Do 2012-12-24 08:44:35 UTC
Problem description: When I try to send documents through email, whenever I click the "Send documents" button, sometimes nothing happens, other times CPU usage goes high then libreoffice crashes.

Steps to reproduce:
1. Follow mail merge wizard and in the last step choose send by e-mail.
2. It told me to set up an email account and I used my gmail account(Google apps).
3. I chose "plain text" as the format to send.
4. Click "Send documents"

Current behavior: I've been trying since yesterday, it worked once.

Expected behavior: The sending documents dialog should open showing progress.

              
Operating System: Ubuntu
Version: 3.6.2.2 release
Comment 1 Alex Thurgood 2013-06-14 04:42:42 UTC
Hi,

For gmail, these are the settings that worked for me :

SSL option ticked
smtp.googlemail.com
Port 25

Under "Server Authentication"
Tick "Outgoing mail server (SMTP) requires authentication"
Select "The outgoing mail server requires separate authentication"
User name : enter full Gmail address here, including the @gmail.com
Password : fill in with password

No need to configure the Incoming Mail Server options


Alex
Comment 2 Andrea Tessadri 2014-09-13 14:58:08 UTC
I couldn't figure out the way to have mailmerge working with my Gmail SMTP but when I did the debug of the mailmerge.py script I've discovered that a SSL connection isn't handled properly.
At the line where the server object is created I found:

self.server = smtplib.SMTP(server, port,timeout=tout)

but in case of SSL connection the correct statement should be:

self.server = smtplib.SMTP_SSL(server, port,timeout=tout)

So, I did this simple change and my Gmail SMTP (smtp.gmail.com) works perfectly on port 465.
I didn't even checked the "Use SSL" checkbox in the mailmerge configuration windows.

I think a good patch should make a choice between smtplib.SMTP and smtplib.SMTP_SSL according to the "Use SSL" checkbox.

Cheers.

   Andrea
Comment 3 Julien Nabet 2015-02-21 15:10:20 UTC
Let's put this one as dup since there's more info in tdf#63388

*** This bug has been marked as a duplicate of bug 63388 ***