Bug 99363 - SMTP over SSL on port 465 (mailmerge on your Google Account: smtp.gmail.com)
Summary: SMTP over SSL on port 465 (mailmerge on your Google Account: smtp.gmail.com)
Status: RESOLVED DUPLICATE of bug 63388
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2016-04-17 21:11 UTC by prrvchr
Modified: 2018-10-17 17:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Modified mailmerge.py (17.56 KB, text/x-python)
2016-04-17 21:32 UTC, prrvchr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description prrvchr 2016-04-17 21:11:30 UTC
Hi All,

After several unsuccessful connection attempt on my Gmail account (smtp.gmail.com port 465) we can see that the mailmerge.py file does not load the library SMTP_SSL but only SMTP

If I replace the line:
self.server = smtplib.SMTP(server, port, timeout=tout)
by:
self.server = smtplib.SMTP_SSL(server, port, timeout=tout)
in the file mailmerge.py the connection work fine.

Is it possible to change this file (mailmerge.py) to supports connections of type: SMTP and SMTP over SSL on port 465.

Thank you.
Comment 1 prrvchr 2016-04-17 21:32:25 UTC
Created attachment 124440 [details]
Modified mailmerge.py

mailmerge.py to support:
Smtp
Smtp over SSL on port 465
Smtp over TLS on port 587
Comment 2 cpohle 2016-11-03 12:07:34 UTC
Hi, I can confirm the patch solved the issue of not being able to send e-mails via SMTP_SSL. However, it still lasts a considerable amount of time before the mails are actually sent. Maybe some routine in the Python script that times out before message handling starts?
Comment 3 Julien Nabet 2016-12-30 15:26:52 UTC
I don't know if the problem can still be reproduced with last stable LO version 5.2.4 but if you got some solution, you can contribute by taking a look here:
https://wiki.documentfoundation.org/Development/GetInvolved

Meanwhile, let's put this one to NEW since cpohle confirms there's a pb without the patch.
Comment 4 Julien Nabet 2016-12-30 15:32:23 UTC
I've just noticed it's a dup of tdf#63388

*** This bug has been marked as a duplicate of bug 63388 ***
Comment 5 prrvchr 2017-02-05 11:53:32 UTC
The patch work fine for me, but need some Google Mail Account setting requirement:

Load: https://myaccount.google.com/security?utm_source=OGB#connectedapps

You must enable less secured application. Needed but apparently the connection is under SSL...