Download it now!
Bug 48538 - MAILMERGE cannot use SSL/port 465
Summary: MAILMERGE cannot use SSL/port 465
Status: RESOLVED DUPLICATE of bug 63388
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: lowest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2012-04-11 00:18 UTC by Gordon Burgess-Parker
Modified: 2018-10-17 17:21 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
error when testing log in to gmail (104.93 KB, image/png)
2016-10-06 18:21 UTC, linuxovios
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gordon Burgess-Parker 2012-04-11 00:18:39 UTC
LO 3.5.2.2
I am trying to send a mail-merged document direct to email and some rather baffling occurrences present themselves.

1. It seems that LO uses it's own mail sending function rather than the default email client that is installed on my machine! What on earth is that all about? Why doesn't it just call my default email client?

2. As my email address is GMail, the GMail smtp server uses TLS authentication.
There is NO option to select TLS for the smtp server in the built-in LO mailing function. There is an option to use SSL but I've NEVER seen an smtp server use SSL - that's normally reserved for POP servers....

So it seems that I cannot mail merge a document from LO direct to email if I use GMail as my email..
Comment 1 Gordon Burgess-Parker 2012-04-11 07:54:52 UTC
Additional information and comments.

1. It seems that if I use an email address whose SMTP server does NOT require SSL connection, it works perfectly OK.

2. Google SMTP can (according to their website) use SSL or TLS. If I check SSL then the sending of mailmerge documents to email just becomes non-responsive. (Tested both in 3.4.6 and 3.5.2.2)

3. If I use the File-Send-Document as Email then it invokes my Default Email client.
WHY DOESN'T THE MAILMERGE TO EMAIL do the same thing?
The emails that I send by the mailmerge are not recorded anywhere on my machine. That is a BAD thing as there is NO record of them being sent.
Comment 2 Rainer Bielefeld Retired 2012-04-17 02:45:31 UTC
I see this as NOTABUG/WONTFIX. 

I doubt that it is useful to use an email client for "our" mailmerge, that is a completely different approach. If you want to do mass mailings that way, a little script should be able to do, or may be someone can create an extension 8or may be there already an extension exists? I don't know). 

But indeed, the MAILMERGE e-mail function still needs some enhancement:
- Transmissions logfile
- may be TLS 
- may be others.
For these needs separate enhancement requests have to be submitted.
Comment 3 linuxovios 2016-10-06 18:21:05 UTC
Created attachment 127846 [details]
error when testing log in to gmail

LibreOffice could not connect to the outgoing mail server. Check your system's settings and the settings in LibreOffice. Check the server name, the port and the secure connections settings
--
<class 'smtplib.SMTPServerDisconnected'>: Connection unexpectedly closed, traceback follows
  /usr/lib/python3.4/smtplib.py:376 in function getreply() [raise SMTPServerDisconnected("Connection unexpectedly closed")]
  /usr/lib/python3.4/smtplib.py:323 in function connect() [(code, msg) = self.getreply()]
  /usr/lib/python3.4/smtplib.py:242 in function __init__() [(code, msg) = self.connect(host, port)]
  /usr/lib/libreoffice/program/mailmerge.py:106 in function connect() [self.server = smtplib.SMTP(server, port,timeout=tout)]
Comment 4 linuxovios 2016-10-06 18:22:54 UTC
There is no way to set LO to use gmail outgoing server for mail merged documents.

Plese give the option to use local mail client i.e. thunderbird instead.
Comment 5 Buovjaga 2017-03-04 19:20:49 UTC Comment hidden (obsolete)
Comment 6 John Talbut 2017-09-17 09:01:09 UTC
I think this is not a problem specific to using GMail but a problem of mail-merge not being able to use SSL.  I get the same problem trying to use SSL to port 465 to a Runbox.
Comment 7 Aron Budea 2018-02-10 22:00:13 UTC
If I understand it correctly, this should work now? (can be tested with a recent 6.1 daily build from here: https://dev-builds.libreoffice.org/daily/master/ )

See Justin Luth's comment: bug 63388 comment 39.
And the following commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=036b51dbc49b533d1db773d8627d56ab86bca487
"tdf#63388: use SMTP_SSL for port 465"
Comment 8 Justin L 2018-02-12 07:10:43 UTC
(In reply to comment #0 and comment #4)
> 1. It seems that LO uses it's own mail sending function rather than the
> default email client that is installed on my machine! What on earth is that
> all about? Why doesn't it just call my default email client?
> Please give the option to use local mail client i.e. thunderbird instead

There is no standard desktop API for sending emails.  Unless you want hundreds of individual windows for each recipient, you couldn't use the default email client. It just doesn't make sense in the context of mailmerge.

In LO 6.1, SSL SMTP should work now (on port 465 only).  However, note that bug 103919 indicates that sending will stop prematurely!! A fix for that is under review.

Also note that for gmail, you probably have to enable "insecure applications". 
> Google Mail Account setting requirement:
>https://myaccount.google.com/security?utm_source=OGB#connectedapps
>You must enable less secured application.

*** This bug has been marked as a duplicate of bug 63388 ***