Download it now!
Bug 95140 - MAILMERGE: Email Test Setting failed
Summary: MAILMERGE: Email Test Setting failed
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2015-10-17 11:34 UTC by Óvári
Modified: 2019-07-19 08:24 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Mail Merge Test Account Settings Failed (119.43 KB, image/png)
2015-10-17 11:34 UTC, Óvári
Details
Mail Merge Advanced Outgoing Server Settings (87.52 KB, image/png)
2018-10-17 20:28 UTC, Óvári
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2015-10-17 11:34:47 UTC
Created attachment 119696 [details]
Mail Merge Test Account Settings Failed

Version: 5.1.0.0.alpha1+
Build ID: a9b31303b76326e0dc0043082082c5fc1dc69be9
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-16_23:54:12


At step 8 of the E-mail Merge Wizard
1. Click "Send documents"
2. Enter:
   a) Your name                     : <name>
   b) E-mail address                : <email_address>@gmail.com
   c) Server name                   : smtp.gmail.com
   d) Port                          : 587
   e) Use secure connection (SSL)   : Selected
3. Click "Server Authentication"
   a) The outgoing mail server 
      (SMTP) require authentication : Selected
   b) The outgoing mail server uses 
      the same authentication as the 
      incoming mail server server   : Selected
   c) Server name                   : pop.gmail.com
   d) Port                          : 995
   e) Type                          : POP3
   f) User name                     : <email_address>@gmail.com
   g) Password                      : <password>
4. Click "OK"
5. Click "Test Settings..."
6. Test Account Settings dialog box
   a) X Establish network connection  Failed
   b) X Find outgoing mail server     Failed
   c) Errors

LibreOffice could not connect to the outgoing mail server. Check your system's settings and the settings in LibreOffice. Check the server name, the port and the secure connections settings
--
<class 'poplib.error_proto'>: -ERR EOF, traceback follows
  C:\Program Files\LibreOffice 5\program\python-core-3.3.3\lib\poplib.py:121 in function _getline() [if not line: raise error_proto('-ERR EOF')]
  C:\Program Files\LibreOffice 5\program\python-core-3.3.3\lib\poplib.py:137 in function _getresp() [resp, o = self._getline()]
  C:\Program Files\LibreOffice 5\program\python-core-3.3.3\lib\poplib.py:93 in function __init__() [self.welcome = self._getresp()]
  C:\Program Files\LibreOffice 5\program\mailmerge.py:405 in function connect() [self.server = poplib.POP3(server, port, timeout=tout)]

Please see attached file MailMergeTestAccountSettingsFailed.png.

Any help to enable emailing within LibreOffice to work with a gmail.com email address would be appreciated. Thank you
Comment 1 Óvári 2015-10-17 11:36:20 UTC
Maybe a duplicate of bug 63388; however, bug 95140 does not freeze and provides error messages.
Comment 2 Buovjaga 2016-04-08 09:33:24 UTC
Can you test with the latest, there were a lot of changes: http://dev-builds.libreoffice.org/daily/master/Win-x86@62-merge-TDF/current/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 Óvári 2016-04-09 20:59:13 UTC
(In reply to Buovjaga from comment #2)
Unfortunately, Email Test Setting failed in:
Version: 5.2.0.0.alpha0+
Build ID: 157469896ef56720f33676222b95e81c04ab5c72
CPU Threads: 2; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-04-06_20:10:15

Perhaps having automatic configuration of email settings may help? For example, this is implemented in Thunderbird.
Comment 4 Óvári 2016-04-09 21:52:05 UTC
LibreOfficeDev could not connect to the outgoing mail server. Check your system's settings and the settings in LibreOfficeDev. Check the server name, the port and the secure connections settings
--
<class 'poplib.error_proto'>: -ERR EOF, traceback follows
  C:\Program Files (x86)\LibreOfficeDev 5\program\python-core-3.3.0\lib\poplib.py:121 in function _getline() [if not line: raise error_proto('-ERR EOF')]
  C:\Program Files (x86)\LibreOfficeDev 5\program\python-core-3.3.0\lib\poplib.py:137 in function _getresp() [resp, o = self._getline()]
  C:\Program Files (x86)\LibreOfficeDev 5\program\python-core-3.3.0\lib\poplib.py:93 in function __init__() [self.welcome = self._getresp()]
  C:\Program Files (x86)\LibreOfficeDev 5\program\mailmerge.py:405 in function connect() [self.server = poplib.POP3(server, port, timeout=tout)]

----
Output from:
Version: 5.2.0.0.alpha0+
Build ID: 157469896ef56720f33676222b95e81c04ab5c72
CPU Threads: 2; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-04-06_20:10:15
Comment 5 Robinson Tryon (qubit) 2016-05-12 00:21:01 UTC
TESTING with
LO 5.2.0.0.alpha1+
OS Version: Mac OS X 10.10.5
Build: 2016-05-11_01:01:27

(In reply to Óvári from comment #0)
> 2. Enter:
>    a) Your name                     : <name>

The Name field doesn't seem to affect my test results.

>    b) E-mail address                : <email_address>@gmail.com
>    c) Server name                   : smtp.gmail.com

smtp.googlemail.com and smtp.gmail.com appear to both work (or at least TEST) equally well for me.

>    d) Port                          : 587
>    e) Use secure connection (SSL)   : Selected
> 3. Click "Server Authentication"
>    a) The outgoing mail server 
>       (SMTP) require authentication : Selected
>    b) The outgoing mail server uses 
>       the same authentication as the 
>       incoming mail server server   : Selected
>    c) Server name                   : pop.gmail.com
>    d) Port                          : 995
>    e) Type                          : POP3
>    f) User name                     : <email_address>@gmail.com
>    g) Password                      : <password>

I tried this configuration option with SMTP, and also got 'Failed' messages:

>    c) Server name                   : imap.gmail.com
>    d) Port                          : 993
>    e) Type                          : IMAP

> 
> Any help to enable emailing within LibreOffice to work with a gmail.com
> email address would be appreciated. Thank you

Possible Fix:
Try selecting the 2nd option: "The outgoing mail server (SMTP) needs separate authentication" and fill in your email address and password. That change to the config works for me.

Ovari: I'll mark this as NEEDINFO for now. If my suggested config works for you, please change the Status to RESOLVED WORKSFORME, otherwise please change back to UNCONFIRMED and let us know if you received a different error message. Thanks!
Comment 6 Robinson Tryon (qubit) 2016-05-12 00:23:51 UTC
(In reply to Robinson Tryon (qubit) from comment #5)
> I tried this configuration option with SMTP, and also got 'Failed' messages:

Oops! That should read 'IMAP', not 'SMTP'.
Comment 7 QA Administrators 2016-11-08 12:20:48 UTC Comment hidden (obsolete)
Comment 8 Óvári 2016-11-08 19:42:41 UTC
Thank you Robinson Tryon (qubit) for your comments. I have tried to make LibreOffice email merge work, but unfortunately have been unsuccessful.

In the meantime a solution that works with Thunderbird:
  http://getthunderbird.com/
is Mail Merge by Alexander Bergmann:
  https://addons.mozilla.org/thunderbird/addon/mail-merge/

It would be nice if email merge worked with LibreOffice, hence:
Status: NEEDINFO → UNCONFIRMED

Thank you
Comment 9 Roman Kuznetsov 2018-06-13 18:42:55 UTC
Mike, i know that you love mail merge. Any opinions about this bug?
Comment 10 Adam Jems 2018-09-21 12:15:43 UTC Comment hidden (spam)
Comment 11 Dieter 2018-09-21 12:23:53 UTC Comment hidden (obsolete)
Comment 12 Mike Kaganski 2018-09-21 12:27:02 UTC Comment hidden (obsolete)
Comment 13 Óvári 2018-10-17 20:28:07 UTC
In the default LibreOffice installation, please include "Advanced Outgoing Server Settings":
* Connection Timeout
* Authentication method (Without, Login/password, OAuth2)
* Connection security (unsecure, SSL, TLS).

This setting can then be added to:
Menu Bar → Tools → Options → LibreOffice Writer → Mail Merge E-mail
The "Mail Merge Advanced Outgoing Server Settings.png" shows an image mock with the inclusion of the the gMailOOo extension.

There may also be a link to these setting in the:
Menu Bar → Tools → Mail Merge Wizard…

What do you think?

Thank you

(In reply to prrvchr from bug 63388 comment 17)
> I make an extension gMailOOo:
> 
> https://github.com/prrvchr/gMailOOo?files=1
> 
> Who implements ssl and tls as well as OAuth2.
> Uno api uno seems obsolete and requires an upgrade.
Comment 14 Óvári 2018-10-17 20:28:59 UTC
Created attachment 145791 [details]
Mail Merge Advanced Outgoing Server Settings
Comment 15 Bean Smith 2019-01-08 09:40:29 UTC Comment hidden (spam)
Comment 16 Xisco Faulí 2019-07-08 15:47:58 UTC
Hi Óvári,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 17 Óvári 2019-07-09 05:12:52 UTC
(In reply to Xisco Faulí from comment #16)
Not sure how to use LibreOffice to do this anymore as the menus/dialogs/etc have changed. Thank you
Comment 18 James Bondela 2019-07-18 11:20:49 UTC Comment hidden (spam)
Comment 19 abdul aziz 2019-07-18 12:54:40 UTC Comment hidden (spam)
Comment 20 prrvchr 2019-07-19 08:24:58 UTC
Hi all,

gMailOOo is now obsolete, (no more development), if you want to use OAuth2 protocol you must now use: OAuth2OOo

See my comment: https://bugs.documentfoundation.org/show_bug.cgi?id=63388