Download it now!
Bug 58831 - Embeded pictures in doc file incorrect size in PDF export. Works fine with OO 3.2.0
Summary: Embeded pictures in doc file incorrect size in PDF export. Works fine with O...
Status: RESOLVED DUPLICATE of bug 104252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf, filter:pdf
Depends on:
Blocks: PDF-Export EMF-WMF
  Show dependency treegraph
 
Reported: 2012-12-28 16:27 UTC by Gibey
Modified: 2016-12-28 10:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File with an image table (46.00 KB, application/msword)
2012-12-28 16:27 UTC, Gibey
Details
Result with LO (432.17 KB, application/pdf)
2012-12-28 16:28 UTC, Gibey
Details
Result with LO (432.17 KB, application/pdf)
2012-12-28 16:36 UTC, Gibey
Details
File with an image table (46.00 KB, application/msword)
2012-12-28 16:37 UTC, Gibey
Details
PDF from LO 4.4.2.2 (162.08 KB, application/pdf)
2015-04-18 14:11 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gibey 2012-12-28 16:27:12 UTC
Created attachment 72219 [details]
File with an image table

Incorrect size for embeded image in doc file when exported as PDF.
Result is bigger than original.
Comment 1 Gibey 2012-12-28 16:28:22 UTC
Created attachment 72220 [details]
Result with LO
Comment 2 Gibey 2012-12-28 16:36:39 UTC
Created attachment 72221 [details]
Result with LO
Comment 3 Gibey 2012-12-28 16:37:59 UTC
Created attachment 72222 [details]
File with an image table
Comment 4 Laurent Bonnaud 2013-02-08 14:21:50 UTC
I have a similar problem and it still occurs with LO 4.0.
Comment 5 Laurent Bonnaud 2013-11-10 13:08:00 UTC
My problem is gone with LO 4.1.2.  Could other people test please ?
Comment 6 Gordo 2015-04-18 14:11:38 UTC
Created attachment 114880 [details]
PDF from LO 4.4.2.2

The attached pdf shows the correct image size.  However, there are now parts of the image missing.  The table borders are there but the text is missing.  SumatraPDF was used to view the file.

Windows Vista 64
Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 7 QA Administrators 2016-09-20 10:17:46 UTC Comment hidden (obsolete)
Comment 8 Gibey 2016-09-20 12:00:27 UTC
Problem persist with LO 5.2.2.1 and Windows 7 SP1 (32 bits)
Comment 9 Telesto 2016-12-27 15:31:56 UTC
Table contented is EMF based
Comment 10 Cor Nouws 2016-12-28 09:59:33 UTC
Export to PDF is fine in Version: 5.4.0.0.alpha0+
Build ID: 702c8c59a5d5dfe839a44da511971470354e2a41
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-12-27_01:47:01
Locale: nl-NL (nl_NL.UTF-8); Calc: group

Table size correct and all content visible too.

Can you please test a recent daily?
thanks - Cor
Comment 11 Telesto 2016-12-28 10:49:03 UTC
@CorNouws 
The PDF export is broken for me. Tables in the exported PDF are mostly empty (page 1). The issue seems exactly the same as bug 104252 (with a better analysis). I'm marking this one as a dupe. 

Version: 5.4.0.0.alpha0+
Build ID: d0288a482a3dc0f50f535565e4c66a95bb140942
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_23:25:18
Locale: nl-NL (nl_NL); Calc: CL

*** This bug has been marked as a duplicate of bug 104252 ***