Bug 59025 - : Add-On 1 toolbar is displayed unexpectedly
Summary: : Add-On 1 toolbar is displayed unexpectedly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other Linux (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: BSA target:4.0.1
Keywords: regression
: 59469 59796 59797 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-04 15:20 UTC by webofht-libreofficebugs002
Modified: 2013-09-02 13:46 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Add-On 1 toolbar (60.09 KB, image/png)
2013-01-04 15:20 UTC, webofht-libreofficebugs002
Details
Add-on 2 displayed (47.10 KB, image/png)
2013-02-09 06:39 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description webofht-libreofficebugs002 2013-01-04 15:20:50 UTC
Created attachment 72512 [details]
Add-On 1 toolbar

Problem description: The Add-On 1 toolbar is displayed. This is not the expected behaviour.

Steps to reproduce:
1. The operating system used is Linux debian 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux.
2. Delete the user profile first by the command: rm -r ~/.config/lodev
3. Install LibreOffice version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0).
4. Start LibreOffice Writer.
5. The Add-On 1 toolbar is displayed.

Current behavior: The Add-On 1 toolbar is displayed.

Expected behavior: The Add-On 1 toolbar should be deleted. This toolbar does not help the user to do any common tasks.

I am attaching the screenshot.

Regards,
C. H. D.
              
Operating System: Debian
Version: 4.0.0.0.beta2
Last worked in: 3.6.3.2 release
Comment 1 Jean-Baptiste Faure 2013-01-05 12:41:37 UTC
This toolbar seems to be the LibreLogo toolbar.

Laszlo: something for you ?

Best regards. JBF
Comment 2 Ruslan Kabatsayev 2013-01-16 14:44:59 UTC
*** Bug 59469 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Hackert 2013-01-20 18:10:06 UTC
Hello C.H.D., *,
I can confirm this bug with Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799 and Germanophone lang- as well as helppack unter Debian Testing AMD64 ... :( @Laszlo: Is there a possibility to change it? In the Germanophone UI under "View – Toolbars" (Ansicht – Symbolleisten) there is also "Add-On 1" instead of "Logo" or "LibreLogo" ... :( I have tried to find it in Pootle, but the only one, that seems to fit is https://translations.documentfoundation.org/de/libo_ui/translate.html#search=Add-On&sfields=source,target&unit=28760729 ... :(
Sorry for the inconvenience and I HTH
Thomas.
Comment 4 László Németh 2013-02-05 10:33:08 UTC
I have also detected it on an x64 platform (3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux).

Stephan: Is this toolbar registration problem maybe related to the x64 platform?

Jean-Baptiste, Thomas: Sorry, I didn't detect this issue before.
Comment 5 Stephan Bergmann 2013-02-05 15:25:47 UTC
share/registry/librelogo.xcd fails to record a dependency on share/registry/writer.xcd.  Whether or not that leads to the described problem depends on which of the two files the OS happens to report first when iterating through the share/registry/ directory.

This had been fixed on master towards LO 4.1 with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=82c53d537a05dadf4d7fd7ea41292897bf2d47c7> "Missing dependency."  I have now requested a backport of that fix to libreoffice-4-0 with <https://gerrit.libreoffice.org/#/c/2002/>.
Comment 6 Not Assigned 2013-02-05 18:31:48 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac4b9e2e6bb2c5f9fbd18cb05a11e9e70650abb7&h=libreoffice-4-0

fdo#59025: Missing dependency


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 László Németh 2013-02-06 15:30:52 UTC
@All, Stephan: thanks for your report and the fix! László
Comment 8 László Németh 2013-02-06 15:32:34 UTC
*** Bug 59796 has been marked as a duplicate of this bug. ***
Comment 9 László Németh 2013-02-06 15:33:38 UTC
*** Bug 59797 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2013-02-09 06:39:59 UTC
Created attachment 74469 [details]
Add-on 2 displayed

On pc Debian x86-64 with 4.0 branch updated yesterday
commit 0dea073b03de7a40414150e8b0ca0814ca106ede
Author: László Németh <nemeth@numbertext.org>
Date:   Thu Feb 7 10:53:35 2013 +0100

I still reproduce this kind of problem.

Don't know if there's a link but here are console logs:
warn:configmgr:7054:1:/home/julien/compile-libreoffice/libo_4_0/configmgr/source/xcuparser.cxx:350: unknown component "org.openoffice.Office.UI.WriterWindowState" in "file:///home/julien/compile-libreoffice/libo_4_0/solver/unxlngx6.pro/installation/opt/program/../share/registry/librelogo.xcd"
warn:configmgr:7054:1:/home/julien/compile-libreoffice/libo_4_0/configmgr/source/xcuparser.cxx:195: bad set node <prop> member in "file:///home/julien/.config/libreoffice/4/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luye2ck7.tmp/Addons.xcu"
warn:configmgr:7054:1:/home/julien/compile-libreoffice/libo_4_0/configmgr/source/xcuparser.cxx:195: bad set node <prop> member in "file:///home/julien/.config/libreoffice/4/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luye2ck7.tmp/Addons.xcu"
warn:legacy.osl:7054:1:/home/julien/compile-libreoffice/libo_4_0/tools/source/fsys/urlobj.cxx:3407: INetURLObject::checkHierarchical vnd.sun.star.expand
... (the same last line several times)
Comment 11 Julien Nabet 2013-02-09 06:40:59 UTC
Stephan: is it another case and I should open a new bugtracker or should we just reopen this one?
Comment 12 Julien Nabet 2013-02-09 06:41:18 UTC
Comment on attachment 74469 [details]
Add-on 2 displayed

mimetype fixed
Comment 13 Julien Nabet 2013-02-09 07:09:05 UTC
Stephan: forget about my previous comment, I made some new tests with master sources.
By default Logo is included in main toolbar. If I undock it, I can see "Logo" as title.

I'll build from scratch 4.0 branch another time to see.

Sorry for the noise.
Comment 14 Adam 2013-02-10 16:58:28 UTC
I have tested Version 4.0.1.0+ (Build ID:4db4976033e55e35eb779e0f9083981f8a2b2cb)

and can confirm the 'Add-On 1 toolbar' bug from the original report has been fixed.
Comment 15 Jean-Baptiste Faure 2013-02-10 18:23:43 UTC
Indeed the bug is fixed for me in my build of Version 4.0.1.0+ (Build ID: 4db4976033e55e35eb779e0f9083981f8a2b2cb). However that is visible only with a new fresh profile because the old registrymodifications.xcu is corrupted in the sense that several lines related to librelogo are missing. As I did not want rebuild my profile, I fixed the problem by copying the missing lines from the new registrymodifications.xcu to the old one in the same place.

Best regards. JBF
Comment 16 Julien Nabet 2013-02-18 22:41:40 UTC
According to 3 last comments, put to VERIFIED
Comment 17 webofht-libreofficebugs002 2013-03-09 05:30:48 UTC
I verify that this issue is fixed.

$ cat /opt/libreoffice4.0/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=84102822e3d61eb989ddd325abf1ac077904985
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductBuildid=2
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation
Comment 18 Heinz Repp 2013-08-22 10:52:09 UTC
Seems that on the 4.1 branch the bug fix did not land everywhere. I am here on a German Debian testing x64 system with stock Libreoffice from the x64 deb packages.

cat /opt/libreoffice4.1/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=89ea49ddacd9aa532507cbf852f2bb22b1ace28
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductMajor=410
ProductMinor=
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation

Ansicht/Symbolleisten (View/Toolbars) has a "Add-On 1" listed, which is the Logo Toolbar. Starting /opt/libreoffice4.1/program/swriter from the terminal shows no output on the console other than returning to the prompt.

On a Windows system with stock Libreoffice 4.1.0 and on a Ubuntu 12.04 LTS with Libreoffice 4.1.0 from the Libreoffice PPA the Logo toolbar is listed correctly as "Logo".
Comment 19 Stephan Bergmann 2013-08-22 12:31:33 UTC
(In reply to comment #18)
> Seems that on the 4.1 branch the bug fix did not land everywhere. I am here
> on a German Debian testing x64 system with stock Libreoffice from the x64
> deb packages.
[...]
> On a Windows system with stock Libreoffice 4.1.0 and on a Ubuntu 12.04 LTS
> with Libreoffice 4.1.0 from the Libreoffice PPA the Logo toolbar is listed
> correctly as "Logo".

Heinz, please follow up on this in Debian's bugtracker then.