Bug Hunting Session
Bug 59797 - LibreLogo: view -> toolbars: LibreLogo has name "Add-on 1"
Summary: LibreLogo: view -> toolbars: LibreLogo has name "Add-on 1"
Status: RESOLVED DUPLICATE of bug 59025
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-24 10:56 UTC by Cor Nouws
Modified: 2013-02-06 19:56 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2013-01-24 10:56:01 UTC
actually in Dutch it is "Invoegtoepassing".
It's a default name given to a toolbar for an extension

Tested in 400 rc2
Comment 1 Jorendc 2013-01-24 18:41:44 UTC
@Cor: How to 'reproduce'? I can't find "Invoegtoepassing" in my Dutch 4.0.0.2 rc2 Mac OSX 10.8.2.
Comment 2 Cor Nouws 2013-01-24 22:10:16 UTC
(In reply to comment #1)
> @Cor: How to 'reproduce'? I can't find "Invoegtoepassing" in my Dutch
> 4.0.0.2 rc2 Mac OSX 10.8.2.

The toolbar is in View > Toolbars...
Comment 3 Gerry 2013-01-26 13:27:59 UTC
Confirmed. The name of the Logo toolbar is "Add-on 1" instead of "Logo Toolbar"

This would be in fact nice if it could be fixed for LibreOffice 4.0.
Comment 4 Jorendc 2013-01-26 20:40:37 UTC
I certainly overlooked something while trying to reproduce. I'm sorry for that. I can confirm this bug :-).

I also mark this bug as priority 'highest' 'critical'. 

Following https://wiki.documentfoundation.org/ReleaseNotes/4.0 this feature is developed by László and András; Therefore I add you both to CC.
Comment 5 Jorendc 2013-01-26 20:44:00 UTC
The closest match I can find where this string is generated: http://opengrok.libreoffice.org/xref/core/framework/source/classes/resource.src
Comment 6 Andras Timar 2013-01-26 21:00:54 UTC
I cannot reproduce it under Window 7 with 4.0.0.2 RC2, I see Beeld - Werkbalken - Logo. And guys, please be reasonable, please do not escalate trivial UI bugs to the highest forums. It is not critical, it is not a MAB.
Comment 7 Mihkel Tõnnov 2013-01-26 21:07:11 UTC
Confirmed once more on Linux, unconfirmed in Windows. On my Linux system, I see "Lisa 1" (Estonian for "Add-on 1") -- regardless of LibO UI language, btw --, but in Win XP it's "Logo".
Comment 8 Jorendc 2013-01-26 21:13:31 UTC
(In reply to comment #6)
> I cannot reproduce it under Window 7 with 4.0.0.2 RC2, I see Beeld -
> Werkbalken - Logo. And guys, please be reasonable, please do not escalate
> trivial UI bugs to the highest forums. It is not critical, it is not a MAB.

I'm sorry, but I don't agree with that. 

If you can't find a feature that is widespread in the media ... I think it's a blocker. This is not just 'a UI bug' ... a normal user just CAN'T find LibreLogo (it seems like Windows isn't affected). Therefore it makes it for a regular user unusable.

I'll not start a prioritizing-war, but I hope you understand my point of view and why I add that to the mab-list and set this priority. I still would like to mark this bug higher than usual. 

Kind regards,
Joren
Comment 9 Julien Nabet 2013-01-26 21:19:57 UTC
On pc Debian x86-64 with 4.0 branch updated today, I've got Add-on 2 (yes "2" not "1")
I noticed these console logs:
warn:configmgr:25551:1:/home/julien/compile-libreoffice/libo_4_0/configmgr/source/xcuparser.cxx:350: unknown component "org.openoffice.Office.UI.WriterWindowState" in "file:///home/julien/compile-libreoffice/libo_4_0/solver/unxlngx6.pro/installation/opt/program/../share/registry/librelogo.xcd"
warn:configmgr:25551:1:/home/julien/compile-libreoffice/libo_4_0/configmgr/source/xcuparser.cxx:195: bad set node <prop> member in "file:///home/julien/.config/libreoffice/4/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luf9dve7.tmp/Addons.xcu"
warn:configmgr:25551:1:/home/julien/compile-libreoffice/libo_4_0/configmgr/source/xcuparser.cxx:195: bad set node <prop> member in "file:///home/julien/.config/libreoffice/4/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luf9dve7.tmp/Addons.xcu"
Comment 10 Andras Timar 2013-01-26 22:54:20 UTC
I've just built one from libreoffice-4-0-0 branch under Linux. I started with a resh profile (I removed ~/.config/libreoffice). I could not reproduce the issue.
Comment 11 László Németh 2013-02-06 15:33:38 UTC
Thanks again! László

*** This bug has been marked as a duplicate of bug 59025 ***
Comment 12 Cor Nouws 2013-02-06 19:56:24 UTC
(In reply to comment #11)
> Thanks again! László
> 
> *** This bug has been marked as a duplicate of bug 59025 ***

Are you shure László ? This issue is about the name of the toolbar. Which is not "LibreLogo", but "Add on 1" or something like that.