Download it now!
Bug 59236 - Can't paste image from MS Office (URI format is wrong)
Summary: Can't paste image from MS Office (URI format is wrong)
Status: RESOLVED DUPLICATE of bug 35176
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-11 09:52 UTC by Dennis Roczek
Modified: 2014-01-28 14:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Copy 'n paste of Word or Outlook 2010 produces missing images (42.35 KB, image/png)
2013-01-11 09:52 UTC, Dennis Roczek
Details
Outlook 2013 copy & paste in LibO Writer (42.36 KB, image/png)
2014-01-16 09:36 UTC, Dennis Roczek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Roczek 2013-01-11 09:52:30 UTC
Created attachment 72844 [details]
Copy 'n paste of Word or Outlook 2010 produces missing images

Today I wanted to save an email from Outlook 2010 (because of an offline exchange server) by copy 'n pasting the mail into LO Writer. Despite some minor formatting issues (additional 0.5 line space between my signature), my main problem was, that the images were not embedded correctly because they are included with the file:// URI (see screenshot) and saved at file:///C:\Users\roczekd\AppData\Local\Temp\msohtmlclip1\01\clip_image002.png

when "right clicking" on the image and "saving Image as" the image wanted to be saved as C:%5CUsers%5Croczekd%5CAppData%5CLocal%5CTemp%5Cmsohtmlclip1%5C01%5Cclip_image002.png

So LO doesn't correctly recognize the file location.
Comment 1 Robinson Tryon (qubit) 2013-12-25 02:20:46 UTC
(In reply to comment #0)
> main problem was, that the images were not embedded correctly because they
> are included with the file:// URI (see screenshot) and saved at
> file:///C:\Users\roczekd\AppData\Local\Temp\msohtmlclip1\01\clip_image002.png

Hi Roczek,
Could you please test to see if you still have the same problem with modern builds of LibreOffice?
https://www.libreoffice.org/download/
https://www.libreoffice.org/download/pre-releases/

If this problem persists after re-testing, please change bug status from NEEDINFO back to UNCONFIRMED and we'll try to get someone with a similar Windows environment to help triage this bug.
Comment 2 Dennis Roczek 2014-01-16 09:36:13 UTC
Created attachment 92210 [details]
Outlook 2013 copy & paste in LibO Writer

The screenshot was taken after copy and paste the text from a email out of Outlook 2013 into LibreOffice 4.1.3.2 

As you can see, the image is displayed correctly in the menu for modifying the image location!
Comment 3 Dennis Roczek 2014-01-24 12:22:16 UTC
as the bug still exists I change the bug status from NEEDINFO to NEW
Comment 4 retired 2014-01-24 12:39:42 UTC
 Roczek: with which LO version did you test? 4.2.0.3 just arrived. Is this bug still valid / reproducible with  the latest pre-release 4.2.0.2: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile
Comment 5 Dennis Roczek 2014-01-24 13:49:51 UTC
just installed 4.2.0.3 on a new laptop (win8.1) - so a really fresh profil: problem still exists...
Comment 6 Maxim Monastirsky 2014-01-27 21:27:50 UTC
An ancient bug reported back in 2003 against OpenOffice 1.1 (!) (Link provided in 'See Also').
Comment 7 Maxim Monastirsky 2014-01-27 21:29:34 UTC
*** Bug 73045 has been marked as a duplicate of this bug. ***
Comment 8 Maxim Monastirsky 2014-01-27 21:30:15 UTC
*** Bug 73912 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Monastirsky 2014-01-28 14:16:31 UTC

*** This bug has been marked as a duplicate of bug 35176 ***