Bug Hunting Session
Bug 73912 - Pasting of images under Microsoft Windows is broken
Summary: Pasting of images under Microsoft Windows is broken
Status: RESOLVED DUPLICATE of bug 35176
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-22 04:11 UTC by Luke
Modified: 2016-05-17 00:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows results of pasting image from Word to Writer, Paint, and Gimp (409.00 KB, image/jpeg)
2014-01-22 04:11 UTC, Luke
Details
Test doc used to copy image (191.00 KB, application/msword)
2014-01-22 04:13 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-01-22 04:11:45 UTC
Created attachment 92562 [details]
Shows results of pasting image from Word to Writer, Paint, and Gimp

LibreOffice support for Copying and Pasting of images under Microsoft Windows is broken.  
Steps to reproduce:
1.	Open a document containing images with Word 2007. 
2.	Copy image into clipboard
3.	Past image into Writer
Expected results:
Images is successfully pasted into Write
Actual results:
A placeholder showing the image’s URL in the file system is shown.  Ex: file://C:\Users\AAA\Appdata\Local\Temp\clip\01\image001.jpg

When tested with other Windows application. 
Gimp : PASS
WordPad: PASS
Paint: PASS
Draw: PASS
Comment 1 Luke 2014-01-22 04:13:32 UTC
Created attachment 92563 [details]
Test doc used to copy image
Comment 2 retired 2014-01-23 07:22:58 UTC
Interesting. Open test document with MS Word right-click image > copy

Open LO 4.3 latest right-click > paste

Nothing.

Confirmed:4.2.0.2:OSX

Lowering version field since that is displaying the first version the issue appeared in and setting OS to All, since reproduced on OSX as well.
Comment 3 Jean-Baptiste Faure 2014-01-25 09:51:35 UTC
Comment on attachment 92562 [details]
Shows results of pasting image from Word to Writer, Paint, and Gimp

fixed mime type
Comment 4 Jean-Baptiste Faure 2014-01-25 09:54:29 UTC
Does it work if you use some alternative option in paste special ?

Does it work in LO 4.1.x ?

Best regards. JBF
Comment 5 Luke 2014-01-27 14:15:51 UTC
I did some research and this is  an ancient bug that goes back to OpenOffice 1.1 https://issues.apache.org/ooo/show_bug.cgi?id=14613

With LO 4.1.4

1) Paste normal:
Result - FAIL

2) Paste special (GDI)
Result - PASS

3) Paste special (GDI)
Result - FAIL 
nothing was pasted

4) Paste special (html)
Result - FAIL
same as 1)

It appears that the paste detection code in Writer and Calc is broken. It is using the html format instead of GDI.
Comment 6 Luke 2014-01-27 14:21:35 UTC
The post should read:
3) Paste special (Bitmap)
Comment 7 Maxim Monastirsky 2014-01-27 21:30:15 UTC

*** This bug has been marked as a duplicate of bug 59236 ***
Comment 8 Luke 2016-05-17 00:58:58 UTC

*** This bug has been marked as a duplicate of bug 35176 ***