Bug 59248 - Writer and Fax wizards do not work
Summary: Writer and Fax wizards do not work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: highest critical
Assignee: Stephan Bergmann
QA Contact:
URL:
Whiteboard: target:4.1.0 target:4.0.0.2
Keywords:
: 59166 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-11 16:11 UTC by Petr Mladek
Modified: 2013-01-29 12:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Mladek 2013-01-11 16:11:53 UTC
File/Wizrads/Letter  and File/Wizards/Fax does nothing in LO-4.0.0.1 build on Linux x86_64.
Comment 1 Stephan Bergmann 2013-01-11 16:20:59 UTC
Works without problem (apart from a noticeable delay between selecting the menu entry and having the corresponding dialog show up) with my local (--enable-dbgutil) current libreoffice-4-0 build on Linux x86_64 (Fedora 17).
Comment 2 Jean-Baptiste Faure 2013-01-11 20:30:06 UTC
I reproduce the problem with Version 4.0.0.1+ (Build ID: f49e469d93749547520ae34c52d26f17bcc32cf) under Ubuntu 12.04 x86-64 FR.

Best regards. JBF
Comment 3 Xisco Faulí 2013-01-14 10:50:11 UTC
it can be reproducible on master and on 4.0 RC1.
Something has been changed in the python3 implementation and now it fails to import API elements.

Simple way to test it:

import uno
from com.sun.star.awt.VclWindowPeerAttribute import OK
Comment 4 Stephan Bergmann 2013-01-14 13:06:53 UTC
> Works without problem (apart from a noticeable delay between selecting the
> menu entry and having the corresponding dialog show up) with my local
> (--enable-dbgutil) current libreoffice-4-0 build on Linux x86_64 (Fedora 17).

Hm, started to fail for me too now after a fresh local master build.
Comment 5 Not Assigned 2013-01-14 13:09:05 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=155600869800a0b51f9787b8a1879d3c680342c3

fdo#59248: Remove remaining dangling view of ViewHandler.py



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Stephan Bergmann 2013-01-14 13:53:03 UTC
Requested backport to libreoffice-4-0 as <https://gerrit.libreoffice.org/#/c/1670/>.
Comment 7 Not Assigned 2013-01-14 16:35:38 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5c1b435378e1e4c99416eb865477123ab596c85&h=libreoffice-4-0

fdo#59248: Remove remaining dangling view of ViewHandler.py


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Jean-Baptiste Faure 2013-01-14 20:49:00 UTC
Verified in Version 4.0.0.1+ (Build ID: e523186e59632ef824eb3262edd0c63e388af6e) under Ubuntu 12.04 x86-64.
Each wizard starts as expected.

Best regards. JBF
Comment 9 Caolán McNamara 2013-01-16 15:22:00 UTC
*** Bug 59166 has been marked as a duplicate of this bug. ***
Comment 10 Jorendc 2013-01-27 17:51:56 UTC
Still reproducible using Mac OSX 10.8.2. Both Letter and Fax doesn't open...
LibreOffice Versie 4.0.0.2 .0.2 (Bouw-id: 408fe71bd18616c467b3dcd7ab6756528ffcae2)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-22_15:37:59
Dutch UI

Therefore I mark this as REOPENED.

Note:
Also tested with Linux Mint 14 x64: NOT reproducible using 4.0.0.2 rc2.
Comment 11 Jorendc 2013-01-27 17:53:18 UTC
(In reply to comment #10)
> Still reproducible using Mac OSX 10.8.2. Both Letter and Fax doesn't open...

PS: I did reset my user profile and completely re-install LO, still reproducible
Comment 12 Stephan Bergmann 2013-01-29 09:57:56 UTC
I can reproduce this, too, with <http://download.documentfoundation.org/libreoffice/testing/4.0.0/mac/x86/LibreOffice_4.0.0.2_MacOS_x86.dmg> on Mac OS X 10.7.5.
Comment 13 Stephan Bergmann 2013-01-29 12:19:27 UTC
(In reply to comment #12)
> I can reproduce this, too, with
> <http://download.documentfoundation.org/libreoffice/testing/4.0.0/mac/x86/
> LibreOffice_4.0.0.2_MacOS_x86.dmg> on Mac OS X 10.7.5.

I can /not/ reproduce it with my own local build of libreoffice-4-0-0.  I tracked it down to a general problem with Python in the above "official" LO build, see bug 60012.  (So marking this bug as fixed again.)