Bug 59471 - UI: Scroll through sheet tabs by mouse wheel not possible
Summary: UI: Scroll through sheet tabs by mouse wheel not possible
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Tomaz Vajngerl
QA Contact:
URL:
Whiteboard: BSA target:4.5.0
Keywords:
: 90945 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-16 15:05 UTC by WoodForWood
Modified: 2015-07-05 08:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description WoodForWood 2013-01-16 15:05:55 UTC
Problem description: 
Scroll command (mouse or touchpad) whilst hovering over the tabs for different sheets does not scroll left or right.  When using multiple sheets, this is very useful (and available on other, M$ products) in order to scroll then merely select the appropriate tab, rather than clicking Ctrl-PgDn/PgUp repeatedly

Steps to reproduce:
1. Hover over tabs
2. Scroll Up/Down/L/R using touchpad gesture or Mouse wheel turn
3. Nothing happens

Current behavior:
Nothing happens.  I end up flicking through each tab in sequence.

Expected behavior:
Up &  Left scrolls move visible tabs to right (without selecting them).
Right & Down scrolls move visible tabs to left (without selecting them).

Thanks, Bughunters
Operating System: Ubuntu
Version: 3.5.4 release
Comment 1 Rainer Bielefeld Retired 2013-01-16 15:41:24 UTC
Indeed, that would be useful for documents with lot of sheets.

That never worked in LibO / OOo

May be we should have a separate bug for the corresponding function in Draw / Impress?!
Comment 2 WoodForWood 2013-01-17 12:07:27 UTC
Thanks for viewing/editting.

Perhaps this it could be changed from Calc to All LibO products rather than separate bugs, (depends upon how people find bugs, I guess, or perhaps other bugs pointing to this generalised bug) as it would be universally handy where tabs are used.  It exists in Firefox and other programs and would good to see it as standard.
Comment 4 raal 2015-04-29 18:21:16 UTC
*** Bug 90945 has been marked as a duplicate of this bug. ***
Comment 5 Mike §chinagl 2015-05-21 16:16:53 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

The tab bar can be scrolled with the mouse wheel now. tdf#59471
Comment 6 pierre-yves samyn 2015-05-23 09:55:12 UTC
Hi

(In reply to Mike §chinagl from comment #5)
> This bug fix is mentioned in the release notes of the coming LibreOffice 5.0
> (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0).
> Therefore it would be wonderful if this feature really worked well,
> otherwise it should not be mentioned in the release notes. In the notes it
> reads:
> 
> The tab bar can be scrolled with the mouse wheel now. tdf#59471

This feature works well on my platform:
Windows 7/64 & Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: fr-FR (fr_FR)

It is only effective if all the tabs can not be displayed. I have completed the Release Notes accordingly.

Regards
Pierre-Yves
Comment 7 Adolfo Jayme 2015-05-23 11:20:36 UTC
(In reply to pierre-yves samyn from comment #6)
> It is only effective if all the tabs can not be displayed

Well, that’s kind of expected… why would you want a scrolling tab bar if nothing can be scrolled? ;-)
Comment 8 pierre-yves samyn 2015-05-23 11:41:43 UTC
(In reply to Adolfo Jayme from comment #7)
> Well, that’s kind of expected… why would you want a scrolling tab bar if
> nothing can be scrolled? ;-)

Well, I think you missed my first sentence: "This feature works well"  ;-)

The very fact that Mike asks the question shows that an explanation was necessary
Comment 9 Adolfo Jayme 2015-07-05 08:53:53 UTC
(In reply to pierre-yves samyn from comment #8)
> The very fact that Mike asks the question shows that an explanation was
> necessary

Nah, it seems he took an automatic approach to spam many bug reports with the same comment, so I wouldn’t be so sure.