Download it now!
Bug 59553 - Support HQ QuickLook previews on all ODF file types
Summary: Support HQ QuickLook previews on all ODF file types
Status: RESOLVED DUPLICATE of bug 35361
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2013-01-18 10:59 UTC by r.vauchez
Modified: 2014-01-29 14:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Quick Look can't show ODS document content, but can show XLS document content (355.55 KB, image/png)
2013-01-18 10:59 UTC, r.vauchez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description r.vauchez 2013-01-18 10:59:27 UTC
Created attachment 73241 [details]
Quick Look can't show ODS document content, but can show XLS document content

Problem description: 

Quick look is not supported

Steps to reproduce:
1. ....click on a ODS document in the finder
2. ....press the space bar or control-click on it and select Quick Look
3. ....

Current behavior:

We have a preview of the app icon

Expected behavior:

We should view a preview of the document content

              
Operating System: Mac OS X
Version: 3.6.4.3 release
Comment 1 Rainer Bielefeld Retired 2013-01-18 12:20:56 UTC
Semms NOTOURBUG?

@r.vauchez:
a) Why do you think that it is a LibO problem? 
b) What is your experience with .odt and .odg, ...
c) What is your experience with documents created from (A)OOo?
Comment 2 Alex Thurgood 2013-01-18 15:26:37 UTC
Can't reproduce on OSX 10.8.2.

I can see the preview of the ODS file as I cycle through a folder. If I click on the spacebar, it displays a preview of the ODS file.

@Rainer : this would be a bug of the LO spotlight plugin, but like I said, I can not reproduce.

Alex
Comment 3 Alex Thurgood 2013-01-18 15:33:48 UTC
Setting as worksforme.

@r.vauchez : If there is something more specific that we do not know about, then by all means, please provide that information, thanks.


Alex
Comment 4 r.vauchez 2013-01-18 16:39:25 UTC
It works with ODT (can see the content preview) but not with ODS and ODP (can see only the icon preview).
I run 10.8.2 too with the LibreOffice 3.6.4.3 with the French language pack.

It's strange that it works for Alex.

Romain


Le 18 janv. 2013 à 13:20, bugzilla-daemon@freedesktop.org a écrit :

> Rainer Bielefeld changed bug 59553 
> What	Removed	Added
> Status	UNCONFIRMED	NEEDINFO
> CC	  	LibreOffice@bielefeldundbuss.de
> Summary	VIEWING: Quick Look            	Quick Look can't show ODS document content            
> Ever confirmed	  	1
> 
> Comment # 1 on bug 59553 from Rainer Bielefeld
> Semms NOTOURBUG?
> 
> @r.vauchez:
> a) Why do you think that it is a LibO problem? 
> b) What is your experience with .odt and .odg, ...
> c) What is your experience with documents created from (A)OOo?
> 
> You are receiving this mail because:
> You reported the bug.
Comment 5 Alex Thurgood 2013-01-21 17:42:21 UTC
Sorry, my bad, I should have tested with a multipage sheet. Indeed, I can reproduce the lack of preview of the pages. I took the iconified view of the sheet to be the preview in a single page sheet - sorry again.

Confirming and re-opening.

No idea who should look at this though on the dev team.
@Romain : it might be a limitation of the OS?



Alex
Comment 6 Emir Sarı 2013-01-21 18:37:55 UTC
For OpenDocument file types Apple provides an ODT QL plugin. TextEdit can also open ODT files as well. But for the other OpenDocument file types there is no support. 

NeoOffice has a QL plugin that can preview other ODF files, but in order for it to work correctly, one should save the file in NeoOffice, since it generates an embedded PDF image of the document, so that it can be displayed with 100% accuracy. LO and AOO creates low quality PNG previews, so only a small preview of the document inside the app icon is shown. 

Therefore this is not a bug, in fact an enhancement request, since LO do not have such feature.
Comment 7 Emir Sarı 2013-01-21 18:54:17 UTC
The strange thing is, I've created an ODT file on TextEdit with some text in it, and it seems that ODT preview is broken too. It displays nothing but an empty white file icon. 

Can anyone confirm this using TextEdit?
Comment 8 retired 2013-09-26 17:29:55 UTC

*** This bug has been marked as a duplicate of bug 35361 ***