Bug 59608 - Use addons.mozilla.org URL for getting Personas instead of getpersonas.com
Summary: Use addons.mozilla.org URL for getting Personas instead of getpersonas.com
Status: RESOLVED DUPLICATE of bug 63498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-01-20 01:00 UTC by Gary Kwong [:gkw]
Modified: 2016-04-24 19:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gary Kwong [:gkw] 2013-01-20 01:00:21 UTC
getpersonas.com will be merged into addons.mozilla.org in the future. Please get the dialog in Options -> Personalization -> Select Persona to accept addons.mozilla.org URLs instead.

For more information, please visit:
https://bugzilla.mozilla.org/show_bug.cgi?id=741826
Comment 1 Adolfo Jayme 2013-01-26 19:54:58 UTC
(Part of the process of merging getpersonas.com and addons.mozilla.org involves the renaming of "Personas" into "themes" (and existing Mozilla themes into "Full Themes". We should consider dropping the word "Personas" from LibreOffice's UI.)
Comment 2 Jean 2013-04-13 13:19:40 UTC
With this little change in mozilla's URL, the Personas feature simply stops working !
I think the importance is major, because this feature is pushed in the LibreOffice's website.
Comment 3 Pedro 2013-04-16 14:39:30 UTC
Migration to addons.mozilla.org (also referred to as ADO) seems to be completed. Pressing the "Visit Firefox Personas" button in LibreOffice redirects to https://addons.mozilla.org/en-US/firefox/themes/

Unfortunately pasting a link of a theme e.g.
https://addons.mozilla.org/en-US/firefox/addon/libreoffice-4-green/
or
https://addons.mozilla.org/en-US/firefox/addon/10900/

is not accepted by LibreOffice in the Persona address field
Comment 4 MagicVince 2013-04-21 10:33:18 UTC
Why there's no way from the UI to install himself a local persona?

I confirm persona stop working when getpersonas.com move to addons.mozilla.org
Comment 5 Pedro 2013-04-22 00:15:03 UTC
Bug fixed in the Master branch

Tested with Version: 4.1.0.0.alpha0+
Build ID: 288c8b9d59024897e88b55b9001f9922998d130
under Windows XP x86
Comment 6 Pedro 2013-04-24 10:01:31 UTC
Although this bug is fixed in Master it should be cherry picked to 4.0.3 ASAP since Marketing made a big deal about this new feature and now it is broken (not LO's fault but still looks bad)
Comment 7 Jorendc 2013-04-24 10:14:30 UTC
(In reply to comment #6)
> Although this bug is fixed in Master it should be cherry picked to 4.0.3
> ASAP since Marketing made a big deal about this new feature and now it is
> broken (not LO's fault but still looks bad)

@Pedro: Isn't this fixed by https://gerrit.libreoffice.org/#/c/3482/ ( = for 4.0 branch) and https://gerrit.libreoffice.org/#/c/3483/ ( = for 4.0.3)?

Kind regards,
Joren
Comment 8 Jean-Baptiste Faure 2013-04-24 12:01:36 UTC
I think Joren is right. It works as expected in my own build of LO 4.0.4.0+ and the commit has been cherry-picked to LO 4.0.3 so it will be in 4.0.3.2 (that is RC2).
The commit : https://gerrit.libreoffice.org/gitweb?p=core.git;a=commit;h=86c58a8109ad0695c91f86c3689df9dc01938386

Please, don't forget to verify when RC2 will be out.

Best regards. JBF
Comment 9 Jean-Baptiste Faure 2016-04-24 19:00:45 UTC
Same description and fix as bug 63498 -> duplicate.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 63498 ***