Bug Hunting Session
Bug 63498 - Personas doesn't work anymore
Summary: Personas doesn't work anymore
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 59608 63835 64020 64497 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-04-13 13:12 UTC by vitriol
Modified: 2016-04-24 19:00 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
Stack Trace (878.09 KB, application/zip)
2013-06-19 09:37 UTC, mal
Details
persona after first install (60.00 KB, image/png)
2013-07-10 08:57 UTC, mal
Details
What happens as you move the mouse (59.75 KB, image/png)
2013-07-10 08:58 UTC, mal
Details
With Help About box (100.59 KB, image/png)
2013-07-10 09:15 UTC, mal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vitriol 2013-04-13 13:12:47 UTC
Personas doesn't work anymore for new added themes. To reproduce try to change Personas from FF site link.
Regression in version 4.0.2 or something changed in FF Personas site?
Comment 1 Jorendc 2013-04-14 22:58:00 UTC
I can reproduce this behavior using Mac OSX 10.8.3 and LibreOffice 4.0.2.2.
A user on the Dutch User mailing list also can reproduce this behavior using Windows 7.

@Kendy: this makes adding a persona impossible :(. Can you have a look at it :-)?
Comment 2 Jean-Baptiste Faure 2013-04-17 18:31:09 UTC
I think the root cause is the change Mozilla did on the website that LO tries to open.

Best regards. JBF
Comment 3 Jan Holesovsky 2013-04-19 16:44:29 UTC
Fixed now; unfortunately I was not aware that the bug was filed before I fixed it, so no automatic updates of the state here.  Here are the commits:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca3fa2a210cc6978dc75566ff453c9138ab9c094 [4.1]

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-0&id=ecc9e5e4e393a81ae5cd31c18e92b99e243b2ed8 [4.0.4]

https://gerrit.libreoffice.org/#/c/3483/ [pending 1 more review for 4.0.3]
Comment 4 Thomas van der Meulen 2013-04-23 10:16:16 UTC
*** Bug 63835 has been marked as a duplicate of this bug. ***
Comment 5 Ben 2013-04-24 18:38:50 UTC
PERSONA BUG NOT RESOLVED - PROBLEM CONTINUES - PERSONA NOT WORKING 

Tested Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39)

As of today 10-24-2013

- Persona Creates an amazing look for the product by customizing. 
- Persona may assist some visually handicapped individuals by selection of contrast themes. 
- Persona may help in low light  or with poor screens.

People are very much looking forward to the Persona feature. Persona not working will get noticed and create disappointment. I recommend the highest priority to fix. It was reported as fixed but I can confirm it is not fixed with the version that I tested.  


Persona Not Working with Mac OSX 10.8.3 [Tested with Firewall Open]
Persona Not Working with Windows 8 [Tested with Firewall Open]

Recognize that Firefox Persona is now called a Theme. Tried every which way to make it work...it does not. If there is a manual workaround, I would appreciate if it was identified.

Any clarification would be appreciated. Regards, Ben
Comment 6 Jorendc 2013-04-24 18:45:36 UTC
(In reply to comment #5)
> PERSONA BUG NOT RESOLVED - PROBLEM CONTINUES - PERSONA NOT WORKING 
> 
> Tested Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39)
> ...
> Any clarification would be appreciated. Regards, Ben

Hi Ben,

As Jan Holesovsky mentioned in Comment 3, there is a patch (that now is merged today) to 4.0.3 as well. Because we can't time-travel and include that patch in 4.0.3.1 (= RC1), this patch will be included in RC2.
If it isn't fixed with the upcomming second release candidate (probably released somewhere next week), please REOPEN it then.

Kind regards,
Joren
Comment 7 Ben 2013-04-24 19:06:48 UTC
Thank You Joren.
Comment 8 Jorendc 2013-04-28 18:28:38 UTC
*** Bug 64020 has been marked as a duplicate of this bug. ***
Comment 9 Thomas van der Meulen 2013-05-12 16:09:07 UTC
*** Bug 64497 has been marked as a duplicate of this bug. ***
Comment 10 Peter Maunder 2013-06-08 16:11:36 UTC
Personas not installing on 4.1 beta on Ubuntu 12.04. 

No Personas folder was created. It works when I manually copied across a Personas folder from a 4.0.3 installation and updated the PersonaSettings entry on the registrymodifications.xcu file from the 4.0.3 version.

On trying to change the working personas by downloading a new one from the Firefox theme website, the PersonaSettings entry was removed and the personas disappeared.
Comment 11 Michael Meeks 2013-06-08 16:54:23 UTC
Ho hum; I guess we really need to clone the persona's site with a predictable presentation / front-end if we continue to ship this - something for sysadmins to consider ? kendy ?
Comment 12 Cor Nouws 2013-06-14 16:27:01 UTC
maybe just confirm this > new
Comment 13 A. Fakhouri 2013-06-15 14:54:15 UTC
I can confirm this on 4.1.0.0beta1 on Mint 14 (Ubuntu based Linux distro).
No command line output to attach.
Comment 14 Jean-Baptiste Faure 2013-06-16 12:57:51 UTC
I do not reproduce on Version: 4.1.0.0.beta2+ (Build ID: 5adfa746fb176c00cefc5fa34c79214fe166855) under Xubuntu 12.04 x86-64.
I tried with a fresh clean profile. That said, I got the following warning message in the console, repeated several times:
(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed


Best regards. JBF
Comment 15 Jan Holesovsky 2013-06-18 12:38:07 UTC
I was unable to reproduce (in master), so whoever can reproduce this, please attach strace output.  It is enough to run ./soffice --strace, do the operations to change the theme, check that it did not work, close LibreOffice, and attach strace.log that was created in the dir from where you run LibreOffice.

Thank you!
Comment 16 mal 2013-06-19 09:37:42 UTC
Created attachment 81058 [details]
Stack Trace

If I've done this right !!

openSuse 12.3, KDE 4.10.4, LO Beta2

Did exactly what I do in 4.0.3 which works fine
Comment 17 mal 2013-06-19 09:48:09 UTC
Actually I should probably mention that the 4.0.3 that works is the openSuse build which I think contains some 4.0.4 fixes. The 4.1 beta is the vanilla LO

M
Comment 18 Adolfo Jayme 2013-07-10 08:12:23 UTC
I can't reproduce this problem in 4.1.0.2 under Windows, Mozilla Themes work.
Comment 19 Jorendc 2013-07-10 08:38:36 UTC
So, as far I c
Comment 20 Jorendc 2013-07-10 08:39:20 UTC
So, as far I can see we can close this bug? (sorry for the noise, pushed 'save changes' by accident :) )
Comment 21 mal 2013-07-10 08:57:03 UTC
It still doesn't work properly for me on openSuse 12.3 and KDE 4.10.5
See attached screen shots

1. When you first install persona the buttons don't get coloured
2. As you move the mouse over active buttons they get coloured in
Comment 22 mal 2013-07-10 08:57:51 UTC
Created attachment 82260 [details]
persona after first install
Comment 23 mal 2013-07-10 08:58:24 UTC
Created attachment 82261 [details]
What happens as you move the mouse
Comment 24 Cor Nouws 2013-07-10 09:02:37 UTC
Works fine in 4.1.0.2 (release candidate 2)

@mal: pls look at the newer version (not default for eg. OpenSUSE)

@all: still - at least for me - I need to work carefully with this, because of the time laps between confirming the Persona dialog and then when the Options dialog becomes active again.
I think some enhancement (visual feed back) is on its place here.
Comment 25 mal 2013-07-10 09:13:23 UTC
This is the vanilla LO RC2 not the openSuse one
Comment 26 mal 2013-07-10 09:15:16 UTC
Created attachment 82262 [details]
With Help About box
Comment 27 Jorendc 2013-07-10 09:27:42 UTC
@Mal: please create another bug report for that. This bug is about the fact personas completely doesn't work anymore. As far we can see on your screenshots Personas work, but not okay. This problem has another root cause.

You can CC me on your newly created bug.

Kind regards,
Joren
Comment 28 Cor Nouws 2013-07-10 09:30:01 UTC
(In reply to comment #25)
> This is the vanilla LO RC2 not the openSuse one

@mal: sorry I did not get that right, But pls follow the advise of Joren!
thanks,
Comment 29 Jean-Baptiste Faure 2016-04-24 19:00:45 UTC
*** Bug 59608 has been marked as a duplicate of this bug. ***