Download it now!
Bug 59663 - FORMATTING VIEWING
Summary: FORMATTING VIEWING
Status: RESOLVED DUPLICATE of bug 62513
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-21 14:26 UTC by Stephan Busch
Modified: 2015-04-04 14:45 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
screenshot of Excel (470.79 KB, image/png)
2013-01-21 14:26 UTC, Stephan Busch
Details
screenshot of LibreOffice (306.23 KB, image/png)
2013-01-21 14:27 UTC, Stephan Busch
Details
XLSX spreadsheet (1.09 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-01-21 14:28 UTC, Stephan Busch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Busch 2013-01-21 14:26:39 UTC
Created attachment 73383 [details]
screenshot of Excel

My XLSX looks weird when opened in LibreOffice 4.0.0.1:

* cells with hyperlinks lack the bottom border and have grey background
* cells with with conditional formatting sometimes show the numbers
  not centered and without points; cell borders are not shown
* spreadsheet background doesn't get imported
* cell borders are thicker than they are in Excel
* fonts are changed: Arial & Arial Unicode in original sheet
  are changed to Calibri


Spreadsheet can be downloaded here:

http://www.squeezechart.com/SqueezeChart2013-preview.xlsx

screenshot from Excel:

http://www.squeezechart.com/spreadsheet-in-Excel-15.0.4420.png

screenshot from LibreOffice:

http://www.squeezechart.com/spreadsheet-in-LibreOffice-4.0.0.1.png
Comment 1 Stephan Busch 2013-01-21 14:27:59 UTC
Created attachment 73384 [details]
screenshot of LibreOffice
Comment 2 Stephan Busch 2013-01-21 14:28:59 UTC
Created attachment 73385 [details]
XLSX spreadsheet
Comment 3 Stephan Busch 2013-02-10 14:37:21 UTC
This also happens with LibreOffice 3.6.4, 3.6.5 and 4.0.0 final
Comment 4 ign_christian 2013-05-28 15:38:36 UTC

*** This bug has been marked as a duplicate of bug 62513 ***
Comment 5 Commit Notification 2015-04-04 02:16:17 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=78f4ed104c832b4aa1ae2d8d367f1db7de486065

correct xlsx element order, related tdf#59663

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2015-04-04 14:45:21 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de90039b9f04233a87b8dffb9a00ea3f534bc22c

actually make the exported file valid, related tdf#59663

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.