Bug Hunting Session
Bug 62513 - XLSX looks weird in LibreOffice Spreadsheet (all versions)
Summary: XLSX looks weird in LibreOffice Spreadsheet (all versions)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 59663 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2013-03-19 09:35 UTC by Stephan Busch
Modified: 2017-07-17 09:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Busch 2013-03-19 09:35:39 UTC
My XLSX looks weird when opened in LibreOffice 4.0.1.2:

* cells with hyperlinks lack the bottom border and have grey background
* cells with with conditional formatting sometimes show the numbers
  not centered and without points; cell borders are not shown
* spreadsheet background doesn't get imported
* cell borders are thicker than they are in Excel
* fonts are changed: Arial & Arial Unicode in original sheet
  are changed to Calibri


Spreadsheet can be downloaded here:

http://www.squeezechart.com/SqueezeChart2013-preview.xlsx

screenshot from Excel:

http://www.squeezechart.com/spreadsheet-in-Excel-15.0.4420.png

screenshot from LibreOffice:

http://www.squeezechart.com/spreadsheet-in-LibreOffice-4.0.0.1.png
Comment 1 Joel Madero 2013-04-09 04:45:53 UTC
Okay I can confirm a lot of what you've said, in general though we try to keep bug reports on a one bug per report basis. 

This being said this document is a great test document for us to work with. For now, I'm going to leave it as one report but a developer may ask you to split it up at some point.

What I can confirm with Bodhi Linux using version 4.0.1.2:

1. Hyperlinks lacking bottom border-- cannot confirm, looks like there is a bottom border to me but maybe I'm misunderstanding that

2. Cannot confirm, need an explicit cell to look at (too much going on for me to jump around searching for what you're talking about here)

3. Confirmed

4. Confirmed

5. Confirmed that it is indeed Calibri, cannot confirm that in Excel it's Arial/Arial Unicode as I don't have excel but I'll trust you here :)


Adding two of our spreadsheet experts to give advice, again they may want individual reports.

Kohei, Markus - great test document here, you want it split up into multiple reports? Also I noticed that saving this document took quite awhile in Spreadsheet as xlsx format, at one point I thought it was just frozen but it finally saved (at least a couple minutes to save).
Comment 2 ign_christian 2013-05-28 15:34:33 UTC
Seems this bug now splitted to many bugs:
Bug 65070
Bug 65071
Bug 65072
Bug 65074
Bug 65075
Comment 3 ign_christian 2013-05-28 15:38:36 UTC
*** Bug 59663 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Suo 2013-06-07 02:08:54 UTC
It's the same as in Bug 56960, the patch is out and this will be fixed in LibreOffice 4.1 release.

*** This bug has been marked as a duplicate of bug 56960 ***
Comment 5 Kevin Suo 2013-06-07 02:11:29 UTC
(In reply to comment #4)
> It's the same as in Bug 56960, the patch is out and this will be fixed in
> LibreOffice 4.1 release.
> 
> *** This bug has been marked as a duplicate of bug 56960 ***

Sorry, but this is only related to this line:
> * cell borders are thicker than they are in Excel

So this bug report should not be "Resolved".
Comment 6 Joel Madero 2013-06-07 03:34:07 UTC
Since the bug isn't assigned it should be set to NEW. Doing so now :)
Comment 7 tommy27 2014-10-06 18:46:54 UTC
(In reply to ign_christian from comment #2)
> Seems this bug now splitted to many bugs:
> Bug 65070
> Bug 65071
> Bug 65072
> Bug 65074
> Bug 65075


so there's no need to keep this it was already split in single reports and 4 out 5 those issues are already resolved.

I mark this as RESOLVED INVALID because it did not respect "a single bug per report" policy.

I hope that the residual issue at Bug 65070 will be fixed as well (still reproducible in 4.3.2.2 and 4.4 master)