Download it now!
Bug 59666 - EDITING: Option to disable Greek letters (αβγδελμ..) converting to big letters (ABGDE...) as automatic capitalization of first letters in sentence
Summary: EDITING: Option to disable Greek letters (αβγδελμ..) converting to big lette...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium enhancement
Assignee: László Németh
URL:
Whiteboard: BSA target:6.5.0 target:6.4.0.2
Keywords:
: 81313 120900 (view as bug list)
Depends on:
Blocks: AutoCorrect-Complete Writer-UX
  Show dependency treegraph
 
Reported: 2013-01-21 15:18 UTC by opensuse.lietuviu.kalba
Modified: 2020-01-09 15:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2013-01-21 15:18:47 UTC
Problem description: 
Greek symbols (αβγδελμ..) converted to big letters (ΑΒΓΔΕΛ...) as automatic capitalization of first letters in sentense. This is sometimes anoying. Yes I could try find these symbols not from Greek letters region in charracter map. 

Steps to reproduce:
1. Write sentence, at end write point (.)
2. type space ( )
3. copy "γ" (small gama)
4. type space ( )

Current behavior:
 γ converted to Γ
Expected behavior:
 Ability to disable Greek letters capitalization, but leave first letter capitalization for general case.
              
Operating System: Windows 7
Version: 3.6.4.3 release
Comment 1 Urmas 2013-01-22 08:11:15 UTC
Any feasible use-case for this?
Comment 2 Owen Genat (retired) 2013-11-23 03:21:18 UTC
I am confirming this bug. Tested under Crunchbang 11 x86_64 running:

- v3.3.4.1 OOO330m19 Build: 401
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

All versions change γ (U+03b3) to Γ (U+0393) when this is the first character after a full stop and space combination and is followed by a space e.g., "End. γ ". Status set to NEW. Version set to Inherited From OOo. Severity set to enhancement (as this has never existed before). Platform set to All/All.

(In reply to comment #1)
> Any feasible use-case for this?

Mainly in science / mathematics, where commencing a sentence with a symbol is considered OK. I personally find this type of expression inelegant, but the use seems widespread in these domains. Further information:

http://english.stackexchange.com/questions/44162/is-it-okay-to-start-a-sentence-with-a-greek-letter-variable
Comment 3 Owen Genat (retired) 2014-01-06 10:04:48 UTC
Setting version back from "Inherited From OOo" to what it was prior (for bugs marked enhancement), for QA tracking purposes. My mistake. Apologies.
Comment 4 Kevin Suo 2015-12-21 07:51:49 UTC
*** Bug 81313 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Suo 2015-12-21 07:53:55 UTC
A workaround is to disable the "Capitalize first letter of every sentence" auto correction option.
Comment 6 Buovjaga 2018-12-27 17:39:07 UTC
*** Bug 120900 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2019-12-31 11:52:59 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/04ef45a6dd7692c6ee08769c4ac4a0e92a0b64b8

tdf#59666 AutoCorrect: don't capitalize single Greek letters

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Mike Kaganski 2019-12-31 13:29:06 UTC
Sigh. This seems to introduce another cludge - but why stop at Greek? What if I use Latin "x", "y", "z"? Is using those characters in Math rare? Isn't auto-capitalization of them less annoying? is that case any different? And is introducing inconsistency here justified?...
Comment 9 Commit Notification 2019-12-31 14:09:16 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/6a37bc154b80e261e6d10d383de73da6ffa1e9d9

tdf#59666 AutoCorrect: don't capitalize single Greek letters

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Buovjaga 2020-01-09 15:10:39 UTC
(In reply to Mike Kaganski from comment #8)
> Sigh. This seems to introduce another cludge - but why stop at Greek? What
> if I use Latin "x", "y", "z"? Is using those characters in Math rare? Isn't
> auto-capitalization of them less annoying? is that case any different? And
> is introducing inconsistency here justified?...

László: FYI