Bug Hunting Session
Bug 81313 - When input "δ=5" in Calc, it becomes "Δ=5" (because of autocorrect)
Summary: When input "δ=5" in Calc, it becomes "Δ=5" (because of autocorrect)
Status: RESOLVED DUPLICATE of bug 59666
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-14 02:15 UTC by Kevin Suo
Modified: 2015-12-21 07:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-07-14 02:15:54 UTC
This bug report was first reported here:
http://libreofficechina.org/thread-151-1-1.html

When you input "δ=5" in a cell, it automically changes to "Δ=5".
Other greek letter are also affected.

This may be because of the "Capitalize first letter of every sentence" auto correction option, as "Δ" is the Capitalized form of "δ".
When disable this option, it works as expected.

When checking the "Capitalize first letter of every sentence" option, libreoffice should ignore the special chars (like greek letters).

Windows XP SP3.
LibreOffice 4.3.0.2.
The original bug reporter also reproduce on Fedora 20 x86_64 LibreOffice 4.2.5.2.
Comment 1 yanjingtao 2014-07-14 02:24:42 UTC
Reproduce in 
Fedora 20 x86_64
Version: 4.3.0.1
Build ID: 9ed0c4329cf13f882dab0ee8b9ecd7b05e4aafbb
Comment 2 Urmas 2014-07-14 04:04:46 UTC
There is nothing 'special' about Greek letters.
Comment 3 Kevin Suo 2014-07-14 04:56:52 UTC
Hi Urmas,

Nowdays greek letters are mostly used for scientific calculation. Upper case greek letters in most cases have exact a very different meaning compared with a lower case greek letter.

Please reference to this wiki page to see how it is different for "δ" and "Δ":
http://en.wikipedia.org/wiki/Delta_%28letter%29

Thus, I set this back to UNCONFIRMED, and added "NeedDevEval" to Whiteboard.
Comment 4 tommy27 2014-07-14 06:55:10 UTC
reproducible in LibO 4.2.5.2 (but I suspect it has always been like that because of auto-correct collision) under WinXP 32bit as well. status NEW.
Comment 5 m.a.riosv 2014-07-14 23:18:58 UTC
Greek is a language with their own alphabet at least like any other, without doubt more, so seems fine to me the option working with it, respecting the people using it, why must it work different?.

IMHO not a bug, it could be a request for enhancement, of course with a new option to modify the behavior, but without change the actual option.
Comment 6 Kevin Suo 2014-07-15 01:50:49 UTC
The point is, in calc you are not able to input "δ=5" or "σ=5" etc. When type in these expressions and hit ENTER, they are auto-corrected as "Δ=5" and "Σ=5", and there is no way to bring it back.
Disable auto-correction can provent it, but it's just a workaround.
Anyway, "δ=5" or "σ=5" are not "sentences", so why calc is auto-correcting them? The option "Capitalize first letter of every sentence" as itself tells, it to correct SENTENCE.
Comment 7 tommy27 2014-07-15 05:25:20 UTC
(In reply to comment #5)
> Greek is a language with their own alphabet at least like any other, without
> doubt more, so seems fine to me the option working with it, respecting the
> people using it, why must it work different?.

please note that this "δ=5" is mathematical language using greek symbols so this issue is not only about the greek users of Calc but may affect all scientific users all around the world

(In reply to comment #6)
> ...
> Anyway, "δ=5" or "σ=5" are not "sentences", so why calc is auto-correcting
> them? The option "Capitalize first letter of every sentence" as itself
> tells, it to correct SENTENCE.

good point Kevin. the code should be tweaked to recognize if a greek letter is at the begin of a sentence like in "αβγδ --> Aβγδ" or a formula "δ=5" and do no case change in this corner case
Comment 8 QA Administrators 2015-07-18 17:42:38 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 9 tommy27 2015-07-19 08:18:14 UTC
still present in LibO 5.1.0.0.alpha1+ (x64)

Build ID: 5a61d7f049a81d6e747d9d097f364ae45f58697b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-16_01:06:26
Locale: en-US (it_IT)

I add Lazlo Nemeth on CC list.
he's a wizard with autocorrect code.
maybe he knows how to tweak it.
Comment 10 Alex Thurgood 2015-12-21 07:38:11 UTC
Isn't this a DUP of bug 59666 ?
Comment 11 Kevin Suo 2015-12-21 07:51:49 UTC
(In reply to Alex Thurgood from comment #10)
Yes it is. Thanks.

*** This bug has been marked as a duplicate of bug 59666 ***