Bug Hunting Session
Bug 59916 - French, Dutch and Czech UI cause ERROR:508 instead calculated results
Summary: French, Dutch and Czech UI cause ERROR:508 instead calculated results
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other Linux (All)
: highest normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 59940 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-01-26 23:36 UTC by Jorendc
Modified: 2013-01-30 15:20 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Settings result in good behavior (203.11 KB, image/png)
2013-01-28 00:22 UTC, Jorendc
Details
Settings result in bad behavior (172.44 KB, image/png)
2013-01-28 00:22 UTC, Jorendc
Details
=NU() (translation: NOW()) result in ERR:508 (154.70 KB, image/png)
2013-01-28 11:41 UTC, Jorendc
Details
screenshot of the NOW() call (90.65 KB, image/png)
2013-01-28 11:46 UTC, Tomáš Chvátal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-01-26 23:36:40 UTC
Tested with Linux Mint 14 x64

Problem description: Open attachment of Bug 57997 (https://bugs.freedesktop.org/attachment.cgi?id=71156) result in many ERROR:508

Steps to reproduce:
1. Open attachment above with LibreOffice 4.0.0.2 rc2

Current behavior: Many ERROR:508
Expected behavior: No Errors; values instead

Now open file again with 4.1 (I opened it with Version 4.1.0.0.alpha0+ (Build ID: f1bca26afcc7593d0124c216c0400a9e2e47fc1))
Behavior: spreadsheet opens perfect

Open file with LibreOffice 3.6.4.3 
Behavior: opens perfect

Summary: regression 3.6 vs 4.0 but not reproducible in 4.1        
Operating System: Linux (Other)
Version: 4.0.0.2 rc
Last worked in: 3.6.4.3 release
Comment 1 Jorendc 2013-01-27 22:26:06 UTC
*** Bug 59940 has been marked as a duplicate of this bug. ***
Comment 2 Jorendc 2013-01-27 22:27:38 UTC
(In reply to comment #1)
> *** Bug 59940 has been marked as a duplicate of this bug. ***

Therefore I mark this bug as NEW and change the title. All these functions do result in a ERR 508
Comment 3 silvio.gerli 2013-01-27 22:56:30 UTC
Not only importing!
Every new file with new forumula with function (i.e. =TODAY() ) gives this error:
ERR:508
it is unable to caluclate formulas.

I have 4.0.0.2.

With 4.0.0.1 I had no problem, so I'm recompiling 4.0.0.1 version.
Comment 4 Jorendc 2013-01-27 22:58:27 UTC
Can't reproduce this bug using Mac OSX 10.8.2 with LibreOffice 4.0.0.2 rc2.

When I save the 'corrupt-looking-ods-file' using Linux Mint and open it using Mac OSX, there is NO loss of data.
Comment 5 silvio.gerli 2013-01-27 23:14:02 UTC
I confirm:

no error with 4.0.0.1

error (Err:508) on EVERY formula on EVERY file (old or new).
Comment 6 Jorendc 2013-01-27 23:36:11 UTC
Following [1] I mark this bug as 'Medium highest'.

Medium because there is no loss of data, the document can be opened etc. Therefore 'Normal'. But in this 'normal' range I'll set it this to 'highest'.

Kind regards,
Joren
Comment 7 Jorendc 2013-01-27 23:46:26 UTC
Newest findings: it's a localization problem

Open file using LibreOffice 4.0.0.2 rc2 Dutch UI -> ERR:508
Open file using LibreOffice 4.0.0.2 rc2 English (USA) UI -> opens fine.
Comment 8 Jorendc 2013-01-28 00:22:25 UTC
Created attachment 73747 [details]
Settings result in good behavior
Comment 9 Jorendc 2013-01-28 00:22:42 UTC
Created attachment 73748 [details]
Settings result in bad behavior
Comment 10 Petr Mladek 2013-01-28 09:03:08 UTC
Hmm, I am unable to reproduce the problem here. I used the official 4.0.0.2 build for Linux, x86_64. I do the tests on SLED11-SP2. I installed en-US, cs, de, fr, nl localizations. I started it the following way:

   LANG=nl_BE.UTF-8 libreoffice4.0 gas_usage.ods
   LANG=nl_NL.UTF-8 libreoffice4.0 gas_usage.ods
   LANG=cs_CZ.UTF-8 libreoffice4.0 gas_usage.ods

I double checked Tools/Options/Language Settings/Languages and it used the default languages for the given LANG locale.

Everything was correctly computed. No Error.
Comment 11 Petr Mladek 2013-01-28 09:08:03 UTC
Could you please tell us more about your systems and builds? OS? Architecture? Official builds or self builds?

Also, do you have installed any extension?

Does it help you to start the application with fresh user configuration? Please, try to stop LO, and rename ~/.config/libreoffice/4 directory. Please, do not remove it. We might want to analyze the old configuration if the fresh configuration really helps.
Comment 12 Jorendc 2013-01-28 10:35:02 UTC
(In reply to comment #11)
> Could you please tell us more about your systems and builds?
Hi, I installed LibreOffice 4.0.0.2 rc2 Versie 4.0.0.2 .0.2 (Bouw-id: 408fe71bd18616c467b3dcd7ab6756528ffcae2) and the Dutch Language Pack by following the installation guideline: https://www.libreoffice.org/get-help/installation/linux/
> OS?
joren@LinuxMint ~ $ cat /etc/*-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=14
DISTRIB_CODENAME=nadia
DISTRIB_DESCRIPTION="Linux Mint 14 Nadia"
NAME="Ubuntu"
VERSION="12.10, Quantal Quetzal"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu quantal (12.10)"
VERSION_ID="12.10"

Other information I can find in my 'System Monitor':
Release 14 (nadia) 64-bit
Kernel Linux 3.5.0-17-generic
GNOME 3.6.0
Memory: 3,8GiB
Processor: Intel® Core™ i5-2300 CPU @ 2.80GHz × 4
Available disk space: 31,8 GiB
> Architecture?
x64
>Official builds or self builds?
Official build, downloaded at http://dev-builds.libreoffice.org/pre-releases/deb/x86_64/ 
> 
> Also, do you have installed any extension?
Not I installed by myself. I have some extensions in my 'Extension Manager'
* English Dictionary, thesaurus, ...
* French Dictionary, thesaurus (<- I think this is installed because I also tried with French version (downloaded+installed fr language pack), but this was after I already reproduce this problem
* Minimize of presentations (= roughly translated), it's a The Document Foundation extension (1.0.4)
* Dutch Dictionary, thesaurus,...  2.0.0 (provided by 'OpenTaal')
* Solver for non linear programming version 0.9 (provided by TDF)
* rapport creator 1.2.3 (provided by TDF)
* Spanish Dictionary, thesaurus, ... 0.6 (provided by 'rla-es')
* Wiki publisher 1.1.2 (TDF)
*

> Does it help you to start the application with fresh user configuration?
> Please, try to stop LO, and rename ~/.config/libreoffice/4 directory.
> Please, do not remove it. We might want to analyze the old configuration if
> the fresh configuration really helps.
Still reproducible by renaming that user profile... (now I have a '4-old' and a '4' folder).

Kind regards,
Joren
Comment 13 Jorendc 2013-01-28 10:42:09 UTC
PS: my system language is also Dutch.
Comment 14 Rainer Bielefeld Retired 2013-01-28 10:44:02 UTC
Hi all, please actualize the summary to your results.

@Fabien MAUREL:
Can you confirm the UI language dependency for Bug 59940?
Comment 15 Rainer Bielefeld Retired 2013-01-28 10:45:16 UTC
NOT reproducible with "LibO  4.0.0.2 rc   -  Dutch UI / Dutch Locale  [Build ID: 5991f37846fc3763493029c4958b57282c2597e)]"  {tinderbox: @6, pull time 2013-01-24  07:20(?)} on German WIN7 Home Premium (64bit) with User Profile automatically created form renamed /3 User profile used by 3.6.5.2

Seems limited to Linux?
Comment 16 Eike Rathke 2013-01-28 11:05:07 UTC
Could someone do a simple test of =NOW() respectively its equivalent in the translated UI and if that results in Err:508 attach a screenshot to this bug with the cell cursor on the formula cell so that the actual formula is visible in the input line?
Comment 17 Eike Rathke 2013-01-28 11:07:05 UTC
Is this reproducible with both, .deb and .rpm packages?
Comment 18 Jorendc 2013-01-28 11:11:21 UTC
(In reply to comment #16)
> Could someone do a simple test of =NOW() respectively its equivalent in the
> translated UI and if that results in Err:508 attach a screenshot to this bug
> with the cell cursor on the formula cell so that the actual formula is
> visible in the input line?

=NU() result in a FOUT:509 (ERR:509) yes.

(In reply to comment #17)
> Is this reproducible with both, .deb and .rpm packages?
I'll test that
Comment 19 Jorendc 2013-01-28 11:11:50 UTC
(In reply to comment #18)
> (In reply to comment #16)
> > Could someone do a simple test of =NOW() respectively its equivalent in the
> > translated UI and if that results in Err:508 attach a screenshot to this bug
> > with the cell cursor on the formula cell so that the actual formula is
> > visible in the input line?
> 
> =NU() result in a FOUT:509 (ERR:509) yes.
CORRECTION: a 508 error! My bad
> 
> (In reply to comment #17)
> > Is this reproducible with both, .deb and .rpm packages?
> I'll test that
Comment 20 Eike Rathke 2013-01-28 11:36:28 UTC
(In reply to comment #19)
> > =NU() result in a FOUT:509 (ERR:509) yes.
> CORRECTION: a 508 error! My bad

Well, yes, and the screenshot I asked for? ;-)

> > > with the cell cursor on the formula cell so that the actual formula is
> > > visible in the input line?
Comment 21 Jorendc 2013-01-28 11:41:57 UTC
Created attachment 73768 [details]
=NU() (translation: NOW()) result in ERR:508

(In reply to comment #20)
> (In reply to comment #19)
> > > =NU() result in a FOUT:509 (ERR:509) yes.
> > CORRECTION: a 508 error! My bad
> 
> Well, yes, and the screenshot I asked for? ;-)
> 
> > > > with the cell cursor on the formula cell so that the actual formula is
> > > > visible in the input line?

I'm sorry for that;

Can't test rpm packages I think. I'm learning how to use Linux (Ubuntu/Mint) etc, and with other distro's I'm even a bigger noob :p... So I think I need to skip that test and look to others to test this.
Comment 22 Tomáš Chvátal 2013-01-28 11:46:10 UTC
Created attachment 73769 [details]
screenshot of the NOW() call

Reproducable in Gentoo with czech translation.
Comment 23 Rainer Bielefeld Retired 2013-01-28 12:10:46 UTC
Due to Tomáš Chvátal Comment 22
Comment 24 Jorendc 2013-01-28 12:13:35 UTC
(In reply to comment #17)
> Is this reproducible with both, .deb and .rpm packages?

Using https://wiki.documentfoundation.org/Installing_in_parallel I can't reproduce this problem using RPM + dutch RPM language pack. I also change the User Profile Location (https://wiki.documentfoundation.org/Installing_in_parallel#Step_4_-_Optional.2C_but_Recommended_when_Testing:_Changing_the_User_Profile_location). But with my current install I also tested with a clean user profile... still reproducible with DEB.

(again tested on Linux Mint 14 see Comment 12)
Comment 25 Frederic COIFFIER 2013-01-29 09:35:05 UTC
I confirm this problem with French (Gentoo ebuild libreoffice-4.0.0.2). Using English USA solves the problem.
Comment 26 Eike Rathke 2013-01-29 14:06:17 UTC
I can not reproduce this even if I use the .deb packages from http://dev-builds.libreoffice.org/pre-releases/deb/x86_64/

Tried on Fedora16 and Debian Wheezy.

Can anyone reproduce this on a system that is not Debian based?

I suspect some recent Debian system lib being the culprit.
Comment 27 Petr Mladek 2013-01-30 09:29:48 UTC
Scarabeus told me that thi bug already got 18 people in CC in the Gentoo bugzilla. I am afraid that quite some people are affected => increasing severity.
Comment 28 Rainer Bielefeld Retired 2013-01-30 10:12:47 UTC
@Frederic COIFFIER, Tomáš Chvátal, Jorendc:
Does that mean "All languages except English on affected PC" show the problem or do you also have non-English UI/Localizations not showing the problem?
Comment 29 Jorendc 2013-01-30 10:54:55 UTC
(In reply to comment #28)
> @Frederic COIFFIER, Tomáš Chvátal, Jorendc:
> Does that mean "All languages except English on affected PC" show the
> problem or do you also have non-English UI/Localizations not showing the
> problem?

The problem is I can't reproduce this problem with other mentioned languages (French and Czech) and all other languages I tested so far (Spanish, German)... I use a Dutch OS-language as well, so maybe that's rather related?

I also asked to try to reproduce this bug on the Dutch mailing list. NOBODY can reproduce the problem (all using Windows, so it's certainly OS dependent as well):
* Windows 7, LibreOffice 4.0.0.2, LibreOffice Dutch UI
* Windows 7 x64, LibreOffice 4.0.0.2, LibreOffice & OS Dutch UI

So, nothing more news on this side. I'm now going to 'play' with my OS-language and try to determine if this is a bug introduced by Linux/Debian (I use Mint 14)
Comment 30 Noel Power 2013-01-30 11:00:16 UTC
on a gentoo machine the 508 gets set from

    at /build-portage/portage/app-office/libreoffice-4.0.0.2/work/libreoffice-4.0.0.2/formula/source/core/api/FormulaCompiler.cxx:1089
 1089	                SetError(errPairExpected);
 (gdb) list
 1084	        {
 1085	            pFacToken = mpToken;
 1086	            eOp = NextToken();
 1087	            if (eOp != ocOpen)
 1088	            {
*1089	                SetError(errPairExpected);

sorry can't tell what eOp is ( seems it is optimised out ) and debugging remotely without the env you are familiar with is painful :-( ( and I am not really familiar with formula stuff )

hopefully even the above might give Eike or someone a hint, I will try and find out more
Comment 31 Eike Rathke 2013-01-30 11:41:07 UTC
Thanks Noel! I'll dig into that.
Comment 32 Jorendc 2013-01-30 11:51:56 UTC
I think it now works OK on my computer (Linux Mint 14)... But I don't know or it's 'damaging'. When I installed 4.0 rc2 I completely removed 3.6.2 version already... The way I did will delete ALL LibreOffice related stuff. Maybe someone with more Linux experience can confirm this is a dangerous way.

What I did:
* Going to the 'Language support' of my OS; Opening this'll search for new or non-installed packages.
* open 'sudo synaptic'
* Search for 'LibreOffice'
* Sort the list on the first field (checkbox)
* !I don't know or this step is dangerous or not! Select all 'checked' units in that list (using 'click' scroll down to the last checked entry and click on it holding 'shift'.)
* Download LibreOffice 4.0.0.2 rc2 again: https://www.libreoffice.org/download/pre-releases/ + language package.
* continue installation and desktop-integration as usual (sudo dpkg -i *.deb)
* restart LibreOffice
* Open attachment mentioned in Bug Report (Description)
-> No problem anymore...

Normally I'll set this as 'RESOLVED WORKSFORME' ... but we still don't know the root cause of this ... OS or LibreOffice :p
Comment 33 Eike Rathke 2013-01-30 15:18:32 UTC
So, on the gentoo machine it turned out that the localized resources are not rebuilt against the current source and hence don't match. In this specific case two opcode entries are missing hence shift following IDs down by 2 and instead of the opcode of '(' another ID is compiled. This of course can't work and rightly complains about "parenthesis expected" ...

Please slap your friendly package maintainer ;-)

Don't know if on Linux Mint it was the same cause, but most probably yes. Also explains why re-installing from pre-releases helps.

Closing this bug as NOTOURBUG.