Bug Hunting Session
Bug 59953 - [RTF] FILEOPEN: wrong column widths for tables with merged cells
Summary: [RTF] FILEOPEN: wrong column widths for tables with merged cells
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.0.1.0+ target:4.1.0.0alpha
Keywords: filter:rtf, regression
: 60644 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-28 05:01 UTC by Valek Filippov
Modified: 2015-12-17 12:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
How table is shown in MSO (151.47 KB, image/png)
2013-01-28 05:01 UTC, Valek Filippov
Details
Screenshot (571.03 KB, image/png)
2013-01-28 07:40 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valek Filippov 2013-01-28 05:01:49 UTC
Created attachment 73755 [details]
How table is shown in MSO

The problem happens with a file attached to fdo#55493
(https://bugs.freedesktop.org/attachment.cgi?id=67922)

Column widths seem to be wrong for tables with merged/splitted cells.
Comment 1 ape 2013-01-28 07:40:34 UTC
Created attachment 73760 [details]
Screenshot

This picture illustrates worsening in the import of tables.
From left to right:
- MS Office 2007 sp3;
- LibreOffice 3.6.5 (OK);
- LOdev 4.0.1.0+ (build 27 jan 2013; win_x86);
- LOdev 4.1.0.0+ (build 27 jan 2013; win_x86).
Comment 2 ape 2013-01-28 08:39:06 UTC
Miklos! Look at this bug please if it possible.
--
(In reply to comment #1)
> Created attachment 73760 [details]
> Screenshot
> 
> This picture illustrates worsening in the import of tables.
> From left to right:
> - MS Office 2007 sp3;
> - LibreOffice 3.6.5 (OK);
> - LOdev 4.0.1.0+ (build 27 jan 2013; win_x86);
> - LOdev 4.1.0.0+ (build 27 jan 2013; win_x86).
--
It is possible that all errors, which are visible in the attachment 73760 [details], are a result of the incorrect import of the structure of tables and sizes of cells. The ODT file, obtained from the RTF file by LOdev_4.0.1.0+, contains all elements, which are not shown on the display: the picture “signature” and the surname of person, who signed document.
Comment 3 headsup 2013-01-31 08:26:51 UTC
Thanks for reporting. Confirmed on w8 pro x86 32 bit libreoffice Version 4.0.0.2 .0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e) and ms office. Seem to be several similar bugs reported re rft tables.
Comment 4 headsup 2013-01-31 08:34:12 UTC
I am marking this as a duplicate of previously reported fdo#59393

*** This bug has been marked as a duplicate of bug 59393 ***
Comment 5 ape 2013-01-31 15:12:34 UTC
(In reply to comment #4)
> I am marking this as a duplicate of previously reported fdo#59393
> 
> *** This bug has been marked as a duplicate of bug 59393 ***
--
1. This bug reports about the damage of table structure, if table has rows, in which the cells were merged and (or) they were split.
2. Bug 59393 error about the fact that:
- the last column’s width is appropriated at the 1st column;
- the 1st column’s width is appropriated at the 2nd column, etc.
3. I returned previous status therefore.
Comment 6 ape 2013-02-01 03:12:52 UTC
LibO-DEV 4.1.0.0.alpha0+ (Build ID: 027bb41aa16793e88e9fc1b3550c8c893363647)
TinderBox: Win-x86@6, Branch:master, Time: 2013-01-31_23:26:04

Errors reading table markup remained without fix.
Comment 7 Miklos Vajna 2013-02-08 09:05:40 UTC
Right, if I look at the sign and stamp pictures, they are readable on 3.6, but not on master. I'll look into this.
Comment 8 Not Assigned 2013-02-08 13:38:59 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e15f9ceafdf6e8b21cd315936ab44edfa91dd8b2

fdo#59953 RTF import: fix unreadable graphic and nested cell contents



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Miklos Vajna 2013-02-08 13:52:55 UTC
-4-0 review: https://gerrit.libreoffice.org/2044
Comment 10 Not Assigned 2013-02-11 11:43:13 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d4e28739681ca947112332016f9e904d4e587c9&h=libreoffice-4-0

fdo#59953 RTF import: fix unreadable graphic and nested cell contents


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Miklos Vajna 2013-07-02 14:51:08 UTC
*** Bug 60644 has been marked as a duplicate of this bug. ***
Comment 12 Robinson Tryon (qubit) 2015-12-17 12:13:11 UTC
Migrating Whiteboard tags to Keywords: (filter:rtf)
Replace rtf_filter -> filter:rtf.
[NinjaEdit]