Download it now!
Bug 60644 - RTF import tables loses column widths
Summary: RTF import tables loses column widths
Status: RESOLVED DUPLICATE of bug 59953
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium major
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: 54900
  Show dependency treegraph
 
Reported: 2013-02-11 09:48 UTC by Sander
Modified: 2013-07-03 15:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example RTF file created with LibreOffice showing a table with three colums with different widths (3.23 KB, application/rtf)
2013-02-11 09:48 UTC, Sander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sander 2013-02-11 09:48:19 UTC
Created attachment 74593 [details]
Example RTF file created with LibreOffice showing a table with three colums with different widths

This is not a duplicate of 59953, because it exists still in daily build libreoffice-4-0~2013-02-08_06.26.04_LibO-Dev_4.0.1.0_Win_x86 . (But seems like the only remaining RTF import bug)

Steps te reproduce:
1. Open a new document

2. Choose table -> insert -> table
3. Set Columns to 3 x 3
4. Choose insert

5. Type text "Small" in the first column top cell
6. Type text "Middle" in the second column top cell
7. Type text "Large" in the third column top cell

8. Make column widths an appropriate size (ie small, middle and large size)
9. Save the document as test.rtf

10. choose to open document.
11. Notice that selection the document shows a preview of the document which is correct (rendered by MS Office perhaps, but it shows that it was correctly exported)

12. Notice the opened document has three columns with equal widths
Comment 1 Jorendc 2013-02-11 10:02:12 UTC
Thanks for reporting this with such clear steps! We do appreciate that!

I can confirm this behavior using Mac OSX 10.8.2 and LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 042e4606a64233299fdc02d9df32329c452d96d)
TinderBox: MacOSX-Intel@3-OSX_10.6.0-gcc_4.0.1, Branch:master, Time: 2013-02-07_23:25:41

@Miklos: any thoughts?

Following [1] I mark this bug as 'normal medium'.

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 2 Guido 2013-02-11 15:41:46 UTC
Same problem in libreoffice 3.6.5.2 (Build ID: 5b93205)
May be related but not fixed with 55525.
Comment 3 Sander 2013-03-29 13:53:57 UTC
Look similar but is definetly not fixed with 55525. Is there any way this could be assigned to Miklos? I guess he is the expert for this :)

@Miklos: Any idea for this?
Comment 4 Mike Kaganski 2013-04-28 00:50:23 UTC
This is a regression comparative to 3.6. The Attachment 67138 [details] from Bug 54900 contains an RTF and screenshot from LO 3.6 showing that it rendered almost perfectly there, while now it opens distorted (with columns having equal widths in each row). Thus adding the keyword "regression" and setting importance to "major" (according to rules of handling regressions).
Comment 5 Mike Kaganski 2013-04-28 00:53:28 UTC
Also, changing version to 4.0.0.3 as per first comment in Bug 54900.
Comment 6 Miklos Vajna 2013-07-02 14:49:47 UTC
Taking this.
Comment 7 Miklos Vajna 2013-07-02 14:51:08 UTC
This was indeed broken with 4.0.0rc3, but I don't see the problem on latest -4-0.

bisect says this was fixed with 7d4e28739681ca947112332016f9e904d4e587c9

*** This bug has been marked as a duplicate of bug 59953 ***
Comment 8 Mike Kaganski 2013-07-02 21:55:09 UTC
Dear Miklos,

but please take a look at the testcase in Bug 54900 (Attachment 67138 [details]). Although that bug is filed against another problem, it _used to_ import almost perfectly. But now its tables are distorted having uniform column width (as may be seen even in 4.1.0.1).
Comment 9 Miklos Vajna 2013-07-03 15:32:09 UTC
Oh, you probably want to set back needinfo to new there, needinfo is normally used to track "pending input from reporter, nothing to do here at the moment". ;-)

Other than that sure, I'll try to get to it, as usual.