Bug 60162 - EDITING: App crashes when editing cell content
Summary: EDITING: App crashes when editing cell content
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.0.0)
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2013-02-01 15:49 UTC by Fieldman
Modified: 2013-02-08 06:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Debug information after forced quit (463.16 KB, text/rtf)
2013-02-01 15:49 UTC, Fieldman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fieldman 2013-02-01 15:49:44 UTC
Created attachment 74052 [details]
Debug information after forced quit

Problem description: 
App crashes when I try to edit cell content by clicking to the "Input line" box.

Steps to reproduce:
1. Open any sheet document (native format, xls, xlsx... doesn't matter which one...)
2. Select a cell I want to edit content of
3. Click or click-and-drag to select text to "input line" box
=> Rainbow spinning wheel appears and app ceases to do anything. After a while it crashes...

Current behavior:
Stil doing the same....

Expected behavior:
No crashing.

Some similarities to this bug:
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=60068
Operating System: Mac OS X
Version: 3.6.4.3 release
Comment 1 Julien Nabet 2013-02-04 20:31:42 UTC
By seeing "accessibility" in stracktrace, I wonder if this Roman's (that I put in cc) comment may help:
"
1) Do you have any accesibility features enabled? Apple’s accessibility
features like “VoiceOver” or “Enable access for assistive devices”, which get
enabled in “System Preferences > Universal Access”, are known to cause many crashes and freezes in LibreOffice. So please try to disable any accesibility features, then check if the problem is still reproducible.

2) Do you have installed any window management/user interface utilities/apps/control panels/extensions for Mac OS X like 
   * AquaSnap                * BetterSnapTool
   * BetterTouchTool         * Breeze
   * Cinch                   * Divvy
   * DoublePane              * Flexiglass
   * HyperDock               * iSnap
   * Moom                    * RightZoom
   * ShiftIt                 * SizeUp
   * SizeWell                * Spectacle
   * Stay                    * TileWindows
   * WindowTidy            ... or something similar?

And/or do you use any mouse cursor/pointer utility, i.e. some little application or control panel etc. which animates or replaces etc. the mouse curser/pointer, like
   * LazyMouse?

And/or do you use any special software which could be related to accessibility stuff, e.g. a screen reader, screen magnifier, speech recognition software,
a text-to-speech (dictation) application, or similar?

All these and many similar utilities rely heavily on Mac OS accessibility features and therefore can cause LibreOffice to crash or freeze. So please check if you have installed any utility of this kind and try to disable it
(or to add LibreOffice to the list of excluded applications for the utility,
if there is such a thing).

So please check these possibilities, if any of them helps to make the crash go away, and report the results here.
"
Comment 2 Fieldman 2013-02-05 10:04:21 UTC
1) No I have “Enable access for assistive devices” checked on.
2) Yes I have BetterTouchTool App and USB overdrive installed. USB ovedrive doesn't affect LO at all. Disabling BetterTouchTool helps! (but it's making me sad because I use the window snapping feature mostly in LibreOffice.

PS: I have also installed v:4.0.0.2.0.2 and it works without glitches.. (even with BTT enabled)

(In reply to comment #1)
> By seeing "accessibility" in stracktrace, I wonder if this Roman's (that I
> put in cc) comment may help:
> "
> 1) Do you have any accesibility features enabled? Apple’s accessibility
> features like “VoiceOver” or “Enable access for assistive devices”, which get
> enabled in “System Preferences > Universal Access”, are known to cause many
> crashes and freezes in LibreOffice. So please try to disable any
> accesibility features, then check if the problem is still reproducible.
> 
> 2) Do you have installed any window management/user interface
> utilities/apps/control panels/extensions for Mac OS X like 
>    * AquaSnap                * BetterSnapTool
>    * BetterTouchTool         * Breeze
>    * Cinch                   * Divvy
>    * DoublePane              * Flexiglass
>    * HyperDock               * iSnap
>    * Moom                    * RightZoom
>    * ShiftIt                 * SizeUp
>    * SizeWell                * Spectacle
>    * Stay                    * TileWindows
>    * WindowTidy            ... or something similar?
> 
> And/or do you use any mouse cursor/pointer utility, i.e. some little
> application or control panel etc. which animates or replaces etc. the mouse
> curser/pointer, like
>    * LazyMouse?
> 
> And/or do you use any special software which could be related to
> accessibility stuff, e.g. a screen reader, screen magnifier, speech
> recognition software,
> a text-to-speech (dictation) application, or similar?
> 
> All these and many similar utilities rely heavily on Mac OS accessibility
> features and therefore can cause LibreOffice to crash or freeze. So please
> check if you have installed any utility of this kind and try to disable it
> (or to add LibreOffice to the list of excluded applications for the utility,
> if there is such a thing).
> 
> So please check these possibilities, if any of them helps to make the crash
> go away, and report the results here.
> "
Comment 3 Julien Nabet 2013-02-07 22:18:50 UTC
Rainer: I thought about putting WFM for this one + "WFM:4.0" in keywords. Any idea?
Comment 4 Rainer Bielefeld Retired 2013-02-08 06:27:59 UTC
@Fieldman (In reply to comment #2):
Plese do not use the mail interface for comments
<https://wiki.documentfoundation.org/QA-FAQ#How_to_cite_other_comments>!

@Julien (In reply to comment #3):
It's a little unsatisfactory not to have that function working in 3.6, but I doubt that there is any chance for a cherrypick.
So I agree with closing WFM, please also see my posting on QA mailing list!