Bug 60187 - Second header deleted when converting to docx
Summary: Second header deleted when converting to docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
Depends on:
Blocks:
 
Reported: 2013-02-02 14:50 UTC by Stephen Rasku
Modified: 2015-12-17 04:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice File With Both Headers (11.36 KB, application/vnd.oasis.opendocument.text)
2013-02-02 14:50 UTC, Stephen Rasku
Details
Converted file only has one header (6.10 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-02-02 14:51 UTC, Stephen Rasku
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Rasku 2013-02-02 14:50:35 UTC
Created attachment 74088 [details]
LibreOffice File With Both Headers

I have different headers on the first and second page.  When I convert to a .docx, the header on the second page is deleted.
Comment 1 Stephen Rasku 2013-02-02 14:51:10 UTC
Created attachment 74089 [details]
Converted file only has one header
Comment 2 Jorendc 2013-02-03 22:52:06 UTC
Thanks for reporting!

I can reproduce this problem.
Is it possible to provide us steps how to reproduce this problem from 'scratch' (I mean: with an empty document in LibreOffice)? I think that'll be very useful for the developers.

Kind regards,
Joren
Comment 3 Stephen Rasku 2013-02-04 02:05:56 UTC
The problem occurred when I tried to convert my resume from OpenOffice format to .docx.  I just stripped the details from the resume to give you a minimal document.  I will try and reproduce "from scratch" but I probably won't get to it until next weekend at the earliest.
Comment 4 Stephen Rasku 2013-02-10 17:20:39 UTC
I can reproduce the bug using the following steps

1. Create blank text document
2. Add text to header
3. Insert page break
4. Format header
5. Deselect "Same content on first page" and press "OK".
6. Change text on second page header
7. Save as .docx
8. Close file.
9. Re-open file.

The file will have the same text on both headers.
Comment 5 Alexandr 2014-08-31 15:41:02 UTC
Hello,
I can not reproduce the bug with LibreOffice 4.2.6 and 4.3.1 on Debian. The patch which solved the issue is unknown, so, I set bugstatus to resolved worksforme. Please, set it to unconfirmed, if you still can reproduce the bug.

When I try to open exported .docx file in LibreOffice I get bug 82175, but in MS Word Viewer and MS Word 2010 it is opened correctly.
Comment 6 Robinson Tryon (qubit) 2015-12-17 04:33:14 UTC
Migrating Whiteboard tags to Keywords: (filter:docx)
[NinjaEdit]