Bug 60256 - Same content on first page setting reset when saving to docx
Summary: Same content on first page setting reset when saving to docx
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-03 23:03 UTC by Jorendc
Modified: 2013-02-11 18:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-02-03 23:03:26 UTC
How to reproduce:
* Open Writer
* Click on the header of the document -> a blue menu will pop up
* Click on the '+' to add a header
* Type some text that you can distinguish later ('header 1') for example
* Press 'Enter' key till next page

Current behavior: the header of the second page will also be 'header 1' -> CORRECT behavior.

* Click on the header on the second page
* Select 'Format Header...' in the drop down list
* Tab 'Header'
* Uncheck 'Same content on first page'
* OK
* Alter the header on the second page so you can distinguish it from the header on first page (for example: 'header 2')
* Save file as odt
* Save the file again as docx
* Reopen docx document

Current behavior: the header on the first page is replaced by the header of the second page. When you go back to 'Format Header...'->'Header' you'll see that 'Same content on first page' is checked again.

Kind regards,
Joren
Comment 1 Jorendc 2013-02-03 23:06:50 UTC
@Miklos: <offtopic>nice to met you at FOSDEM :-)</offtopic>. 
Ontopic now: following https://wiki.documentfoundation.org/ReleaseNotes/4.0 I can see this is a feature you introduced (thanks for that). So I hope you're the right person to 'ping'.

Thanks for your time.
Kind regards,
Joren

PS: opening odt file again -> good behavior. So I suppose there is something wrong in the export filter for docx.
Comment 2 Joel Madero 2013-02-04 17:59:53 UTC
This can be marked as NEW as it is confirmed.

Version 4.1.0.0.alpha0+ (Build ID: 027bb41aa16793e88e9fc1b3550c8c893363647)

Bodhi Linux

--------------------------------------------
Marking as:
New (confirmed)
Normal (can prevent high quality work for .docx)
High (bumped up from medium, new feature should function correctly, relatively common feature especially for professional work)
Comment 3 Jorendc 2013-02-11 18:15:12 UTC
I can't reproduce anymore with LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 67fbad1d1d593416136264aefb66d324e8e75bd).

This bug is fixed thanks to Luke Deller: https://gerrit.libreoffice.org/#/c/2065/ or https://gerrit.libreoffice.org/#/c/2062/

Therefore I don't mark it as WFM but as FIXED