Download it now!
Bug 60267 - Unreadable text in OS X due to bad font spacing
Summary: Unreadable text in OS X due to bad font spacing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 56932 62583
  Show dependency treegraph
 
Reported: 2013-02-04 09:09 UTC by Juanjo
Modified: 2013-06-01 07:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing Openoffice 3.4.2 on the left and Libreoffice on the right 3.6.5.2 (1.14 MB, image/png)
2013-02-04 09:09 UTC, Juanjo
Details
One sample page that looks ugly (25.60 KB, application/vnd.oasis.opendocument.text)
2013-02-04 09:10 UTC, Juanjo
Details
broken kerning on 100% zoom level (158.51 KB, image/png)
2013-02-04 23:09 UTC, Emir Sarı
Details
better kerning, but still errors on 110% zoom level (196.52 KB, image/png)
2013-02-04 23:10 UTC, Emir Sarı
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juanjo 2013-02-04 09:09:07 UTC
Created attachment 74163 [details]
Screenshot showing Openoffice 3.4.2 on the left and Libreoffice on the right 3.6.5.2

I am using LibreOffice on two computers: one with an old version which I can now not check and another one with a way larger display and a recent Libreoffice. While the former works fine, the latter produces unreadable text using the same fonts and document. I mean unreadable because sometimes letters are so separated that they look as different words (i s  vs is)

Since I cannot check that other computer now, I am providing a comparison of Libreoffice vs Openoffice on the _SAME_ document which, incidentally, was created using Libreoffice, not Openoffice.

The computer is running OS X Mountain Lion.
Comment 1 Juanjo 2013-02-04 09:10:38 UTC
Created attachment 74164 [details]
One sample page that looks ugly
Comment 2 Jorendc 2013-02-04 22:22:09 UTC
Hi,

I can confirm the behavior shown in your screenshot of LibreOffice; but I can't reproduce the behavior when viewing it in OpenOffice 3.4.1. It's exactly the same as far I can see. Testing with Mac OSX 10.8.2 and LibreOffice 3.6.5 and 4.0.0.3 rc3 (both exactly same behavior as shown in the LibreOffice window in your screenshot).

I'm not sure what's the problem you reported about, but as far I can see are the only differences in your screenshot the 'indent' between 'Fundamental results' and the text (and other text with 'First line indent' style).
I also checked the properties of the style 'First line indent', and can't find any indent there (or any differences between LibreOffice and OpenOffice). Because of that, I think there is no problem in LibreOffice (as far I can see), and if there is a problem or difference in the document.. I think that's a 'bug' in OpenOffice.

Therefore I can't reproduce this behavior.

Kind regards,
Joren
Comment 3 Emir Sarı 2013-02-04 23:03:10 UTC
I can reproduce this behaviour using 4.0 RC3. At first it seems not reproducible but when looking at the page with different zoom levels, it can be easily seen that text rendering is corrupted. I'll attach some screenshots now.
Comment 4 Emir Sarı 2013-02-04 23:09:36 UTC
Created attachment 74202 [details]
broken kerning on 100% zoom level
Comment 5 Emir Sarı 2013-02-04 23:10:26 UTC
Created attachment 74203 [details]
better kerning, but still errors on 110% zoom level
Comment 6 Emir Sarı 2013-06-01 07:09:30 UTC
It seems fixed with the latest 4.1 beta. If someone else could confirm that this is fixed, we can close this bug I guess.
Comment 7 retired 2013-06-01 07:19:01 UTC
I can confirm Emirs findings. For me too this is fixed in LO 4.1b1.

RESOLVED - FIXED.