Bug Hunting Session
Bug 62583 - Text on a line inconsistently re-rendered while typing
Summary: Text on a line inconsistently re-rendered while typing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Mac OS X (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 60267
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2013-03-21 07:41 UTC by Matthew Francis
Modified: 2014-07-24 22:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple example of text dancing while being typed (559.08 KB, image/gif)
2013-03-21 07:42 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2013-03-21 07:41:28 UTC
Especially at some combinations of font size and page zoom, text earlier on a line in Writer dances around (is inconsistently re-rendered) while typing. While not serious, this is ugly and distracting.

See attachment for a simple example

This occurs on OSX, but I can't immediately reproduce it on Linux.
Comment 1 Matthew Francis 2013-03-21 07:42:20 UTC
Created attachment 76857 [details]
Simple example of text dancing while being typed
Comment 2 Jorendc 2013-04-17 10:54:58 UTC
I can reproduce this behavior. I'm sure this is mentioned already somewhere. I don't know if someone already create an independant bug report for it.

Therefore I mark this one as NEW, because I can reproduce this behavior using Mac OSX 10.8.3 and LibreOffice 4.0.2.2. It is even more visible when you zoom a bit.

Kind regards,
Joren
Comment 3 Ahmad Harthi 2013-05-29 12:42:28 UTC
I suspect sallayout.cxx for this bug and 64957!
Comment 4 Don't use this account, use tml@iki.fi 2013-05-29 13:28:41 UTC
Is the version number correct? Did the original bug reporter really see this in 4.0? Or in 4.1?
Comment 5 Matthew Francis 2013-05-29 14:16:59 UTC
(In reply to comment #4)
> Is the version number correct? Did the original bug reporter really see this
> in 4.0? Or in 4.1?

In 4.0

I'm looking at it still happening in 4.0.3.3
Comment 6 Michael Meeks 2013-06-03 19:15:47 UTC
If this is in 4.0 it's un-related to coretext or bug#64957 we don't use coretext there.
Comment 7 Norbert Thiebaud 2014-03-14 07:39:11 UTC
Matthew do you still see the problem on recent version ?
I can't seems to reproduce
Comment 8 Matthew Francis 2014-03-14 07:48:44 UTC
(In reply to comment #7)

I can still see it in "Web Layout" mode under 4.2.0.4, but it may possibly have been fixed by the resolution of bug 64957 ?
Comment 9 Emir Sarı (away) 2014-07-24 22:59:42 UTC
Cannot reproduce with 4.2.5.2.