Bug 60343 - FILEOPEN: Cannot open pass protected docx
Summary: FILEOPEN: Cannot open pass protected docx
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 60334 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-06 02:00 UTC by tefaa8
Modified: 2013-10-10 14:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
password: test (18.50 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-02-06 02:00 UTC, tefaa8
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tefaa8 2013-02-06 02:00:40 UTC
Created attachment 74266 [details]
password: test

Problem description: 
Cannot open password protected docx files

When opened it does not promtp for password, but instead opens a file with weird characters


i have reposted this bug
Operating System: Windows 7
Version: 3.6.4.3 release
Comment 1 Jorendc 2013-02-06 13:08:32 UTC
*** Bug 60334 has been marked as a duplicate of this bug. ***
Comment 2 Jorendc 2013-02-06 13:15:51 UTC
I can confirm this behavior using attached document. Therefore I mark it as NEW.

@Bug reporter: is this behavior always reproducible (I mean, with every protected docx document). With what application did you create this file (LibreOffice, OpenOffice, Word, ...) and which version of that application?

Following [1] I mark this as 'Major High'.

Kind regards,
Joren


[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 3 tefaa8 2013-02-06 14:06:34 UTC
(In reply to comment #2)

(i appologize for the duplicate post, i had issues with the log in manager so I was forced to make another post)

This behavior IS reproducible, and has been encountered in every password protected docx i tried to open with libre office writer.

I have used microsoft office word 2010 to create the password protected docx.

This issue is unresolved also in the latest version of libre office available (3.6.5.2)


> I can confirm this behavior using attached document. Therefore I mark it as
> NEW.
> 
> @Bug reporter: is this behavior always reproducible (I mean, with every
> protected docx document). With what application did you create this file
> (LibreOffice, OpenOffice, Word, ...) and which version of that application?
> 
> Following [1] I mark this as 'Major High'.
> 
> Kind regards,
> Joren
> 
> 
> [1]
> https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.
> jpg
Comment 4 Jorendc 2013-02-06 14:17:41 UTC
(In reply to comment #3)
> (In reply to comment #2)
> 
> (i appologize for the duplicate post, i had issues with the log in manager
> so I was forced to make another post)
Don't mind for that, I only need to ask that to prevent it next time :-).

> This issue is unresolved also in the latest version of libre office
> available (3.6.5.2)

Thanks for your extra information.

I can reproduce using Linux Mint 14 x64 using latest master LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 1a3c90a292c7fc9060604151de9dc51eecf5b6a).
Comment 5 tefaa8 2013-06-07 15:59:44 UTC
This bug also applies to opening password protected spreadsheets with Calc
Comment 6 Caolán McNamara 2013-06-13 12:28:10 UTC
"agile" encryption foo which is a different format that the one we've implemented
Comment 7 retired 2013-07-16 10:07:10 UTC
This is a dupe. Caolán: can you look into this? Imo high/major is correct and this is valid for all OS.

*** This bug has been marked as a duplicate of bug 51194 ***
Comment 8 Marmel 2013-07-16 12:07:00 UTC

*** This bug has been marked as a duplicate of bug 35422 ***
Comment 9 Adam CloudOn 2013-10-10 14:40:45 UTC
Seems like patches submitted by Tomaž Vajngerl's (quikee@gmail.com) have solved this !

Here is the list of commits I found that relate to this.
Great job, Tomaž

fdo#59524 Encryption for MS Office 2007 Spreadsheet documents
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3423db6f81dfcd3993178a70bde7c69a0c02c302

fdo#59524 Also write sheet length so MS Office will open it.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=651b1d08a19c2770ad6f9ed4a6889faeec73e6ba

fdo#59524 Enable encryption for docx, pptx and standard OOXML formats
http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef947839c9e6e5e86e11f7a7cbf13470010ca48f

Move OOXML decryption to DocumentCrypt.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=0566ddb1841ac1e8c87db6d766739e6df7e1856d

fdo#35422 Support to open encrypted Office 2010 and 2013 formats
http://cgit.freedesktop.org/libreoffice/core/commit/?id=4323c66840e4c7dcacda0e33d33d7e67fdb08f09

Encryption: and add exceptions to methods that need it
http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8ed55b38c41a4fba3bbafaf03a39cf4718259e0

Save should encrypt OOXML document if it was loaded encrypted.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=13aedd1d0ec1ef4c5687c207eb1d9c986c1299d9