Bug 51194 - FILEOPEN password encrypted .docx and .xlsx fails, opens Filter Selection dialog
Summary: FILEOPEN password encrypted .docx and .xlsx fails, opens Filter Selection dialog
Status: RESOLVED DUPLICATE of bug 35422
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 35422
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 01:39 UTC by rolandelferink
Modified: 2013-12-05 16:28 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test case of password encrypted file (18.50 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-06-20 05:05 UTC, rolandelferink
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rolandelferink 2012-06-18 01:39:03 UTC
I hope I am not duplicating a previously reported bug but I couldn't find one previously reported.

If I have a microsoft office .docx or .xlsx password encrypted file I am unable to open it in LibreOffice.  LibreOffice opens up the "Filter Selection" dialog box.
Comment 1 rolandelferink 2012-06-18 06:32:43 UTC
I have upgraded LibreOffice to LibreOffice 3.5.4.2 Build ID: 350m1(Build:2) but the issue remains.
Comment 2 rolandelferink 2012-06-20 05:05:26 UTC
Created attachment 63262 [details]
Test case of password encrypted file

The password for the encrypted test file is "poorpassword".
Comment 3 rolandelferink 2012-06-20 05:06:37 UTC
I think that this might be isolated to documents created with microsoft 2010 since I have been able to open password encrypted documents created with earlier versions of microsoft office.
Comment 4 Joel Madero 2012-10-19 17:17:11 UTC
I get an even better situation. I am able to open this file with NO PASSWORD prompt but the text is garbled (lots of # signs, then some strange ? signs). No legible text at all.

Marking as NEEDINFO, please provide answers for the questions below and then mark as UNCONFIRMED, we'll go from there. Since we are getting different results I'm hesitant to just mark this as confirmed.


1. What version of MS Office created this document?

2. Have you tested on a newer release (3.5.7 or a 3.6 series)?

3. If so, with what results?

Thanks for your patience in helping us track this down.
Comment 5 rolandelferink 2012-10-21 11:39:45 UTC
1.  Microsoft Office Professional Plus 2010 version 14.0.6.6123.5001 (32 bit) for Windows.
2.  No,  I am using LibreOffice 3.5.4.2 Build ID: 350m1(Build:2).
3.  No, the updates to move to the next version have not been released on ubuntu as yet.
Comment 6 Marmel 2012-10-28 15:02:18 UTC
@ Joel - I can confirm this issue. I am seeing the same behavior as described in comment #4.

1) These files have been created in MS Office 2010 SP1 x64.

2) I have tested with LibreOffice 3.6.2 and 3.5.7

3) The result:

   a) with 3.6.2 there is no password prompt and the file "opens" displaying garbled ascii characters.
   b) with 3.5.7 the Filter Selection window opens. It appears LO has no idea how to open the MSO 2010 file format.

As with the reporter I can also open files created and encrypted by older versions of MS Office (2007 & 2003). This bug seems specific to the encryption of Office 2010.

@rolandelferink - You can install 3.5.7 via the LibreOffice 3.5.x stable ppa for Ubuntu:
https://launchpad.net/~libreoffice/+archive/libreoffice-3-5
Comment 7 Alexander Winizki 2012-12-10 10:42:06 UTC
Can confirm this for: LibreOffice LibreOffice 3.5.4.2 
Build-ID: 350m1(Build:2)
Comment 8 tefaa8 2013-01-23 12:22:42 UTC
So what happened with this bug ? This is a major limitation for me since I deal with a lot of encrypted docx files! Please fix it !
Comment 9 Ant 2013-02-10 18:11:22 UTC
(In reply to comment #8)
> So what happened with this bug ? This is a major limitation for me since I
> deal with a lot of encrypted docx files! Please fix it !

Ditto. I just ran into this last night. :(
Comment 10 Rainer Bielefeld Retired 2013-02-20 18:53:32 UTC
This bug has been reported concerning "Filter Selection box appears". Nothing else! Please do not abuse the report for any other problem related to encrypted docx.

I tested for "Filter Selection box appears at any fieopen attempt" (LibO Start Center, Writer, Calc - from Explorer only LibO 3.6.5).

Still [Reproducible] when I try to open document from LibO Start Center with
* server installation of "LibreOffice 3.5.7.2  German UI/Locale [Build-ID: 3215f89-f603614-ab984f2-7348103-1225a5b] on German WIN7 Home Premium (64bit) 
* Server Installation of "LibreOffice 3.5.1.2 English UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit) 

Behavior changes with Server Installation of  "LibreOffice 3.6.0.4  English UI/ German Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit). Still Filter Dialog from Start Center, But Empty document from Writer File Dialog and garbled Spreadsheet from Calc File Dialog.

@all:
Please always improve the Summary line with any new knowledge

@tefaa8, Ant:
unfortunately you cause few minutes additional delay for all bugs with any of these pointless comments.
Comment 11 rolandelferink 2013-02-23 06:41:39 UTC
@Rainer,  the bug is that LO is unable to open a MS office 2010 password encrypted file.  The result of the bug, because LO can't tell what kind of file it is due to the encryption, is that the Filter Selection dialog box is opened instead of simply opening the file after entering a password.

I have now upgraded to LO Version 3.6.2.2 (Build ID: 360m1(Build:2)) and I still unable to open the example file in comment 2 although the behaviour is now different.  Instead of opening up the "Filter selection" dialog box, LO does open the file and displays the binary contents i.e. I am not able to see the text which I know is in the document.

@teefa8 & @ant are simply adding their voices to mine that this is a real limitation that we are experiencing in LO and it really does need to be sorted out.
Comment 12 ign_christian 2013-07-16 02:31:44 UTC
> I have now upgraded to LO Version 3.6.2.2 (Build ID: 360m1(Build:2)) and I
> still unable to open the example file in comment 2 although the behaviour is
> now different.  Instead of opening up the "Filter selection" dialog box, LO
> does open the file and displays the binary contents i.e. I am not able to
> see the text which I know is in the document.

Now that behavior reported on Bug 60343.

Is this bug still valid since changing of original description? 
Or Bug 60343 is a duplicate to this bug?
Comment 13 retired 2013-07-16 10:05:51 UTC
in LO 4.1.0.2.0 on OS X 10.8.4 when trying to open the Test case file, I get an error message:

"Version conflict.
This file exists in a wrong version."

Would be nice to get this fixed. Setting to NEW, since from what I can see there was no code patch or similar.

@Rainer: no bug abuse here, imo.

fdo#60343 is a dupe. As jorendc set 60343 I'm adjusting this bug to that importance states.

Since I can reproduce this with both test files from this bug and from 60343 on OS X, setting OS to "ALL".
Comment 14 retired 2013-07-16 10:07:10 UTC
*** Bug 60343 has been marked as a duplicate of this bug. ***
Comment 15 retired 2013-07-16 10:12:22 UTC
*** Bug 48687 has been marked as a duplicate of this bug. ***
Comment 16 retired 2013-07-16 10:13:44 UTC
*** Bug 66941 has been marked as a duplicate of this bug. ***
Comment 17 retired 2013-07-16 10:40:21 UTC
*** Bug 63614 has been marked as a duplicate of this bug. ***
Comment 18 retired 2013-07-16 10:45:27 UTC
*** Bug 35422 has been marked as a duplicate of this bug. ***
Comment 19 ign_christian 2013-07-16 10:53:52 UTC
James, tested attached file with LO 4.0.4.2 (Win7 32bit) I can reproduce Bug 60343. So LO 4.0 & 4.1 generates different behavior.
Comment 20 Kohei Yoshida 2013-07-16 11:55:42 UTC

*** This bug has been marked as a duplicate of bug 35422 ***