Bug 66941 - FILEOPEN: Problem in opening encrypted DOCX file
Summary: FILEOPEN: Problem in opening encrypted DOCX file
Status: RESOLVED DUPLICATE of bug 35422
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.2 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-15 20:15 UTC by arpitchauhan
Modified: 2013-07-16 12:04 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arpitchauhan 2013-07-15 20:15:21 UTC
Problem description: 
LO Writer was unable to open a DOCX file created in Microsoft Word 2010 and encrypted with AES-128 (by Microsoft Office itself.)

Steps to reproduce:
1. Create a DOCX file in Microsoft Word 2010
2. Encrypt it using AES-128
3. Open it in LO.
[I can't provide a sample file as I don't use Word anymore. And, the file I'm trying to open is private.]

Current behavior:
The message "libreoffice version incompatibility incorrect file version" is displayed in a pop-up.
[In LO 4.0.4 Final or RC2 (which are identical "bit-by-bit"), the Writer opens the file but displays gibberish inside it, not the actual text. No password is solicited.]

Expected behavior:
LO should solicit the password and when the right one is entered, it should open the file correctly.
              
Operating System: Windows 8
Version: 4.1.0.2 rc
Comment 1 ign_christian 2013-07-16 02:08:31 UTC
Looks similar to Bug 60343, perhaps duplicate?
Comment 2 retired 2013-07-16 10:13:44 UTC
Indeed a duplicate, but of 51194.

*** This bug has been marked as a duplicate of bug 51194 ***
Comment 3 Marmel 2013-07-16 12:04:26 UTC

*** This bug has been marked as a duplicate of bug 35422 ***