Bug 63614 - FILEOPEN: Excel 2007 spreadsheet with Agile encryption cannot be opened
Summary: FILEOPEN: Excel 2007 spreadsheet with Agile encryption cannot be opened
Status: RESOLVED DUPLICATE of bug 35422
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 63916 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-16 21:12 UTC by Richard Schneiderman
Modified: 2013-07-16 12:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
password 123456 (15.00 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-04-16 21:12 UTC, Richard Schneiderman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Schneiderman 2013-04-16 21:12:03 UTC
Created attachment 78112 [details]
password 123456

Problem description: 
libreoffice 4.0.2.2 
Steps to reproduce:
Open File
Current behavior:
No password prompt. tries to open corrupt spreadsheet
Expected behavior:
Should get password prompt and valid spreadsheet

I can open the files in issue 92645: code FIXED P3 Cannot open Password protected docx/xlsx Files
              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Jorendc 2013-04-16 22:31:54 UTC
Thanks for reporting!

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 74af27fef6505d4e47b53ea765b9cc4a96629fa (build today).

When I try to open attached document I got this error:

Version Incompatibility.
Incorrect file version.

Therefore I mark this bug as NEW.

@Richard: I forgot to ask on IRC. Can you reproduce this behavior with every file you create and 'encrypt'/'protect' using office 2010? Or is it just this file (and some others)?

kind regards,
Joren
Comment 2 Urmas 2013-04-26 12:57:32 UTC
*** Bug 63916 has been marked as a duplicate of this bug. ***
Comment 3 Urmas 2013-04-26 13:17:54 UTC
This encryption algorithm is default in Office 2010, as it is supported by 2007 since SP2.
Comment 4 Jose Manuel 2013-04-26 13:42:05 UTC
Then is open in the bug-63614 for your solution?

A greeting.

Jose Manuel López
rocholc@hotmail.com


From: bugzilla-daemon@freedesktop.org
To: rocholc@hotmail.com
Subject: [Bug 63614] FILEOPEN: Excel 2007 spreadsheet with Agile encryption cannot be opened
Date: Fri, 26 Apr 2013 13:20:58 +0000


    
      
    
     Urmas
 changed
              bug 63614
        

             
          
            What
            Removed
            Added
          

         
           OS
           Linux (All)
           
           All
           
         

         
           See Also
           https://issues.apache.org/ooo/show_bug.cgi?id=92645
           
           
                
           
         

         
           Summary
           FILEOPEN: Cannot open this 2007 Protected/encrypted Excel Spreadsheet produced in office 2010
           
           FILEOPEN: Excel 2007 spreadsheet with Agile encryption cannot be opened
           
         
      
      
      
      You are receiving this mail because:
      
      
          You are on the CC list for the bug.
Comment 5 Paco 2013-04-26 17:30:47 UTC
*** Bug 63969 has been marked as a duplicate of this bug. ***
Comment 6 retired 2013-07-16 10:40:21 UTC
This is valid on OS X 10.8.4, LO 4.1.0.2.0.

Imo a dupe of 51194.

*** This bug has been marked as a duplicate of bug 51194 ***
Comment 7 Marmel 2013-07-16 12:03:35 UTC

*** This bug has been marked as a duplicate of bug 35422 ***