Bug 48687 - FILESAVE: Silent removal of password protection - .docx format.
Summary: FILESAVE: Silent removal of password protection - .docx format.
Status: RESOLVED DUPLICATE of bug 35422
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: All All
: highest major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-14 05:53 UTC by clayson.pc
Modified: 2013-11-27 13:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clayson.pc 2012-04-14 05:53:50 UTC
Problem description: 

Steps to reproduce:
1. Open a password protected .docx file.
2. Modify.
3. Save.

Current behavior:
Password protection is removed without warning.

Expected behavior:
Either password protection should be maintained or a prominent warning displayed. 

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Jaime Navarro 2012-04-19 02:00:51 UTC
[Reproduced] with "LibreOffice 3.5.2 - Debian 6.0.4 i386 English UI"

Not save the password file format .docx.
Should generate a warning if the password is lost.
Comment 2 Joel Madero 2012-09-10 19:16:31 UTC
Apparently passwords aren't supported for .docx (try to save a document as .docx and you'll see the save with password grayed out). This is a serious problem and I agree should come with a warning of some kind. Marking as NEW and prioritizing.

Priority: Major + Highest both because of security concern
Comment 3 Joel Madero 2012-09-10 19:25:24 UTC
Also CC'ed Michael and Cedric on this one.

Do you guys think this is a Most Annoying Bug? Also, can one of you take care of it or know someone who might be able to?
Comment 4 Michael Stahl (allotropia) 2012-09-11 10:47:40 UTC
what exactly does "password protected" mean here?

if it means "encrypted" then i agree this is a problem that should be fixed.

if it means "password to modify" or something like that then
that is just snake oil anyway and i wouldn't waste my time
implementing that (except for a paying customer :).
Comment 5 clayson.pc 2012-09-11 11:48:38 UTC
The .docx password protection encrypts the file - that's why the silent removal of the protection is important.
Comment 6 retired 2013-07-16 10:12:22 UTC
Is this here a dupe of https://bugs.freedesktop.org/show_bug.cgi?id=51194 ?

I've just tested the other bug. When trying to open a password protected .docx file LO 4.1.0.2 (RC2) spits an error message (which isn't very informative). But that means LO does currently not open any password protected  docx files. So I'm unsure: either this bug is a dupe (see above) or maybe invalid?

Clayson: when I try to reproduce I get stuck at step 1. (see above)

marking this a duplicate, since I'm sure once 51194 is solved this here should be solved as well.

Please re-open if you disagree.

*** This bug has been marked as a duplicate of bug 51194 ***
Comment 7 Marmel 2013-07-16 12:06:34 UTC

*** This bug has been marked as a duplicate of bug 35422 ***
Comment 8 Joel Madero 2013-11-27 13:32:06 UTC
Please don't change the upper section unless you know what we use the fields for. Thanks!